LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware - Installation (https://www.linuxquestions.org/questions/slackware-installation-40/)
-   -   Slackware 10.2 on IBM xSeries 306m (https://www.linuxquestions.org/questions/slackware-installation-40/slackware-10-2-on-ibm-xseries-306m-410456/)

Frogmistress 02-01-2006 12:14 PM

Slackware 10.2 on IBM xSeries 306m
 
I'm trying to install Slackware 10.2 on an IBM xSeries 306m 8849-1AU with 2 SAS/SATA Hot Swappable drives.

I set up the raid array using the Adaptec HostRAID configuration utility.

I cannot, under any circumstances, using any kernel, get Slack to see my array or drives. I have tried with Adaptec's Raid enabled and with it disabled. I have tried bare.i through xfs.s. If they are being detected, I have no idea what Slack is calling them.

Any suggestions, ideas or comments are highly welcome!

lestoil 02-05-2006 12:05 PM

Review of the ibm 306m series shows they support RHE,suse and there are several updates available,including bios,adaptec raid,and other linux specific drivers. Maybe getting needed updates and reviewing a redhat or suse install on your server would help you. Good luck.
See http://www.itjungle.com/tlb/tlb013106-story03.html for mention of E7230 chipset(intel) that has to be recognized by the kernel.

ExplodingTurnip 02-05-2006 02:40 PM

I had the same problems installing on an xseries 226 server. I never got my RAID1 array to work using Adaptec's config utility so I ended up using the raidutils included with Slackware.

From my understanding (from searching Google) the Adaptec RAID adapter included in these servers is actually software based, and that it's better using the raidtools included with Linux. I'm no expert when it comes to RAID but I was better off using Slack's raidtools.

cereal83 02-07-2006 09:22 AM

Have fun, I have asked several questions to this effect with little help because not to many people use these machines. I am trying to get a Adaptec SAS controller working with Slack 10.2 on a IBM x460 with no luck. I installed on a SATA drive and am trying to get it working from there with a driver from http://linux.adaptec.com/sas/index.html hopefully that will help you because now it see's my controller, just not my drives

cereal83 03-06-2006 01:48 PM

Just an update. I got it working. The server was missing a RAID card. I dropped it in and it started to work without issue

Frogmistress 03-07-2006 09:58 AM

Quote:

Originally Posted by cereal83
Just an update. I got it working. The server was missing a RAID card. I dropped it in and it started to work without issue

Congrats on getting it working! Can I get some details on how you used their drivers to get it up and going?

lestoil 03-07-2006 12:47 PM

Funny how often we forget to open the box. If you have time please write a small blurb explaining how you installed and config'd SW10 in HCL or SW forum. Other users/installers would appreciate the help. Congrats and thanx.

phek 03-08-2006 05:40 AM

I just finished installing slackware 10.2 on an xseries 306m. Had to look everywhere for the adp49xx source so that I could create a bootable slackware kernel. Source is located at
ftp://ftp.software.ibm.com/pc/pccbbs...40k8641.tar.gz

I've also posted my updated slackware kernel, a 2.4.31 kernel patch, along with a little bit of documentation at:
http://www.narcopia.com/index.php?ht...le=adaptec9405

If you have any questions about it, let me know.

Eric Kinolik
spam@narcopia.com

lestoil 03-08-2006 11:46 AM

ibm server SW10.2 install
 
phek that for your entry. Could you add same info to the LQ HCL.
This cooperation from users makes SW and LQ more useful. Thanx again:)

phek 03-09-2006 03:11 AM

Just realized that after you install slackware (with the prebuilt sata_adp94xx.i kernel I made), you need to also install lilo with the initrd image from the install cd. I'm guessing that the sata.i config I used didn't have some scsi subsystem driver which this controller needs (since it's an SAS controller instead of a regular SATA). This could possibly be solved by recreating a kernel based off the adaptec.s kernel instead.

Lestoil: I tried to add it to the HCL, but it's not showing up in the list even though it says it was submitted successfully.

cereal83 03-30-2006 10:06 PM

Sorry I never came back and posted what I did but I don't come here often. After I dropped in the raid card, slackware detected it automatically using the raid.s image due to the fact it was a adaptec raid controller. It just worked

johnpelster 04-11-2006 10:36 AM

Thanks for this thread...

I've just about completed my Slackware install on our IBM 306m server. One thing that I had to do some digging to figure out was how to get the Adaptec SAS controller to recognize the RAID-1 array. The solution was to pass "adp94xx=attach_HostRAID:1" as a kernel option on boot. This was documented in the adp94xx source code readme.

Thanks,
John Pelster


All times are GMT -5. The time now is 02:57 AM.