-   Slackware - Installation (
-   -   Slackware 10.0 Network/Internet setup (

Cryptic_K 08-11-2004 11:55 AM

Slackware 10.0 Network/Internet setup
hi all. i have just successfully setup slackware on my box, and i think its cool. but i can't setup my internet for some reason.
i am connecting through a d-link router, but if i run ifconfig, it dosen't tell me my local ip under the inet: thing, only when i was in windows, running ipconfig would tell me that i was but on slackware, it acts as if i'm not on a network. i try to ping, which is another computer thats connected to the router, but it says 'network unreachable'. so because of that, i don't know my local ip, so i can't run netconfig. can anybody help me?

hrp2171 08-11-2004 02:02 PM


First, is your D-Link router handing out IP addresses? Is it running DHCP? Second, did you manually configure the IP address in Windows or did Windows just grabbed that IP address from the D-Link router?

If you don't remember setting up the IP address in Windows manually, then the D-Link router handed out the IP address to Windows.

shilo 08-11-2004 03:27 PM

netconfig. Select dhcp. Done.

Cryptic_K 08-12-2004 11:54 AM

sorry, i'm not sure about the handing out ip addresses thing, but i don't remember setting up my internet on windows.. it was just.. there. as for the dhcp thing, i'm just not sure what to put the values in for.

edit: for the dhcp thing, i just pressed enter because my isp didn't give me anything, but it dosen't work.

hrp2171 08-12-2004 12:30 PM

Ok, then you may have to look at the D-Link router's config interface and double-check the DHCP settings and make sure your Slackware box is not hooked up to the uplink port on the D-Link.

Cryptic_K 08-12-2004 12:46 PM

i'm pretty sure its not, because i used to have windows on the same box, and the internet worked fine, but in slackware, nothing works. and i haven't touched the router box. its a di-604 model box, if that matters.

shilo 08-12-2004 12:59 PM


I have the same router. All that I did was.

1) Hook cable modem/ dsl modem up to the router (Uplink port)
2) Hook computer up to router (Port 1)
3) Run netconfig
4) choose dhcp

You are correct in that you do not need to enter extra information for dhcp. It has nothing to do with your ISP, though. Your computer is not getting an IP address from your ISP, it is getting it from your router. Your router handles getting an IP address from your ISP all by itself. Your computer should receive the IP address, just like it did under windows.

Run netconfig again. This time, write down all of the options and what you choose. Post back and let us know.

Cryptic_K 08-12-2004 04:37 PM

well, i'm pretty sure my computer's connected to the router and everything, and i've tried netconfig, and put cryptick as the host name, then as domain, then selected dchp, then just pressed enter when it asked me for info. but it dosen't work.! i just don't know why i can't even ping my router. does that imply that i'm not connected? does video cards matter? if they do, i'm on a nVidia GeForce.

shilo 08-12-2004 04:44 PM

Video card doesn't matter.

Is your computer dual boot right now? And everything is working from WIndows?

Did you do a full install?

OK, here's what I'm thinking. You probably don't have the module loaded for your NIC card. Run

and post the contents here. What type of NIC card do you have?

gyodai 08-13-2004 11:30 AM

try to do this:

# ifconfig eth0 down
# cd /etc/rc.d/
# ./rc.inet1 restart

My network - with a SiS900 NIC - only works if I do these commands. Why? I don't know.

Cryptic_K 08-13-2004 01:46 PM

hm.. i got everything working fine.. i'm on slackware right now.. i'm not sure why it worked, i just ran netconfig, selected dchp, and pressed enter for everything. then i rebooted.. after that, it worked. i think i didn't reboot the first time, which is why it didn't work. Thanks everybody for helping me!

NumbSkullMD 08-23-2004 06:35 PM

It's probably not necessary to restart your computer. Just do what @gyodai said and restart /etc/rc.d/rc.inet1 as root.


All times are GMT -5. The time now is 10:29 AM.