-   Slackware - Installation (
-   -   Slackware 10.0 - Direct Boot Fails, Cannot Create Linux Bootdisk (

Ffi 07-18-2004 03:20 PM

Slackware 10.0 - Direct Boot Fails, Cannot Create Linux Bootdisk

I'm off to install Slackware Linux 10.0, but when I try to boot it directly (when starting PC to locate boot record on a CD) it doesn't locate boot record (Not found.). Also, I've tried to create bootdisk (to later add install.1 install.2 to it), but I can't do it - MS-DOS fails when I try to use RAWRITE :( So I can't install in this way, as well... Maybe I'm doing it somehow in a wrong way? Also, I've tried to use "loadlin", but I had some problems with kernel.
So maybe someone could suggest me any other ways to install this distribution? Or maybe I'm doing something wrong? Then what?
Thank YOU! I really appreciate any help...:rolleyes:
Sorry if it'll sound you noobish, but... And sorry for my bad english.


nObRaIn 07-18-2004 08:56 PM

hi there,

i was in a similar situation some time ago with my laptop. i used loadlin and it worked great. well... i thing there was something wrong with the instructions on (the guide is a bit outdated) but after finding some details it worked just fine for me.

what exactly was wrong with the kernel?

*edit* about the cd thing. double check the boot settings in bios, and if this is not the original copy of slackware make sure it is bootable.

Ffi 07-19-2004 05:29 AM

I don't remember what was the error when I've executed loadlin :D But now I've decided to search for more information and to correctlly setup loadlin to install Slackware... :rolleyes:

Ffi 07-19-2004 06:52 AM

I've messed up with loadlin... Maybe someone could post a command line (loadlin bzImage ...) how to boot bare.i kernel. It's located on primary Windows partition (goes after swap partition (the 2nd) and the 3rd is Linux ext2 partition), C:\loadlin\bzImage .

Thanks :rolleyes:

Ffi 07-19-2004 07:38 AM

When I use this boot command: "loadlin bzImage rw root=/dev/ram initrd=initrd.img load_ramdisk=1", I've got bare.i kernel executed and initrd.img, as well, but not fully, I've got these errors :

RAMDISK: Couldn't find valid RAM disk image starting at 0.
UMSDOS: msdos_read_super failed, mount aborted.
sh-2021: reiserfs_read_super: can not find reiserfs on ramdisk (1.0)
Kernel panic: VFS: Unable to mount root fs on 01:00

gnashley 07-19-2004 07:41 AM

Did you download the ISO files or which files for installation?

Ffi 07-19-2004 07:47 AM

I've downloaded both .ISO files and burned CDs from .ISO images, so I'm sure that there is no problem with CDs...

By the way, I've got Mandrake 9.1 CDs and they boot directly with no problem... :rolleyes:

Andronik 07-19-2004 11:02 AM

question-is reizer filesystem supported under bare.i
i had somewhere in my mind as it is not.

gnashley 07-20-2004 02:13 AM

Okay, if the CD won't boot, then try again with rawrite and the floppy images. if you are runing winXP you should use rawritent.
Copy rawrite and each floppy image into C:\
then double-click rawrite and it will prompt you for the file name and destination drive.
burn the bare.i image and each of the install disks.

Ffi 07-20-2004 06:48 AM

Nevermind, friend burned me a CD with no problems (boot sectors has been written).

All times are GMT -5. The time now is 06:35 AM.