LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - Installation
User Name
Password
Slackware - Installation This forum is for the discussion of installation issues with Slackware.

Notices


Reply
  Search this Thread
Old 09-16-2004, 04:23 PM   #16
kersten78
Member
 
Registered: Nov 2003
Location: Minneapolis, MN
Distribution: Slackware, Debian, Gentoo, openSuSE
Posts: 358

Original Poster
Rep: Reputation: 33

Hey, mel82, thanks for the input. I think I may be getting closer to the problem. I changed my slackware mouseconfig settings back to the regular ol' PS/2 to get my touchpad working, to see if I could get the usbmouse added afterwards.
I looked at my rc.gpm file and it DOES have the line:
/usr/sbin/gpm -m /dev/mouse -t imps2
So I checked out my lsmod. Even with the touchpad working under the PS/2 settings, there is no psmouse module loaded...and even more strange, even though the usbmouse is not configured, the usbmouse module is loaded (although it is listed as Used by: 0 (unused). And usbmouse is listed under both the input and usbcore modules.
So I tried to load the psmouse module just to see what happened...
modprobe: Can't locate module psmouse
Maybe I'll redo the slack mouseconfig for my usbmouse and see if anything changes. Who knows. Anyone ideas?
 
Old 09-16-2004, 04:46 PM   #17
mel82
LQ Newbie
 
Registered: Sep 2004
Posts: 29

Rep: Reputation: 15
Ok. Your ps2 support is included in the kernel, the usb not, but you see it loaded, so that is not a problem.
Nothing out of the ordinary.. That's normal.

check if "lsusb" show your usb mouse.
It surely do. If it does not (but I don't think so) at least that gave us a way..

The strange thing is that you don't need any other setting to have them both working.. It sounds very strange to me..
I have the same gpm settings and they works..

And now.... (....drums...) Now the stupid question: have you tried to move both the devices BEFORE starting X? they will work as soon as your gpm is loaded, if they are well configurated ..

Does your system load the gpm as startup? If not try to load gpm manually.
/usr/sbin/gpm -m /dev/mouse -t imps2

post an "ls -l" of all the symlink and devices that you see under /dev that seems a mouse (psaux, mouse, etc..)

Last edited by mel82; 09-16-2004 at 04:48 PM.
 
Old 09-16-2004, 05:38 PM   #18
kersten78
Member
 
Registered: Nov 2003
Location: Minneapolis, MN
Distribution: Slackware, Debian, Gentoo, openSuSE
Posts: 358

Original Poster
Rep: Reputation: 33
OK. I've got some info for you.
Code:
bash-2.05b# ls -l /dev/mou*
lrwxrwxrwx  1 root root 5 2004-09-16 17:25 /dev/mouse -> psaux
bash-2.05b# ls -l /dev/ps*
crw-rw----  1 root sys 10, 1 2004-09-16 17:28 /dev/psaux
bash-2.05b# lsusb
Bus 001 Device 001: ID 0000:0000
Bus 001 Device 002: ID 0461:4d03 Primax Electronics, Ltd Kensington Mouse-in-a-box
Note that this is with my touchpad working--no usbmouse.
Also, from console, only the device configured with "mouseconfig" works under gpm. I can run mouseconfig, switch to usbmouse, and run rc.gpm restart and then BOOM the usbmouse is working.
And then whichever device is active is the one that works in X. I'll try activating my usbmouse and see if the symlink for /dev/mouse changes.
 
Old 09-16-2004, 05:45 PM   #19
kersten78
Member
 
Registered: Nov 2003
Location: Minneapolis, MN
Distribution: Slackware, Debian, Gentoo, openSuSE
Posts: 358

Original Poster
Rep: Reputation: 33
After running "mouseconfig" in a terminal window, setting the mouse to type usb, and then running rc.gpm restart, I have:
Code:
bash-2.05b# . /etc/rc.d/rc.gpm restart
Restarting gpm...
bash-2.05b# ls -l /dev/mouse
lrwxrwxrwx  1 root root 10 2004-09-16 17:37 /dev/mouse -> input/mice
Funny, my touchpad is still the only one working in X, but I'm sure if I log out, my usbmouse will suddenly become active on the console.
 
Old 09-16-2004, 06:06 PM   #20
kersten78
Member
 
Registered: Nov 2003
Location: Minneapolis, MN
Distribution: Slackware, Debian, Gentoo, openSuSE
Posts: 358

Original Poster
Rep: Reputation: 33
PROBLEM SOLVED!!
Thanks mel82. That advice on checking the symlinks solved the whole problem. I just decided to forget the gpm for the minute and look at my xorg.conf file again. Since whatever /dev/mouse was pointing to was the active mouse under gpm, I just changed the "Device" option in my mouse sections.
My PS/2 (touchpad) now reads:
"Device" "/dev/psaux"
And my usb scroll mouse now reads:
"Device" "/dev/input/mice"

I then added the line
"InputDevice" "mouse1" "AlwaysCore"
to the Server section for my usb mouse (thanks to lupin) and that's all it took...

Now I can mouse with both hands!!! heh.
Thanks everybody.
-Kris
 
Old 09-16-2004, 09:59 PM   #21
mel82
LQ Newbie
 
Registered: Sep 2004
Posts: 29

Rep: Reputation: 15
Rally oh!
 
Old 09-16-2004, 11:13 PM   #22
kersten78
Member
 
Registered: Nov 2003
Location: Minneapolis, MN
Distribution: Slackware, Debian, Gentoo, openSuSE
Posts: 358

Original Poster
Rep: Reputation: 33
Man, slack is fxxn fantastic. But now it's working like it should... I need a new problem. Thanks again for the help everybody.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how to use touchpad and mouse simultaneously? sorno Linux - Laptop and Netbook 4 09-01-2004 03:00 PM
having both Snaptics touchpad and external mouse available simultaneously Danathar Linux - Laptop and Netbook 5 08-29-2004 03:31 PM
use usb mouse & touchpad Together on laptop mehargags Slackware 13 08-01-2004 11:09 AM
Touchpad and USB mouse simultaneously? Pathian Linux - Hardware 0 01-07-2004 12:18 AM
USB mouse + touchpad working simultaneously stevenhasty Slackware 1 07-26-2003 07:11 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - Installation

All times are GMT -5. The time now is 02:40 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration