-   Slackware - Installation (
-   -   Slack 10, laptop, touchpad and usb mouse simultaneously? (

kersten78 09-09-2004 09:25 AM

Slack 10, laptop, touchpad and usb mouse simultaneously?
Hello everybody.
I'm sure there are threads about this, but in all my searching, I couldn't find anything that would work for me. I just installed Slack 10 a few days ago, switching from Mandrake 9.2 via Mandrake 10. In both the Mandrake distributions, my touchpad and usb mouse would be configured automatically, with both devices functioning simultaneously. I can't seem to figure out how to do this with Slack10. I can get both devices working separately, but I'd like to have them both active. Is this possible? If so, can anyone point me in the right direction? The usb mouse is also a wheel mouse, and I'd like to get that working too...but I'd rather get both devices running before I move on to the wheel problem.

lupin_the_3rd 09-09-2004 10:40 AM

For the wheel... insert this under your usb mouse config:

Option "ZAxisMapping" "4 5"

Also, my usb and touchpad both work at the same time and I just have this one entry for mouse... here is my setup from xorg.conf:

Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "PS/2"
Option "ZAxisMapping" "4 5"


kersten78 09-09-2004 02:15 PM

I'm at school right now, but I'm 99% positive that I have the exact same mouse section in my xorg.conf file...I'll have to check when I get home. Oh wait a sec... I was having trouble detecting my monitor, so I ran xorgsetup. I wonder if that changed my mouse settings. I'll have to check the conf file. Thanks lupin, I have a feeling my mouse settings were changed with xorgsetup. I didn't have it working before I ran xorgsetup, but I didn't really have any way to check since X wouldn't start. At least I have a place to start now.

SBing 09-09-2004 03:08 PM

Yes, just to point out when you run xorgconfig you create a new xorg.conf file - this contains (among other things) your input settings, so these would have gone back to whatever you set up them up as during xorgconfig :)

lupin_the_3rd 09-09-2004 04:20 PM

pretty sure it's the ps2 protocol that makes them both work at the same time...

kersten78 09-09-2004 05:21 PM

Ok. xorgsetup did write a new xorg.conf file, so I had to change the mouse section. It had set the protocol to "Auto", so I first changed it to "IMPS/2" because I heard that it was necessary to use the scroll wheel. I also added the ZAxisMapping option and BOOM, usb mouse with scroll wheel is fully functional. However, no touchpad. So I tried protocol "PS/2". Evidently, IMPS/2 is necessary for the scroll wheel because I lost the scroll wheel with the PS/2 protocol, and still no touchpad.
I think the problem may be with my Slackware config rather than with my X settings. I can run pkgtool and change the mouse settings to activate either the touchpad OR the usb mouse on boot with the option that allows mouse activity on the command line (can't remember what the option was called). But unfortunately, it is either/or. I haven't been able to get both devices running at boot, so I think that is where my problems are originating. Currently I have the usb mouse active on slack boot, so maybe I'll try resetting the config to activate the touchpad and see if X will add the usb mouse. If anyone has any suggestions in the meantime, please let me know...

kersten78 09-09-2004 05:39 PM

Well, I changed the slack settings back to PS/2 and the touchpad if working again, but no usb mouse. Also, I had to switch my xorg.conf mouse protocol back to "PS/2". The IMPS/2 setting for X wreaks total havoc on the touchpad. It was kinda funny--I'm surprised I made it out alive.
Unfortunately, this basically confirms my suspicion that the problem lies in my Slcakware mouse config. I can only use the mouse that was activated at boot, no matter how I set up my X config. Unless allowing the mouse to become active at boot on the command line somehow prevents X from detecting both devices. Maybe I'll try doing away with that option and see what happens. Lupin, how do you have the mouse configured in the Slack settings? Are you using whatever option it is that brings up the mouse at the command line? Thanks again for all the help everybody...I'm a lot closer to getting this working than when I started.

kersten78 09-09-2004 06:01 PM

Good I go again flooding a thread with senseless rambling.
I was poking around (the program that activates the mouse at boot for command line use is GPM--there's a file /etc/rc.d/rc.gpm) and I looked in the rc.gpm file. It showed the lines for activating the mouse at boot, even after I had supposedly turned the feature off. There was also an interesting comment at the end about making GPM act as a repeater for use with X.... I'm really pretty clueless--still a newbie, but I think this may be the solution.
Anyway here's the comment...if anybody can make more sense of it that I can, please let me know if this is maybe what I'm looking for.

# There is another way to run GPM, where it acts as a repeater outputting a
# virtual MouseSystems mouse on /dev/gpmdata.  This is useful for feeding
# gpm's data to X, especially if you've got a busmouse (in that situation X
# and gpm may not coexist without using a repeater).  To try running a GPM
# repeater for X, change the gpm command line to look like this:
# /usr/sbin/gpm -R msc -m /dev/mouse -t ps2
# Then, make sure that the mouse configuration in your XF86Config file refers
# to the repeater device (/dev/gpmdata) and a MouseSystems mouse type.  If you
# edit the file directly, you'll want the lines to look like this (minus the
# comment marks '#' shown here, of course):
#Section "Pointer"
#    Protocol    "MouseSystems"
#    Device      "/dev/gpmdata"

If anyone can steer me in the right direction, please let me know...Any help would be greatly appreciated.
PS I just had one more thought upon rereading the above comment. Is it possible so add another Mouse section to my xorg.conf file for the usb? Or would it really screw things up to refer to two different mouse devices? Thanks again.

lupin_the_3rd 09-09-2004 07:16 PM

I don not use gpm at all on my setup...and I left out part of my setup above... I do have two mouse sections... here's the second mouse section:

Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "PS/2"
Option "Device" "/dev/input/mice"
#Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"

and add this to your InputDevice section (at the end of the slack xorg file)
InputDevice "DevInputMice" "AlwaysCore"

my whole section looks like this:

InputDevice "Mouse1" "CorePointer"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "DevInputMice" "AlwaysCore"

kersten78 09-11-2004 12:02 AM

Man, I'm having nothing but problems. I tried adding another mouse section using the /dev/input/mice device. Nothing. So I tried adding the "InputDevice" section like yours, and I get an error starting X telling me that "InputDevice" is not a valid keyword in this section...not exactly what it says, but it's close. It's not letting me use the "InputDevice" tag in a section titled "InputDevice" which seems logical. But I don't know how else I would specify the core devices.
I think the problem is with my mouseconfig in slackware itself, not in the X config. No matter what I do when setting up the mouse using mouseconfig or pkgtool, I can only choose 1 device. It's either PS/2 which activates my touchpad, or usb, which obviously activates the usb scroll mouse. I can't get both devices active on boot, which is probably why I can't get both of them running in X. If slack doesn't know there's a touchpad, then there's no way for X to start it... same deal with the usb... I have a feeling that until I get the Slack config to correctly recognize both devices, there's no way I'm going to get X to magically start a device that doesn't even exist according to slack... <frustration> I guess that's what keeps me coming back.... Anyway, if anybody has any ideas for slack config, let me know...I need all the help I can get with this one.

kersten78 09-11-2004 12:56 AM

Well, I've narrowed it down a bit. It is without a doubt a Slackware issue, and not a configuration problem with X. No matter what I have set in my xorg.conf file, X will only start the mouse device that I have set up through mouseconfig in Slackware. I've read some posts about trouble with 2.6.7 and running both devices. It sounds like 2.6.8 fixes it. What's weird is that I was running Mandrake 9.2 with 2.2.24 and both devices worked on installation. So I'm guessing that 2.4.26 should be fine for running both devices. I went into my rc.modules file and uncommented the lines that load the usb host support, usb mouse support, and the usb event handler for mouse. No change, even though there were some new messages at boot saying that usbmouse drivers were loaded, etc, etc... I can still only use the device that is selected with mouseconfig in Slackware. Anybody have any suggestions?

stevie_velvet 09-11-2004 11:44 AM

For all Laptop ownes with trakpoint pointers (e.g. Thinkpad owners) :
tha vast majority of sponataneous moue movements with the sensitivity degradeation of the trackpoint (try repositioming it with you hands and leave it for a week ~ worse case = replace the keyboard). If you pointer moves everyday, try diabling the trackpoint ans see if it stops ~ you'll be surprised

For everyone else:
check for spyware & ensure you anti-virus is up-to-date

kersten78 09-14-2004 07:14 AM

If anyone has both devices working with Slack or any other distro, would you mind posting your xorg.conf? I don't really want to dump everything to go back to Mandrake 10, but I'd like to see the difference in the xorg.conf files since both devices worked without a hitch on Mandrake 10. :scratch:

mel82 09-14-2004 04:02 PM

[auto-removed post.. I missunderstood the problem.. Sorry]

mel82 09-14-2004 04:20 PM

You were right.

Your problem is in the gpm.

Your mouses have to work both right from command line.
If it is not, then I fear you have no choices to get them running under X before you fix it on the shell.

/usr/sbin/gpm -m /dev/mouse -t imps2
is the right command line to have both the mouses working together.
Check if your /etc/rc.d/rc.gpm have that line.

If yes assure you have both the modules loaded.
lsmod | grep -E "usbmouse|psmouse"

If not, load then by
modprobe psmouse
modprobe usbmouse

and restart the gpm with
/etc/rc.d/rc.gpm restart

I hope this will help =)

All times are GMT -5. The time now is 12:31 AM.