-   Slackware - Installation (
-   -   Running 13.37-64 help w/ alien's kdtown rsync (

NightSky 12-27-2013 06:41 PM

Running 13.37-64 help w/ alien's kdtown rsync
Running 13.37-64 w/ kernel What is the latest KDE version I can build for my version of Slackware? Currently KDE 4.5.5 is running. Would be happy with KDE 4.6.1.
Tried to use

# rsync -av rsync://
Returned Errors: rsync: get add info: 873: Name or Service not known
rsync error: error in socket 10 (CODE 10) at client server.c (122) [Receiver=3.0.8]
error: bandwith Cap Limit try another mirror.

Also tried to first:

mkdir 4.6.5
cd 4.6.5

Then issue the rsync command line above & got similar errors.

I've read & printed Readme File.
Read & Re-read:

Regarding dependencies- Can these dependencies exist side-by side with older ver. of stable slackware 13.37-64 (which has been updated but not to current)

Your help is appreciated everything i do on slackware is still a big learning experience. Thank you.

NightSky 12-27-2013 11:40 PM

Where do I put:

mkdir 4.6.5
In /home/user/ ?

Drakeo 12-28-2013 07:18 AM

for the cap limit it means just that that website has reached the amount of band it is allowed to use
!!!!!!! I just tried this and it worked. !!!!!!!!!!!
as normal user in xfce4 or flux box. create a folder kde-4.6.5 then cd kde-4.6.5 open a termianl there
and do this

lftp -c 'open ; mirror -c -e x86_64'
this will down load all. then assume root and install as as below.

how I do it I just log in as root create a kde-4.6.5 folder cd the kde-4.6.5 folder open a terminal there run the rysnc then after it is all done downloading. you will have a copy of that repo. you will have x86 and the x86_64 . cd your kde-4.6.5/4.6.5/x86_64
I always install the dependencies first.

cd deps and run upgradepkg --reinstall --install-new *.t?z
then I

cd kde and run upgradepkg --reinstall --install-new *.t?z
if you need another language to be installed then install the kdei. same way

little tip I usually do this from fluxbox or xfce4. and read the readme you may have to uninstall stuff.
I hope this helps
you are the master of your computer it doesn't matter where you tell the rysnc program to download the software. just that you need to be root to install it.

NightSky 12-28-2013 12:27 PM

Thank you Drakeo.. as root when u create kde-4.6.5 you leave it in root directory?
What is the rsync command syntax you use? I tried different syntax but it didn't work.
I'm downloading now using Xfce lftp in terminal. (I prefer XFCE.) Guess its best to download to /home since it is a huge partition. I've never used KDE. Friend wants it so might, as well, check it out.
How long is the download time? lol

NightSky 12-28-2013 07:01 PM

Drakeo - Completed the dependencies but a couple of errors occurred- they flashed by to quickly.
How can I check what dependencies installed?
I know 'Upower' did not because it did not exist to begin with? There was one more dep that did not install for sure probably because it did not exist either to begin with.
So I won't proceed with the kde upgrade until I find out what dependencies failed to install.

Thank you

Drakeo 12-28-2013 10:07 PM

for just installing not sure what error you could get.
alien Bobs install is pretty much to the point. I installed it today on one of my slackware 13.37 I keep for compiling programs with the older glibc.


Thank you Drakeo.. as root when u create kde-4.6.5 you leave it in root directory?
if you create it as root I would leave it in /root if you create it as a user then yes /home/user-name
yes just when you run rysnc little info the 4.6.5 is done ! end of maintenance and has gone to 4.7 in latest.
if you want to run the latest then may be.
the reason you may want to run a rysnc for the kde is if your running the latest and there is changes to it.
as far as that server not allowing rysnc drop an email to alien bob.
or start a thread in here Eric will see it.

NightSky 12-29-2013 10:42 AM

Got rsync to work last night, this isn't my computer and will copy to flash drive. Here is command line that worked for rsync:

#rsync -av rsync:// 4.6.5
No forward slash between kde/version... Now I have the README Files that warn about using in non-current slackware64-13.37. Going to run

upgradepkg --reinstall --install-new*.t?z
Drakeo - It seems logical that I ought to run

installpkg-new *.t?z
for dependencies that are not installed?
You mention the end of life for kde 4.6.5 - I'm confident w/ Slackware64-13.37 to keep learning fine tuning lib & upgrading on it.
Thank you I now understand the function of rsync now which I wanted to learn as part of running a local mirror;)

NightSky 12-29-2013 10:54 AM

Should have posted the dependencies that were previously not on system & failed to intall:
libdbmenu-qt, sip,grantlee, libatasmart, libbluedevil, upower, libshh, sg3_utils, & udisk? Will try the #installpkg command on these. I vaguely remember reading that previously not install packages won't install under #upgradepkg ..

NightSky 12-29-2013 12:52 PM


upgradepkg --reinstall --install-new x86_64/deps/*.t?z
Worked. The problem was the folder from which I issued the command. Originally I was in /deps when I issued the upgradepkg command.
So kde-4.6.5 installed and appears to working fine in Slackware64-13.37 Seems a bit snappier than 4.5.. Wonder if I'll try kde 4.7 on same os version... Thank you Drakeo

All times are GMT -5. The time now is 09:56 PM.