-   Slackware - Installation (
-   -   Promise FT376 SATA Controler on Slack9.1 (

KoldFusion 02-03-2004 09:32 PM

Promise FT376 SATA Controler on Slack9.1
ok, I have an MSI KT4 Ultra-SR with a Promise Fasttrack 376 Serial ATA controler onboard. I managed to find a "dirty" module that seems to work well enough with it. I was able to put the module onto a floppy and load it into memory ok when I am installing slackware. I copy it to /lib/modules/2.4.22/kernel/drivers/scsi and edit the rc.modules file to try to load the module with no luck. I have also tried several other options with out luck either. How would I load this driver so I can boot my system? Any help would be really greatly appreciated! Thanks!

Jojef.K 02-04-2004 07:11 AM

You'll have to make your own initrd (INItial RamDisk). This file contains a virtual filesystem and a script called linuxrc which loads all the requiered modules for booting. I have a Promise 20276 ATA Raid controller and faced exactly the same problem as you and the solution proposed solved all my problems. Unfortunatelly, Slackware unlike other distros doesn't contain a mkinitrd script and you have to do this by yourself. Look at the kernel documentation for details or give an e-mail and I'll send you mine :) . All you have to do to make it work is to replace my module with yours and modify the corresponding line in linuxrc (eg instead of insmod FastTrak.o write insmod SerialATA.o).

KoldFusion 02-04-2004 06:29 PM

Hey, Thanks for the advice. I tried to mount the initrd file by inputing "mount -o loop /dev/initrd /data" after creating a folder called dada so that I would be able to alter the files on the initrd image. Every time I did so, I would get "no such device" error. If you could just point me in the correct direction I would be very greatful. Again, thanks for the help

Jojef.K 02-05-2004 07:59 AM

Which is the file system of your initrd ? Is it ext2 ? Mine is ext2 so I give the command "mount -t ext2 -o loop /path-to-initrd/initrd /path-to-mount-point".

id10t 02-05-2004 10:26 AM

I'm having the same problem with my Promise 376 onboard controller. I got the driver working on installation but don't know how to get the thing to use the driver when I boot. But anway, above I saw "initrd" being in /dev/inird, and I could have sworn I saw this in the /etc folder... but I guess that may have been a config file.

Jojof.K-- I sent you an email about that script and never got a reply... Just wondering if the one you have inyour profile at LQ was what you meant.

One more question... Would putting the driver in /lib/modules/2.4.22/kernel/drivers/scsi be the standard way of solving this problem? Because I have yet to try that.


KoldFusion 02-05-2004 01:57 PM

Hey id10t, Thats what I tried initally, with no success. I think the way jojef.k sudjested is probably the only way. Oh, the file in /etc you are probably thinking of is inittab. This controls a few startup related items but is not what we are looking for.

Jojef.K 02-05-2004 05:15 PM

id10t, I guess you've sent the email to my hotmail account which I don't check regularly (I get a lot of chunk over there). Check your email now :) .

id10t 02-05-2004 06:39 PM

OK booting of a boot disk... followed your instrution... Got the driver in and the harddrive mounted to /sda I made sure I made all of the changes to the hard drive on /sda and not my boot disk.

The problem is when I get to the end. I am trying to run lilo. so I cd to /sda/sbin/ and type
and it can't find the lilo.conf. No problem:
./lilo -C /sda/etc/lilo.conf
then I get
"Fatal: creat /boot/boot.0810 No such file or directory"

Is there another switch for lilo that I need to throw in there?

EDIT: And I forgot to say how much I appreciate the help. I have so many people giving me trouble over this server being down (Runs a Counter-Strike server for the school)

Jojef.K 02-05-2004 07:51 PM

That's a problem I encountered too but I can't give a "clean" solution to this. I happen to have a Suse 8.2 dvd and I booted into Slackware using it! From there I normally ran lilo and voila! Slackware booted ever since. Maybe some more experienced guy could give us an answer to this (hey, I am not a connoisseur either :D ) ?

KoldFusion 02-05-2004 11:40 PM

ok, this is where I stand. I have attempted to mount the initrd file using every possible combination I could think of. I am on an ext3 so I typed in (after chrooting into where I had the drive mounted) mount -t ext3 -o loop /dev/initrd /mnt. no luck. tried ext2 and ext and a verity of other file system options. Still gives me the same error that /dev/initrd cannot be found. I did some research on it and found some information that is rather usefull if I were doing just about anything else. Any way... enough of my mad ramblings, do you know of any other way I can go about altering this file?

Jojef.K 02-06-2004 07:31 AM

Usually initrd is compressed with gzip. Have you tried to uncompress it and then mount it ?

KoldFusion 02-06-2004 08:57 PM

It says it isin't a regular file. Where is initrd stored on your computer? Mabe I am at the wrong location...

id10t 02-06-2004 09:29 PM

It worked! Booted into Slack 9.1 runnng happy. If you want my initrd file, email at You can jusrt copy that file into your /boot folder and run lilo.

Jojef.K 02-07-2004 02:07 PM

id10t , how did you manage to run lilo after all ?

id10t 02-08-2004 12:25 AM

/<mounted HD>/sbin/lilo -r /<mounted HD/

If oyu want the exact oen I used, it was.

/sda/sbin/lilo -r /sda/

Thank you for all of your help. I am so greatful.

All times are GMT -5. The time now is 05:47 PM.