-   Slackware - Installation (
-   -   nVidia Geforce Graphics Driver Help (

Toods 12-12-2005 02:23 AM

nVidia Geforce Graphics Driver Help
I'm fairly new to Linux and have been installing Slackware 10.2. Each time I installs it defaults to a 'Vesa' driver. I have had many attempts (and fresh Slackware intalls) to install the nVidia drivers provided for download on the nVidia site ( without success. Each time when I run 'StartX' I get a few coloured dots on the screen and all is frozen. I have made the necessary modifications to the xorg.conf file and tried many of the suggestions posted on this and other forums without success.

What I would like to try now is to replace the 'Vesa' driver with the 'nv' driver that is apparently included with the distribution.

How can I 'force' the use of the 'nv' driver?. Is it simply a case of modifying xorg.conf?. Can I do it by running 'xorgconfig' and in this case which of the drivers would I select?.

Thank you.


bp12345 12-12-2005 05:41 AM

When you install X, it should give you a screen saying something like 'choose how much you want to configure' with 'simple', 'medium', and 'advanced' as choices. If you select 'medium', I think you should be able to choose the driver yourself and maybe select other options that you need. I once had a problem where X tried to use too big a screen resolution, and it didn't work. If 'medium' doesn't work, try 'advanced', but for that you will need to know even more about your monitor and graphics card.

Toods 12-12-2005 05:50 AM


Thanks for your reply - very interesting.

In the slackware installation, I was never offered any options to configure X at all and I have recently installed it several times.

Is there a command that I can run on my installation to invoke the "install X" commands that you refer to?.

Thank you,


heltreko 12-12-2005 07:08 AM


You can either edit /etc/X11/xorg.conf by hand or use some scripts. Try xorgconfig which asks you several questions. Or xorgsetup which is supposed to be more automatic.

I often prefer edititng xorg.conf try startx and look in /var/log/Xorg.0.log

Good luck!

All times are GMT -5. The time now is 02:31 PM.