-   Slackware - Installation (
-   -   No sound on a fresh Slackware install (

tanaselia 03-31-2005 01:17 PM

No sound on a fresh Slackware install
I've just installed Slackware 10.1, but I get no sound. I have an on-board SiS Audio hardware. It's odd, because a few days earlier SLAX was running smoothly from my CD-ROM, but this 2CD distro won't play my sound...
Whta sould I do?

xowl 03-31-2005 03:00 PM



as root

tanaselia 04-01-2005 03:02 AM

already tried...
Already tried alsaconf as root, it detects my SiS card, says that it is OK, it is configured.
But still no sound.
When I run alsamixer, (alsaconf tell me that), i get 'no elems' messege, and STILL no sound...
Also looked in modules.conf, some SiS stuff there too... Also, in asound.state all seem ok...
Please help...

richikiki 04-01-2005 08:35 AM

Could you give us more information about your system the exactly hardware that you have, in order to compile as module the driver of your sound card.

well they are 3 ways to configure it:
1) Making a new kernel
2) Just compiling the module for your kernel
3) Using Alsa drivers.

I prefere the 2nd option

Cheeeers !!!

tanaselia 04-01-2005 08:55 AM

Well, I have a SiS630/730 chipset, with modem, LAN and sound onboard. When I start alsaconf, after searching the data base, it says that he found something called 'trident SiS bla-bla-bla' (cant' remember right now the exact message, but it was correct). Them alsa said it's all configured, but no sound after that.
I prefere not to cmpile my kernel. As simple as possible... please.

heltreko 04-01-2005 10:09 AM

Make sure the sound is not muted in alsamixer.

It took me a while to understand the "M" in there...

tanaselia 04-01-2005 10:24 AM

But my alsamixer doesn't start! It says that 'no elements found'.
How cand I un-mute it, if it didn't even start?

dan_slack 04-09-2005 03:24 PM

Take a look at:

Good luck!


richikiki 04-09-2005 09:32 PM

Hi tana,

This is what I suggest for you:

1) As root tipe:
# lspci
and post your message here. Just for to be sure,

2) Try to download the latest version of ALSA.

Here we go: in the page

As you can see the latest version

# cd /usr/src/
# mkdir alsa
# cd alsa
# wget
# tar xvzf alsa-driver-1.0.9rc2.tar.bz2
# cd alsa-driver-1.0.9rc2
# ./configure --with-kernel=/usr/src/linux --with-oss=yes --with-cards=all

NOTE: you can use './configure --help' to see more options and just compile your card in my case that is an intel card i just put '--with-cards=intel8x0'
# make
# make install
# reboot
Now try alsaconf as root in order to configure automatic your /etc/modules.conf
# alsaconf
Now adjust your volume and etc :D
# alsamixer

Yupiiii !!! enjoy it baby :D, Linux el mejor sistema heee.

I did that and now my sistems rocks heeeeeeeee !!!!!!!!!

amos 04-23-2005 11:45 PM

Open something like aumix and try unmuting all of the channels.

If you're still having no luck open the "Sound System" part of the Control Centre, go to the second tab labelled Hardware, where it says Select the Audio Device there should be a drop down box to the right of this. Try each of the options there (you may have to restart the sound server each time I can't remember) this worked out of the box under Slack 9.1 and 10 without Kernel recompiles (as long as the Kernel is newer than 2.4.20 or 21) for SiS 7012 onboard sound.


amos 05-08-2005 03:27 PM

Well that's just typical, I now find this doesn't work for Slackware 10.1!

But not until after I've changed the motherboard of my desktop machine to one with SiS 7012 because it works for my laptop. Except that as I've upgraded that to 10.1 as well I now have no sound on the laptop either.

Maybe I'll have a look at a 2.6.x kernel and see if that gives me any luck.

Let me know if anyones solved this.


xetra 05-14-2005 04:51 PM

What are you using to test sound? If you are using something like xmms, make sure it's loading the correct drivers. Sometimes it will load OSS insteal of alsa.

XavierP 05-14-2005 04:54 PM

Couple of things I've had to do:
in /usr/rc/alsa/alsa-driverxxxx run ./snddevices prior to doing the chmod'ing
mute the Headphone Jack Sense option in alsamixer

xetra 05-14-2005 06:13 PM

chmod 755 /dev/dsp
chmod 755 /dev/mixer

amos 05-15-2005 11:05 AM

Have recompiled with kernel and spent two days compiling bits in as modules getting rid of bits etc, all to no avail.

I was seriously debating downloading ALSA and compiling it separately, so I looked at the link for ALSA that richikiki posted:

and searched for my card - SiS 7012
there are two listings for it, the second one for the SiS 740 Northbridge chip seemed like the best bet as my motherboard has a SiS 741GX Northbridge chip.

Whilst reading the notes on the resulting page:

I found this at the very bottom:


Miklosi Attila
Wednesday, 21 April 2004

EPOX 8RDA3+, CMedia Audio Chipset

Alsa 1.04 i8x0 audio driver works well, but:
after sucking for half a day, I figured out, that
beside you unmute PCM, you have to mute the IEC958 Capture
Monitor, else there won't be any sound.

Hope it helps someone.
Going into alsamixer I muted "IEC958 Capture Monitor" and Robert is most definitely my mother's brother.



All times are GMT -5. The time now is 09:47 PM.