-   Slackware - Installation (
-   -   No mouse cursor in KDE (

EldonCool 05-23-2013 01:46 PM

No mouse cursor in KDE
I just installed slackware 14 (32 bit) and when I go into X windows by running "startx", everything works except that I have NO MOUSE CURSOR showing. It is invisible, so I don't know what my mouse is pointing at. I can somewhat navigate by guessing where it is pointing, like I can get the menu of things from the bottom left of the screen and then select menu items that are high lighted by using the up and down arrows on my keyboard.

Anyone have an idea how to get my mouse cursor to show
up? I have been able to get some mouse functions on screen, but cannot do much with them, because they seem to require a mouse to do anything with them, and
my mouse just is not letting me do much since I can't figure out what it is pointing at. Like I can get into the help function, you have to click
on the word "Mouse" to read about it, and of course
I can't click on it, because the mouse is not cooperating.

If I can't get KDE to cooperate, maybe I can do startx with another windows manager, but I have forgot how you startx with other window managers.
I thought maybe I could do "startx fwm2" and maybe
get it to run with favorite windows manager number 2 that I was able to do on my last installation,
slack 13, but this one is not cooperating.
So how do I get it going with a different manager than KDE, or how in hell do I get my mouse cursor
to show up with KDE?

EldonCool 05-23-2013 02:14 PM

problem solved
After initially trying to fix this by getting into
the mouse cursor theme, and navigating by using
Alt and Letter commands, it never cooperated at
changing the mouse color, which I tried to change
to red. I figured the mouse must be the same color
as the screen background, and that is why I could
not see it. Anyway all attempts failed and I posted
this using Windows where my mouse works.

Next I rebooted linux, and logged in as root, and then
did "startx". This time my mouse showed up. I exited
as root and logged in as my regular user name and then
my mouse worked and it was also red, the last color
I tried to change it to, back when I could not see
any mouse.

So it looks like, maybe running the X windows as root,
or either a reboot of the system straightened things out.

All times are GMT -5. The time now is 08:44 AM.