-   Slackware - Installation (
-   -   Minor issue with CUPS install and "Encrypted root" setup instructions. (

slackin1stimer 01-19-2013 01:21 AM

Minor issue with CUPS install and "Encrypted root" setup instructions.
I am still fairly new to Slackware and have only done an install with Slackware 14 64-bit. I did a bit of googling on both the issues I had but found little.

RE: CUPS--The program works as it should but for some reason the install process omits the "/etc/rc.d/rc.cups" file. I tried a direct "installpkg" from the dvd I burned but no luck. Oddly enough though I can "explodepkg" and get the rc.cups file. Problem solved but cause still a mystery to me.

RE: "Encrypted root"--I meticulously followed the instructions included on the DVD but always got stuck at the same point in the boot process. I did SIGNIFICANT Googling to try and find a solution but to no avail. The README_CRYPT.txt leads one to a lilo.conf entry including the line "root = /dev/mapper/cryptroot" which did not work for me. However, by changing the line to
"root = /dev/mapper/lukssdaX" I can unlock and boot my system. And to be clear I certainly don't doubt the author's expertise on this one, but rather am just puzzled why the clear and easy to understand instructions didn't work for me.

Since I managed to solve my issues I suppose this post doesn't constitute a question, but I am curious to know if anyone else ran into the same or similar issues.

natharran 01-25-2013 05:49 AM

Re: Encrypted root

regarding the encrypted root, I've followed these two videos on Youtube:

The author is using Slackware 13.0, but you can use the same method witch 14.0.

Hope it helps you.

All times are GMT -5. The time now is 04:15 AM.