-   Slackware - Installation (
-   -   Lilo failed to install? (

MDesigner 02-22-2005 10:58 PM

Lilo failed to install?
During Slack 10.1 setup, I got an error saying Lilo could not be installed. Nothing about the MBR not being able to be written..but just that Lilo could not be installed. As a result, I had to totally wipe my WinXP partition and reinstall Windows :( Grrr..why does WinXP FIXMBR/FIXBOOT *NEVER* work?!

To avoid this mishap again, maybe someone could tell me what I did wrong? I've never had issues before on other machines...

DaHammer 02-23-2005 12:20 AM

Best way to approach the issue would have been to figure out why lilo didn't install correctly, correct that, and install it manually. Most likely it was due to a space in the name of a label or something simple like that. And yeah, the Slackware installer doesn't show you the output from lilo, which will usually tell you or at least point you in the right direction as to what's wrong, it just simply informs you that it failed.

Anyway, as I said, I'd just continue with the installation even though it failed and then manually run lilo from the comand line after exiting the install, but prior to rebooting the PC. Then you'll see any errors and can adjust your lilo.conf file to correct them. You can also use the "-t" option to do a test run first before actually installing it. That way you can see any problems without effecting your MBR. Of course that's not going to help if you don't skip the actual lilo installation step in Slackware's setup program. Aside from that, install it to the superblock instead of the MBR and use WinXP's boot manager to boot it.

MDesigner 02-23-2005 12:52 AM

I couldn't run lilo.. it didn't install it apparently. I tried "lilo" which didn't work. The /etc/lilo.conf was missing. I'd have to somehow install lilo off the CD, right? I believe the message said it failed to install lilo, not it failed to install the boot sector..

voyciz 02-23-2005 11:08 AM

Well were you running from the CD still when you were trying to run "lilo" and looking for /etc/lilo.conf? If so, that's probably why, 'cause you're root would still be in memory rather than on disk. Check in the /mnt directory for your partitions.

MDesigner 02-23-2005 11:37 AM

I think my mistake was this.. the hard drive was partitioned as such:

1 - Linux (not formatted)
2 - WinXP (already installed)

I took the CDs to work and did a test.. partioning the drive as such:

1 - Win2000 (installed)
(about 4GB leftover, unpartitioned space)

Booted the Slackware CD.. ran cfdisk, and set up the HD this way:

1 - Win2000
2 - Linux (primary)
3 - Linux swap (logical)

Installed Linux, lilo worked fine, dual boot works perfectly.

Now I'm going to wipe the machine and simulate the first scenario above and see if it fails.. then I know that's what my problem was at home.

MDesigner 02-23-2005 12:21 PM

Bingo, that was it indeed. The partition order was screwy and Lilo didn't like it.

Proper order: partition 1 = Windows, partition 2 = Linux, partition 3 = Linux swap

zor_sv 02-23-2005 03:08 PM

similar issue
I have a similar problem, I installed Slackware 10.0 and chose newbye from the install menu. After I selected every package that I needed, at the end asked if I want LILO installed. I selected yes and added new headers and linux booting from /dev/hda1 (boot-part - /boot). Said it couldn't install lilo and after I pressed ok, it said that instalation was finished and I should reboot. After reboot (I removed the slack cd) instead of booting I get lots of screens with text: "GRUB GRUB GRUB ...". I booted from cdrom again and it seems the /dev/hda1 does contain the vmlinuz and all the boot files that are needed.
I mounted the /dev/hda3 and looked at the lilo.conf file, it contains at the begining a line as:
boot = /dev/hda3

At the end of the file has 2 options (added by me on install, I was confused):
1 -> /dev/hda1
2 -> /dev/hda3

Now my guess I should change that boot = /dev/hda3 in /dev/hda1, but the booting from the slackware cd doesn't seem to help in file-editing. Is there an editor that is loaded?
What can I do ?

All times are GMT -5. The time now is 01:14 AM.