LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware - Installation (https://www.linuxquestions.org/questions/slackware-installation-40/)
-   -   KDE 3.2 "visual and Audio problem" (https://www.linuxquestions.org/questions/slackware-installation-40/kde-3-2-visual-and-audio-problem-179859/)

kuol3m4 05-10-2004 04:54 AM

KDE 3.2 "visual and Audio problem"
 
ok i've updated Xfree to 4.4 and now i got kde 3.2 running on slack 9.1, but i got some problems :

when i start kde a msg appears on the screen saying :

"Sound server information message

error while initialiting the sound driver

device/dev/dsp/ can't be opened (no such device)

the sound server will continue using the null output device."

---- WHAT TO DO???


second problem :
when i click the KDE menu, and try to navigate it i notice that some icons are missing, for example in the game section there are 15 games, only some have got an icon, the other game's icon are missing, and i have the same situation in the other menu. also the main menu seems to be "graphically truncated" in the border i mean.. is hard to explane, maybe something during the installation went wrong...

any suggestion?

drowstar 05-10-2004 09:19 AM

All you did was update X? Hm, ok.

In the KDE control center, in Sound & Multimedia -> Sound System -> Hardware try changing the audio device drop down menu to a different sound architecture. Maybe this solves your problem. I have encountered this error when I was trying to access a non running sound system.

Your second problem is also very strange (i.e. not something that I thought would happen when you upgrade X). It sounds like some icons are simply not there. And maybe other image files have been damaged as well.
You might want to try changing the icon in the Menu Editor (right click on the K-Menu button). See if there is an icon for it there. If there is not, try reinstalling the icon theme. It is something of a hack, but wont do any harm.

I hope this helps. It all is really strange.

Good luck,
- drowstar

kuol3m4 05-10-2004 09:28 AM

thanks for the reply...

i've already tried changing the audio device in the Hardware panel of the sound section..., no way.

same error. i don't have a DSP folder under DEV folder. is this normal?


for the 2nd problem :
i can apply new icon to the programs that are missing the icon... but this is strange.. i've to reinstall the icon packages... gotta find it please..
sorry but as u may notice i'm a newbye!

thanks again man!
claudio

drowstar 05-11-2004 06:16 AM

Hi kuol3m4.

i don't have a DSP folder under DEV folder. is this normal?
Yes. Make sure alsa is running, that might be the problem (although, once again I dont know how that would result from an upgrade of the x server). I dont know, if slackware needs this, but there might be a command line utility called alsa-init or something. Also, try running alsaconf again.

gotta find it please..
here you go: http://kde-look.org/index.php?xsortmode=high&page=0

I hope this will at least solve the icon problem.

Good luck,
- drowstar

kuol3m4 05-11-2004 06:24 AM

news on the audio problem . read here :

http://www.linuxquestions.org/questi...692#post926692

now the mute button of my laptop is enabled when i start linux...
what to do ?


i'll try for the icons! thank u!


All times are GMT -5. The time now is 11:37 AM.