-   Slackware - Installation (
-   -   invisible files and dirs (

karmine 12-25-2004 02:33 PM

invisible files and dirs
im running the latest zipslack, actually i just got it today and im having problems throwing X on it. i downloaded the source etc etc thru windows and put the targz in my zipslack dir, and when i boot slack and do a ls -a the file magically is not there. i even untared it and made a dir for it and the directory isnt there. its kinda pissing me off, any ideas?

iZvi 12-25-2004 02:54 PM

First, why don't you use ZipSlack instead of Win to download the files?
Second, ls (-a) show the files known by the umsdos filesystem, which are keeped in the --linux-.--- file. umsdos is not a real filesystem, don't forget.

Try umssync to synchronise the contents of this file with the contents of the directories.

> umssync -r99 -v- /

Good luck!

karmine 12-25-2004 08:32 PM

the thing is i dont know how to download when all i have is the main terminal, and thats about it. plus i cant use the "make" command, says it doesnt exist.

gnashley 12-25-2004 10:44 PM

First, don't download the source for X. Grab the Slackware .tgz pkgs for slack10. You'll need tcp-ip, X and fonts-misc as a minimum. When downloading with Windows for use in zipslack, don't place the download INSIDE the linux folder, instead outside and under zipslack then install the thing -don't even need to move it inside the running linux.

iZvi 12-26-2004 02:47 AM

I'd suggest you to configure your network in ZipSlack (if you're using DHCP it's even preconfigured for you) and then start the links browser and go to a local mirror to select and download everything you want. Yeah, it's text based but it will be enough for just downloading some packages.
"links local.slackmirror.adress" and then the mouse makes things easy. As gnashley says just install the binaries (*.tgz) for X. TCP/IP comes with the ZipSlack package and is already installed in your system.

If you like you can download everything from Win, but you're probably planning to use i-net from Linux, so at least configure your net with netconfig.

karmine 12-26-2004 11:56 AM

first, i did install from tgz with installpkg, it seems to have worked, but im stuck as to how to get it up and going. i havent found any instructions for pkg installation, only the source (which for some reason i cant use "make").
i tried the umssync -r99 -v- /
from your one post and it went and changed my KDE long files into unusable 8char filenames;\ not like im trying to put kde on right now, seems to much of a pain right now i wanna keep it easy.

i used netconfig and tried to configure my ethernet, i did it manually but it seems since i switched from USB to ethernet my IP has changed 3 times in the past 3 days. as a matter in fact it changed again today so i see. verizon has a DHCP server so im going to try that cause i did everything manually and i couldnt ping my isp etc etc.

i guess ill get to the point:
i have all the neccessary files for X extracted etc and now i need to know how to configure it and have it able to startup, cause of course ive tried startx and nothing happens.

iZvi 12-26-2004 01:54 PM

The 8 char filenames are a limitation of msdos fs.
I can't figure out why are you trying to "make" the X packages.
If you have installed the *.tgz packages for X (you need at least the base and one with fonts in the name), you must install a window manager and then you 're ready to go. Since the tgz packages are binary they can't be compiled (they already are), and for make to work you have to install the make*.tgz package.(don't try to use it for binary packages though).

If you're sure you have installed the required packages for x, type xorgcfg to configure your videocard, mouse and keyboard and then xwmconfig to set a window manager.
Note that it should install the very basic twm, which you should use only for a test. After the GUi works, install KDE, fluxbox, gnome or whatever you want.

karmine 12-26-2004 03:03 PM

it seems X11 only has source, they dont have binary distros, i went ahead and re-tried KDE, and everything is OK except its looking for some shared libraries with X11. do you have AIM or anything where i can talk to somebody realtime.
i got this error msg when i tried runlevel 4

Starting up X11 session manager...
/opt/kde/bin/kdm: error while loading shared libraries: cannot open shared object file: no such file or directory

karmine 12-26-2004 03:05 PM

i forgot to mention i used pkgtool to install the kde binaries (tgz) and it seems to work better than the installpkg, but of course X11 is source only and it has to be compiled? and that is my problem

my aim is: drvonspawn

also i can be found on efnet #exploiters

All times are GMT -5. The time now is 07:36 AM.