-   Slackware - Installation (
-   -   Installing Slackware via VMware player (

spaghettios 08-05-2012 12:10 PM

Installing Slackware via VMware player
I am trying to install Slackware 13.37 on vmware player [windows host]. I get to the screen shown here: the 8th screenshot down which says setup complete, reboot your machine. I hit ctrl-alt-delete which then set off the windows task manager. Rebooted vmware player, but now when i start it, gives me the PXE-M0F :... Operating System not found message. I did the full install, and there's 5.16GB of space used up in my host 'virtual machines' folder.

I've tried changing the CD settings on vmware player, which were left on the 3rd disc (iso). But that didn't do anything.

Any ideas?

jefro 08-06-2012 03:15 PM

Don't use ctrl-alt-del unless you sent it to the VM, that also is bad since linux doesn't normally use it. To reboot you should do a shutdown or reboot command.

Now the pxe is telling me that your virtual computer is trying to boot to some device maybe and no bootable media is there.

Start all over, delete the current machine from disk and menu. Make a new machine in vmplayer. Be sure to add in enough ram and hard drive virtual space as you might need later. The space will only be used when needed. I'd add in more cpu's at this time if you have a fully supported smp computer.

Then boot up and install as usual. When you get to the end then use correct linux command or menu or mouse click to reboot.

You may have to double check your downloaded iso's. If you can't easily swap iso then you might have to create disks in the worst case.

Shame you can find a pre-made virtual machine to download. They make this real easy.

spaghettios 08-09-2012 06:27 AM

Excellent thanks for your help!

spaghettios 11-04-2012 09:43 AM

I feel so stupid, i'm just installing a new distro on vmware player and i can't remember how i did this last time. When the install is finished it tells me to remove the disk and reboot. So in the vmware player i go into virtual machine settings and instead of using ISO image file i tell it to use the physical device. Then in the emulator type reboot. I still get the same 'operating system not found message'. I have also tried using the 'send ctrl+alt+del' function on vmware player, but get the same result.

(I knew i should've written it down the first time)

TobiSGD 11-04-2012 02:11 PM

Seems to me that you don't have installed Lilo (or Grub, ...) into your your VM, or you have installed it to the /-partition instead of the MBR.
Which settings do you have used and where there any errors?

spaghettios 11-04-2012 02:52 PM

That's the ticket. Works on the MBR.

All times are GMT -5. The time now is 09:13 AM.