-   Slackware - Installation (
-   -   Installing Slackware 10.2 on SATA drive with a SATA CD-RW drive (

Voltar 07-13-2006 10:59 PM

Installing Slackware 10.2 on SATA drive with a SATA CD-RW drive
OK, I've installed Slackware many times and I've even done it on SATA drives before. Now here's the problem. I don't have use of a IDE channel on this particular machine, so I have a IDE>SATA gender changer on my CD-RW drive. It shows up in the BIOS, and I can boot from it, but when I go through the start of the install and try to search for the drive to install with, it cannot be found.

And help would be appreciated.

Also, as an absolute last resort I have a IDE controller card (PCI) that I can take out of another machine and use for the install if I have to, and if it would work. Only thing is the CD-RW drive that is in the machine now would have to work after the install.

nadroj 07-14-2006 12:14 AM


when I go through the start of the install and try to search for the drive to install with, it cannot be found.
the hard drive to install to cannot be found? how is it connected, SATA? im kind of confused because you say you know how to install it to SATA drives.
sorry if its obvious, but please explain to me what the problem is and what you have tried.

maybe 'fdisk -l' to see what harddrives are installed?

Voltar 07-14-2006 12:29 AM

The SATA hard drives are recognized fine. The SATA CD-RW drive isn't. I can boot into the install with the CD drive, but when looking for a source it cannot see it.

I've tried the bare.i, sata.i, test26.s, and the scsi kernels, and I've tried moving the CD drive to SATA connector one to no avail.

nadroj 07-14-2006 12:36 AM

try manually specifying the cd drive, try '/dev/cdrom' and '/dev/scdX' where X is 0,1,2,etc

Voltar 07-14-2006 12:44 AM

I tried mounting /dev/scdX (0-4) and got...

mount: /dev/scd1 is not a valid block device

I tried mounting /dev/sdc (It's the third thing on the SATA bus) and /dev/sdd and got...

mount: special device /dev/sd[cd] does not exist

I also tried manually selecting the install cd source in setup, I tried every option listed, and the auto scan, and the legacy hardware scan.

nadroj 07-14-2006 12:53 AM

do you see your harddrive that your going to be installing to? what device file is that using? /dev/sda1?

edit: "The SATA hard drives are recognized fine." ok

nadroj 07-14-2006 01:03 AM

try using /dev/srX devices

does 'dmesg | less' give any useful hints?

Voltar 07-14-2006 01:04 AM

Yeah, all my hard drives show up correctly, and I partitioned them with cfdisk, and I can go through setup to the point that it looks for the seemingly non-existant CD-RW drive.

I could pop a IDE controller card in there and use the drive on a native IDE interface and install, but then if Slack didn't recognize the SATA CD-RW after installing I'd be left without a optical drive, and I'm apprehensive in doing that... I don't want it to be something I regret...=S

Voltar 07-14-2006 01:06 AM


Originally Posted by nadroj
try using /dev/srX devices

does 'dmesg | less' give any useful hints?

/dev/srX also gives the not a valid block device and dmesg | less gives ....

less: No such file or directory

nadroj 07-14-2006 01:12 AM

is there a /var/log/messages?
i would have thought /dev/scd0 or /dev/sr0 would work.

can you post the output of 'lspci' and 'lsmod'.

off to bed now ill check it out tomorrow, but i hope someone can help you out before then!

Voltar 07-14-2006 01:18 AM

Thanks for all the help so far.

Yes there is a /var/log/messages, but it doesn't contain hardly anything.

lspci doesn't work in setup either it seems, lspci: No such file or directory

lsmod gives....


and that's it.

nadroj 07-14-2006 01:36 AM

did you say your using a SCSI to IDE changer, making the cd drive connect to the motherboard via IDE? if so then youll be using /dev/hdX#

if not, try 'modprobe sr' or 'sd' then search again.. or 'ide-scsi'. dont know if thatll work in setup either though...

sorry, out of ideas.

edit: NOW im off.. good luck

Voltar 07-14-2006 02:03 AM

Other way around, IDE to SATA changer, so it should show up as a SATA device, and have a /dev/sXX name. For the heck of it I tried using /dev/hdX up to hdh or something with no luck.

onebuck 07-14-2006 08:26 AM


You stated in a earlier post that the cdrw is recognized by the bios. As what device assignment?

I would also suggest you do a

fdisk -l
to see what the system has recognized.

Voltar 07-14-2006 12:24 PM

Hi Gary,

The CD-RW is given id 3 by my SATA controller, and my two SATA hard drives are 0 & 1.

fdisk -l shows all my IDE devices (I have four 320 GB hard drives in an LVM), I can't see anything about SATA devices there.

I have tried booting with an old Ubuntu 5.10 Live CD I had, and it worked perfect, could mount/read CDs, etc. I ended up taking my mass of IDE drives out, installing Slack, putting them back in, but it still doesn't recognize the drive after installation.

Now it's more of a matter of "I can't get slack to recognize my SATA CD-RW", Should I repost in the main forum? I'm thinking it has something to do with the kernel, and something needing to be compiled.

Edit: My bad, fdisk -l shows SATA and IDE drives after install, it went by so fast that I didn't see them all.

All times are GMT -5. The time now is 09:26 AM.