-   Slackware - Installation (
-   -   Installing Slackware 10.2 from scratch (

dfresh 10-31-2005 10:58 PM

Installing Slackware 10.2 from scratch
I've been trying to get a slack 10.2 install going on a clean system. Mainly wanna use it to learn more than the basic linux stuff and use it as a test for apache http. Every time I get it installed and try to boot it either hangs or I get a kernel panic error. LILO won't install either and I've tried it both without LILO and tried using a boot disk. I'm wondering if my partition scheme is causing the problem. System specs are very basic: Athlon XP 2600+, 512MB ram, radeon 9600, 160GB HD. Here's the partition scheme I've been using:
/boot - 100MB (bootable)
/ - 500MB
/swap - 1GB
/var - 10GB
/home - 10GB
/usr - rest of unused space (approx 140GB)

Can anyone tell me what the basic partition scheme I should use is to just get Slackware running? Also, are there certan partitons that need to be logical or extended? Thanks

gbonvehi 10-31-2005 11:24 PM

It shouldn't matter the partition scheme or if the partitions are primary or logical.

Is your harddisk sata or ata? Can you give more details on which kernel you select and what errors you're getting? Also, in the lilo configuration, choose Expert mode and install to MBR, that works better than on superblock.

dfresh 11-01-2005 09:02 AM

My HD is ATA; it's just a plain old Western Digital drive. I'm using the default kernel, but I've also tried the base kernel too. I've also gone through the expert install for LILO and it won't install to either the superblock or the MBA. Not sure what else to try.

gbonvehi 11-01-2005 10:30 AM

Ok, so, could you sucesfully install Slackware?
If you did, you could boot into it by booting with CD 1, and at LILO's boot: prompt, typing: bare.i root=/dev/hdXX

Change hdXX to your root partition and if you need, change bare.i for other kernel you may want.
If you can boot into it succesfully, try running the lilo configuration script from there by typing: /sbin/liloconfig and again, try Expert mode -> Install to MBR

dfresh 11-01-2005 12:51 PM

I've gotten through the entire installation & configuration except for LILO. Every time I try to install LILO, whether it be to the superblock or MBA, it fails. Also tried going without LILO completely. If I try to boot after install it either hangs on a blank screen or I get a kernel panic error. I also tried using the floppy boot disk it asks to create and I still get a kernel panic. I know I tried one of the bare kernels when going through the config, but not sure if it was the bare.i specifically. I've gotten both Fedora & Mandrake to successfully intall on this box so I'm not sure what I'm doing wrong with slack.

sweetnsourbkr 11-01-2005 01:48 PM

Can u post your /etc/lilo.conf?

dfresh 11-01-2005 02:50 PM

Is it possible to do that if I can't boot? Can I get that info if I boot from the install CD?

sweetnsourbkr 11-02-2005 10:41 AM


Refer to gbonvehi's post above.

mjjzf 11-08-2005 05:52 AM

If there are troublesome remains from previous systems, you may want to blow away the installation with Darik's Boot and Nuke.

jsmarshall85 11-10-2005 01:44 PM

assuming you are installing a very basic install, my / has 1.2 gig in it, but i installed everything

shouldnt the / partition be bootable and not the /boot partition? i may be wrong but i remember seeing another distro that installed a /boot partition by default but the / partition was what was marked bootable

All times are GMT -5. The time now is 02:19 AM.