-   Slackware - Installation (
-   -   Installing From USB Question?? (

LionOfGod 03-06-2011 08:55 AM

Installing From USB Question??
First time on these forums, so Hello! : )
Im going to get straight to it, I've been a windows user all my life and one day i just had this notion to try out a UNIX. So i picked up a couple of books and i tried Ubuntu and now I'm using PClinuxOS. Now i want to switch so Slackware because i keep hearing everyone saying
"If you learn Fedora, You know Fedora, But If you learn Slackware
You Know Slackware
(plus the fact that my PCLinuxOS doesn't have any man pages)
So i downloaded the discs from 1-6 (13.1) and i want to install from a usb, by the way i`ve read a few guides on how to do it and searched up my questions but I still cant figure them out! So here they are...

Will my USB be useless after using it to install Slackware ?

Do i have to make a partition and put all of the Slackware
disks on the computer that i`m installing it on?(If so will Slackware install on the said partition ?) ( I have an 8 gig usb so can`t i just put all the files on that???)

Will Slackware uninstall PCLinuxOS ( If No how do i do it?)
(BTW i have no LAN or any sort of connection to my linux PC)

What is a swap partition, what is its purpose and how big is it supposed to be?

A lot of sites say that the usb image is included with the Slackware installation, how can i get access to that?

Also, im on windows so how do i get the usb image on to my usb
(copy paste??? or some mounting stuff??)

Thanks guys, sorry for the loong post ; )

Alien Bob 03-06-2011 10:03 AM

The article explains how to create a USB bootable installer for Slackware if you are running Windows.

Slackware will not wipe anything off your harddisk unless you tell it to. First stage of the installation (before starting "setup") is to use fdisk or cfdisk to create any partitions you need. If you want Slackware to re-use your existing PCLinuxOS partition(s) then all you need to do is to run the "setup" right away and tell the installer to use the existing Linux partition.


LionOfGod 03-06-2011 11:36 AM

Hey, thanks for the guide but i still have one problem,
The guide says "Use Winimage to extract the content of the image file “D:\usb-and-pxe-installers\usbboot.img” to the newly created directory “U:\boot\syslinux\” on the stick"
Problem is, i downloaded Disk 1-6, not the full dvd set, so i just have the ISO's, where is this image???
Also for every ISO image i have i have an .asc and a .md5 file too, what are those for??


Okay sorry i figured it out, i mounted disk 6 and found the usb and pxe file

LionOfGod 03-07-2011 06:52 PM

Okay, I have successfully made my usb, but now when im installing i cant figure out the instruction you directed me to.

PHP Code:

When booting this USB installer (the version containing the Slackware packages), 
you have to mount the USB partition before starting “setup” because you can access your
packages only after mounting itYou cannot use the directory “/mnt” to mount this partition 
because the Slackware installer uses “/mnt” already. After the booting has finished and it
delivers you to a command-promptyou create a new directory in the installer, for instance 

mkdir /usbinstall

After you have created this mount point
you have to find out the name
 of your partition 
(you can run “fdisk -l” or “blkid” to find out) and
then use the following mount command to preserve upper case filenames:

mount -t vfat -o ro,shortname=mixed $(/sbin/blkid -t LABEL=USBSLACKINS cut -f1 -d:) /usbinstall

“shortname” option used in that mount command is required, and Slackware
installation will fail if you forget it.

you labeled the stick’s partition “USBSLACKINS” in step 7 above, then you 
can use the following command instead of the previous mount commandIt will
 find the correct partition automatically 
(note that what follows is a single command line !):

mount -t vfat -o ro,shortname=mixed $(/sbin/blkid -t LABEL=USBSLACKINS cut -f1 -d:) /usbinstall

Then afterwards
when it is time to specify the package SOURCE directoryyou type:


The rest of the installation will proceed 
as usualGive me feedback in 
the comment section below 
if you encounter any problems. [/CODE]] 

can someone explain this to me a bit easier please??? also why is his code (mount -t vfat -o ro,shortname=mixed $(/sbin/blkid -t LABEL=USBSLACKINS | cut -f1 -d:) /usbinstall) identical in both spots where he mentions it??? Please hellp!!!

allend 03-07-2011 09:56 PM

Eric has changed his method slightly, to make it easier, but has left some stuff from the previous instructions that is causing your confusion.

What you want to do is:
Boot the USB installer and wait until booting has finished and delivers you to a command-prompt. (Look for a line ending with # and a flashing cursor.)
Create a new directory to use as a mount point using the command:

mkdir /usbinstall
Mount the appropriate partition.
If you labeled the stick's partition “USBSLACKINS” in step 7 above, then you can use the following command that will automatically mount the appropriate partition.

mount -t vfat -o ro,shortname=mixed $(/sbin/blkid -t LABEL=USBSLACKINS | cut -f1 -d:) /usbinstall
Now you can start the install following your preferred guide.

Then afterwards, when it is time to specify the package SOURCE directory, you type:

Note: You may want to change 13.0 to 13.1 in the above if you are installing Slackware 13.1

LionOfGod 03-08-2011 05:44 PM

When i enter the code mount -t vfat -o ro,shortname=mixed $(/sbin/blkid -t LABEL=USBSLACKINS | cut -f1 -d:) /usbinstall i egt a big long note talking about mounting and other stuff, am i supposed to use /sbin/blkid as the directory or come up with my own? Please help! BTW i only have 2 partitions and ones a swap. (if partitions have anythign to do with that code)

allend 03-08-2011 11:01 PM


mount -t vfat -o ro,shortname=mixed $(/sbin/blkid -t LABEL=USBSLACKINS | cut -f1 -d:) /usbinstall
That command will only work if you labeled the stick's partition “USBSLACKINS”.

To explain the above command:
mount is the command name.
-t vfat tells mount that you want to mount a vfat file system.
-o ro,shortname=mixed are options for the mount. (ro is for read only. shortname=mixed is for display the short name as is; store a long name when the short name is not all upper case.)
$(/sbin/blkid -t LABEL=USBSLACKINS | cut -f1 -d:) is a bash command substitution. It takes the output of the /sbin/blkid command, looks for the label USBSLACKINS and then isolates the appropriate device name (e.g. /dev/sda1).
That device is then mounted to the /usbinstall directory.

If you are having problems, then it may be due to your partition name. If you have already partitioned your target system then it is likely that the stick's vfat partition is the only vfat partition available.
You could try changing to

mount -t vfat -o ro,shortname=mixed $(/sbin/blkid -t TYPE="vfat" | cut -f1 -d:) /usbinstall
Run /sbin/blkid.
Inspect the output (something like below) for the stick's vfat partition.

/dev/hda2: TYPE="swap"
/dev/hda3: TYPE="reiserfs"
/dev/hda4: TYPE="reiserfs"
/dev/sda1: UUID="9B98-9ADB" SEC_TYPE="msdos" TYPE="vfat" LABEL="My Book"
Then issue the command

mount -t vfat -o ro,shortname=mixed /dev/sda1 /usbinstall
The important information is the device name, /dev/sda1 in this example.

LionOfGod 03-09-2011 07:38 PM

Okay, so i tried typing /sbin/blkid and my usb is not displayed, only the two partions are.
I think this is because i am using plop boot manager in order to boot from my usb because my bios does not support usb booting.
But something interesting did happen, i tried putting my usb in various ports and one time it was detected, i messed up and tried to mount it without making a directory and my brother pulled the plug (*tough life), but it was surprising because my usb was detected.
I found out that my usb was named USBSLACKINS and also the file was something like /dev/sdba or something like that, what i mean is that the last part of the file location which could be sda1 or sda 2 had a "b" in it, thats what i remember (in case that helps anyone in solving the question.
I also tried going to the /dev directory and i found sda1 and sda two but it hink my usb may be at a higher part of the list, because i just typed "ls" and it scrolled by fast (fat chance though, because if it was in the directory it would be detected right?)
currently i have no internet connection to that computer, also i have no operating systems on it.
Any help??? That computer used to be a windows 2000 until it became a ubuntu, i formatted that in one day and installed PClinuxOS, then i formatted that because it had no man pages and decided to with slackware, im not about to quit anytime soon, so please HELP!!! BTW plop bootmanager is able to boot from my usb yet the kernel or cmd (w/e its called) cannot detect it??

allend 03-10-2011 08:20 AM


I think this is because i am using plop boot manager in order to boot from my usb because my bios does not support usb booting.
This is new information.

A device name like /dev/sdb1 or /dev/sdb2 is valid. /dev/sda1 is probably the first partition on your primary hard drive.

Please post the output of '/sbin/blkid' and '/sbin/fdisk -l'.


i just typed "ls" and it scrolled by fast
You can do 'ls | less' to see a listing a screen at a time. Type 'q' to quit.

LionOfGod 03-10-2011 09:56 AM

hey, okay
I found that when i leave the usb in my computer for a while (an hour or two) and i come back and use /sbin/blkid
Then my usb is detected :) Thanks a lot, i ran the setup over night, im at school right now so il check on it when i get back home,
It was installing lilo when i checked before, so it hink it was a successful installation, thanks a lot!
Installed slackware jsut in time for march break ;)

LionOfGod 03-10-2011 02:16 PM

ARGHH!!! :(
Another problem, i finished installation, installed everything, it said it was succesful, i rebooted like it told me to and....

GRUB error 15 (blackscreen) wtf???! i thought lilo was my boot manager???
help please!!!
I tried both booting from hardrive AND nomrally!
bad start to march break :( HELP please!

allend 03-10-2011 03:07 PM

It seems that you installed lilo to the root partition of your Slackware install rather than the MBR. You will need to get your bootloader to chainload the Slackware partition.

LionOfGod 03-10-2011 04:28 PM

Okay so whats chainlaoding and how do i do that?
when i use plop to boot from hda Partion 1 OR 2 i get a message saying no valid boot signature do you stilll want to boot?
i say yes but all i get is a blackscreen with a blinking cursor?
is it possible to reinstall just LILO???
Okay forget that, i just formatted the whole drive with the setup
(luckily it detected my USB)
And my computer is currently reinstalling the whole thing
(hope it works this time ; )

LionOfGod 03-10-2011 10:11 PM

Okay, problem...again!
Reinstalled slackware...lilo cant install to MBR because of video card n stuff
Then i find out i could have just pressed reconfigure system to reinstall lilo
i tried different methods of installing lilo, none worked (tried expert and simple)
Now what do i do?
Everything I find on internet about installing lilo to a cd is confusing
and constantly talks about dual booting, which i dont need.
Please explain what i should do and how??? :S
Thanks very much!
Ima stick with Slackware to the end ; )
Can i install GRUB and use it instead???It looks like that would be easier...?

allend 03-10-2011 11:12 PM


...lilo cant install to MBR because of video card n stuff
This is very unlikely. Please give exact details of the any error message.

Does your system have some BIOS setting that stops the MBR from being written?

Can i install GRUB and use it instead???
GRUB is available in the /extra directory of the install media.

It looks like that would be easier...?
That is debatable, and has been many, many times over :-)

All times are GMT -5. The time now is 07:36 AM.