-   Slackware - Installation (
-   -   installing 14.0 on an xSeries 206 (

zarb 09-08-2013 09:28 PM

installing 14.0 on an xSeries 206
Hello friends. I installed 14.0 on an IBM xSeries 206 server, using four ISO CDs, and the OS crashes each time I attempt to boot it. It gets to the boot page, where there is an option to either boot the Linux partition or proceed with special text commands at the boot root, and then crashes with a fuzzy screen before the system gets fully loaded. According to the FAQs at the distro website, it is possibly caused by hardware in the machine that is mounted to non-standard ports, so it doesn't jive with the kernel; that makes sense but I cannot confirm that, and would not expect it to be a fatal thing. The distro page prescribes bringing the kernel into conformance with the machine after booting to CD or USB, about which I would request assistance here now, except that my USB boot stick also causes a crash, and the CD simply tries to walk me through another partition/format/setup procedure. I suppose I could attempt to fix the boot root by using the boot shell that comes up on the OS launch screen? How?

zarb 09-09-2013 02:04 PM

or to say it a different way, when I enter "mount root=/dev/sda1" at the LILO prompt, the system response is "No such image. [Tab] shows a list."

zarb 09-09-2013 03:42 PM

Also with ArchLinux
Well, now the same crash is happening when booting from an ArchLinux ISO.

TracyTiger 09-09-2013 08:10 PM

A Start ...
Welcome to the LQ Slackware forum zarb!

You should know that this Installation subgroup gets less traffic than the main Slackware forum. Since it's been a day and none of the helpful, friendly Slackware first responders has replied yet I'll give you some information that may help get you make progress with your problem. The following is just to get you to boot Slackware, not to install it.

Let me mention that I have no knowledge about the your computer model or its CPU. Below are general comments regarding Slackware.


Originally Posted by zarb (Post 5024774)
or to say it a different way, when I enter "mount root=/dev/sda1" at the LILO prompt, the system response is "No such image. [Tab] shows a list."

At the boot: prompt if you are not going to just hit ENTER and take the defaults, then the first argument must be the kernel you want to load. If you're using the 32 bit version of Slackware then this would be either hugesmp.s or huge.s. Try huge.s in case your CPU is older or non-standard in some way.

If that doesn't work try to turn off some features that have historically caused problems on some systems. At the boot prompt type...

boot: huge.s
boot: huge.s acpi=off noapic nomodeset
boot: hugesmp.s acpi=off noapic nomodeset

Note that acpi and apic are two different settings. The are spaces between the arguments but no spaces in the "acpi=off" argument.

Hopefully using the 32bit version of Slackware using the huge.s kernel and turning off one or more features will enable you to boot to a root@slackware:/# prompt.

If you get the system to boot here a couple of commands that may be helpful if you're not familiar with the hardware in your computer.

cat /proc/cmdline - Shows Arguments used in boot if you forgot
cat /proc/cpuinfo - Displays information about the CPU
cat /proc/meminfo - Displays information about the memory

Other Slackware forum members will eventually scan this subgroup and perhaps offer better advice and perhaps some links to documentation that will help in your situation.

zarb 09-10-2013 03:11 PM

Howdy Tracy Tiger! Thank you for your thoughtful input on this project.

FYI, I was not just hitting enter and taking the defaults because that method was leading to a crash at some point fairly early in the loading of the OS. One source said this is likely because of some non-traditional configuration of hardware/firmware in this machine. It’s hard to say exactly what particular load-in was crashing it, because the screen goes all fuzzy and then I cannot see what was loading at the time of crash.

Anyway, I took your advice in trying to load the kernel, and the system responds with the same “no such image. [Tab] shows a list” I tried to load the kernel from both the 14.0 that I already installed on the hard disc, and from the USB boot stick that I made when installing 14.0. Still, LILO responds with “no such image. [Tab] shows a list”. (Unfortunately, [Tab] does NOT show a list, but I wish it did for the sake of clues on this issue!)

Anyway, I also subsequently have tried to load both ArchLinux and CentOS from ISO CDs; the ArchLinux crashes much like the slack 14.0 does (after the LILO prompt/default boot screen it crashes to a fuzzy screen pretty early in the boot text scrolling). The CentOS never offers a LILO prompt, but it does crash with a blank screen pretty soon right after the CentOS splash screen.

Here is what I propose: The machine I am tinkering with is was marketed as a server, and has RAID capability. Yes, it’s a 32-bit chip, though I eventually want to upgrade that to a 64. Since its on-board hardware config is very possibly the cause of the problem, I am going to fetch another hard drive so that I can configure a RAID disk array on the machine BEFORE spending too much time on troubleshooting a temporary one-hard-disc config.

The machine’s configuration setup shows some 21 items on the PCI bus, so I expect I will be looking for good reference material about how to do that, when it comes to modifying the kernel to accommodate those things.

My ultimate goal is to use this machine as both 1) a local LAN file server and 2) a web server for my own small business and personal websites thus eliminating my having to pay anymore for third-party website hosting.


TracyTiger 09-10-2013 05:20 PM


Originally Posted by zarb (Post 5025457)
Yes, it’s a 32-bit chip, though I eventually want to upgrade that to a 64.

First things first. You should be able to use the Slackware 32 bit version installation source media to boot to a minimal system (like a live CD) used to later install Slackware on your system. No hard drives needed for this first step.

Only the 32 bit version will work with your 32 bit CPU so don't try to boot the 64 bit version of Slackware.


Anyway, I took your advice in trying to load the kernel, and the system responds with the same “no such image. [Tab] shows a list”
The source media you're booting from should have a directory named "kernels" which contains two kernel images; "huge.s" and "hugesmp.s". If if doesn't then you'll get the "no such image" message and won't be able to proceed any further.

It's possible that you don't have a good/complete installation source. So you may want to start the process over by obtaining good Slackware installation media for 32 bit CPUs.

I don't have any experience booting from a USB flash drive. I've always installed from a CDROM or DVD. Are you able to burn CD disk # 1 of the Slackware installation set and configure your BIOS to boot from a CDROM/DVD? If so, try that. I'm just trying to keep it simple to get you started.

Others may be able to give advice regarding the proper setup for a USB Flash Drive Boot. I'm usually about a decade behind everyone else. :)

zarb 09-13-2013 11:58 AM

~Tracy Tiger~
I successfully booted to the root from the image disc by simply loading huge.s (hugesmp.s crashed). Now I am wondering:

1. One source said I should alter the kernel through the root so that the full system that I created a partition for and uploaded onto the hard disc will properly boot, in order that I do not have to LILO boot every time the system is dunked, and so that I can access the full array of the distribution, but A) I am not sure which of the box’s hardware are causing the crash during loading, and B) I am willing to experiment with that but I do not know how to access the kernel on the hard disc, because I am getting ‘permission denied’ responses from the bash shell when trying the view the contents of the hard drive after mounting it. (I was mounting it in a directory that I created and named /mnt/frisbee - is that OK?)
2. I would like to toy about in trying to configure the network (as mentioned before, I am wanting to set up a LAN and a web server), but I would like to get the full distribution up and running before I do that. ~zarb~

TracyTiger 09-13-2013 01:10 PM

My recommendation is to keep things simple and try to accomplish things one task at a time.

I recommend you try simple installation of Slackware 32. Don't bother about networking server services or anything else. Since you got the system to boot with huge.s don't worry about making any kernel changes. Just get Slackware installed on a hard disk that will boot to a command line prompt. Once you get that far then you can spend the next several days/weeks/months/years having fun with Slackware configurations.

Assuming an empty system so there is no worry about wiping out other OS or data ...

With a disk connected to the system, partition the disk with fdisk. It's okay just to make two partitions, one for swap (type 82) and one for all the files (type 83). Don't get complicate with your first installation. Keep it as simple as possible while you learn about Slackware installations.

Follow the normal installation procedures. You'll want to pick huge.s for the kernel since it appears that hugesmp.s doesn't work for your system.

Do NOT mount anything in /mnt during the installation process. The install process uses that directory to mount file systems.

It's easy to just reformat the disk and start over if things don't work.

That's just how I would proceed. Others often do things differently than I do.


Sorry to be so short. I wasn't prepared to help you on the installation of Slackware. I was just trying to get the installation system to boot for you.

In an hour I have to leave the state for several days so perhaps others can point you to documentation on how to install Slackware and how to make sure LILO boots the huge or generic kernel instead of the SMP versions.

Note that there are several README files in the root partition of the boot media. You should look at those whether or not someone else responds here to you.

It's up to you to make backups of important data before beginning tasks that can potentially destroy the disk/media content.

All times are GMT -5. The time now is 01:51 AM.