-   Slackware - Installation (
-   -   Installation freezes when Formatting (

AbbyTritonus 12-16-2007 04:56 PM

Installation freezes when Formatting
Trying to install Slackware 12.0 (and this happens to Zenwalk also) on a desktop I acquired recently, that I am unsure of the complete specs of, but it runs Pentium 4 with 256MB of RAM. I've tried this install on two different hard drives. I am running the huge.s kernel.

Everything goes fine until I reach the format/check of the swap/target partition. Whether I check for bad blocks or not makes no difference to the error output.


[<c017ac9a>] block_read_full_page+0x27a/0x2e0
[<c017d590>] blkdev_get_block+0x0/0x60
[<c0143dc1>] __do_page_cache_readahead+0x171/0x210
[<c013ca22>] handle_level_irq+0x72/0xb2
[<c0120787>] irq_exit+0x47/0x70
[<c0105ced>] do_IRQ+0x3d/0x70
[<c0143ea3>] blockable_page_cache_readahead+0x43/0xb0
[<c0143f6e>] make_ahead_window+0x5e/0xc0
[<c0144058>] page_cache_readahead+0x88/0x200
[<c013e45a>] do_generic_mapping_read+0x47a/0x4e0
[<c01403f6>] generic_file_aio_read+0xf6/0x1f0

# (etc etc, there's much more for the above, I don't think it's relevent - but I could be wrong)

Code: 45 8d 46 1c 89 44 24 28 eb 06 4d 83 fd ff 74 36 8b 0b 56 14 8b 56 14 8b 44 24 0c
0f af 50 10 03 56 0c 47 89 7e 10 8b 7e 14 8b 44 24 28 <8b> 3c b8 89 7e 14 89 54
8b 10 8d 41 01 89 03 8b 7e 10 8b 44 24
EIP: [<c01574b0>] cache_alloc_refill+0xe0/0x490 SS:ESP 0068:c1249d4c
The cursor just flashes after that (into infinity I assume, I have left it for a long time without it changing).

If I skip the formatting entirely and go onto the installation, I get these messages: (on the full default installation)


There was a fatal error attempting to install /var/log/mount/slackware/a/kernel-modules-smp- The package may be corrupt, the installation media may be bad, or something else has caused the package to be unable to read without error. You may hit enter to continue if you wish, but if this is an important required package then your installation may not work as-is.
If you hit enter, it will continue to bring up that error (but for different packages) almost continuously.

I've tried installing Slackware & Zenwalk on two different hard drives (both of 40GB+) and get the same error output.

H_TeXMeX_H 12-17-2007 03:02 AM

Check the md5sum of the disk and make sure it matches the one on the mirrors. It's likely a badly burned disk. Burn at slower speed.

allend 12-17-2007 05:17 AM

Hmm, two separate distros and two separate hard drives tried without success on a "recently acquired" desktop. This sounds like a hardware problem to me. It is possible that the primary IDE chip has failed. I had a similar problem with an old computer that I managed to get around by switching to using the secondary IDE chip via BIOS settings. May be worth a try.

AbbyTritonus 12-17-2007 10:00 AM

Hmm, I've used the disk before multiple times and I've never had a problem with it. And I've tried it on two different OSs, on two different disks. I burnt is at a slower speed, however (4x for a 12x disk should be fine=/) and checked it against the md5sum. The disk was fine, and the outcome was the same from being burned at a slower speed.

I have a problem with GParted as well - I choose the first option off the list, and it boots up, but freezes after:

Freeing unused kernel memory: 384k freed

I've tried changing to the secondary IDE chip (at least, I changed from IDE-0 to IDE-1 in the booting options - that's all I could find that mentioned "IDE"). That made no difference either.

I also got this error when booting into the Zenwalk kernel

sisfb: Fatal error: unable to reserve 16MB frame buffer memory
sisfb: Is there another framebuffer driver active

I think this may be a hardware problem now however, so this is probably being posted in the wrong forum.

H_TeXMeX_H 12-17-2007 12:21 PM

I see, well then it's probably a hardware issue. But with what ?

I would personally use the ultimate boot CD (or similar) to at least test the RAM with memtest and then also maybe the hard drive. But, you said it's a new desktop, or an old desktop you just acquired ?

Other than that, I wouldn't know too much. It's hard to diagnose hardware issues, typically it involves lots of trial and error unless you can make sense of the error messages, and it doesn't seem like I can help there, never seen these kind of errors before. You might have better luck in the hardware forum as you said.

Good luck.

allend 12-17-2007 03:39 PM

This may also be a memory problem. Have you conducted a memeory test on your RAM?

onebuck 12-18-2007 07:17 PM


You do seem to have a hardware problem. I would use memtest86 to test your memory. Let it run overnight if an immediate error(s) do not appear within the first few passes. If you have a Knoppix Livecd then memtest86 is available on it.

You can find several tools in the Tools, Recovery, Diagnostic, Emergency section of the 'Slackware-Links'.

You could open the box an make sure that the cables to the HD an motherboard are ok. Be sure to power the system down before you disconnect or reconnect anything within the box.

If the memtest86 passes without error then I would suggest that you get the manufacture diagnostics for your hard drive to allow you to test it.

AbbyTritonus 12-20-2007 08:33 AM

Yeah - I conducted a memtest, and in 4 hours there was about 15000 errors and four passes ... so I replaced the RAM and it's working now. Thanks for all the help :) :)

All times are GMT -5. The time now is 01:21 PM.