LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware - Installation (https://www.linuxquestions.org/questions/slackware-installation-40/)
-   -   ICH9 RAID prevents installation, any ideas? (https://www.linuxquestions.org/questions/slackware-installation-40/ich9-raid-prevents-installation-any-ideas-727828/)

kay27 05-22-2009 12:00 PM

ICH9 RAID prevents installation, any ideas?
 
I have motherboard Asus P5E3 with 6 SATA ports:
/dev/sda: member of ICH9 RAID5
/dev/sdb: member of ICH9 RAID5
/dev/sdc: *TARGET DRIVE* for installation (SINGLE, not member of RAID)
/dev/sdd: member of ICH9 RAID5
/dev/sde: DVD ROM (Source)
/dev/sdf: ---

cfdisk without parameters say error. When I run "cfdisk /dev/sdc", I can manage partitions, add target partition and partition for swap... But then when I run "setup"... it could not find created partitions :(:(:(

RAID5 contains critical data, so disconnecting /dev/sda and /dev/sdb simultaneously or reordering drives (sda <--> sdc) may be dangerous... //There is an option in BIOS in AHCI mode to software switch off SATA ports, but it seems it affects only BIOS ;)

Is there any way to point setup to /dev/sdc immediately?

H_TeXMeX_H 05-22-2009 01:01 PM

Did you remember to write the partitions to the disk ? If cfdisk sees the drive then the drive should be seen by setup as well. I usually put SATA drive in AHCI mode to avoid possible driver issues.

kay27 05-22-2009 01:38 PM

Yes, of course I write partitions before quit cfdisk :)
But it seems that setup try access /dev/sda at the first anyway...

kay27 05-22-2009 02:09 PM

...or it does not, not really sure.

There was one strange thing:
if I use cfdisk, everything is OK,
but if I use fdisk (partitions type 82 and 83 are already created, I just enter 'p' and then 'w' commands), it always says that the partitions are written but could not be read again, and the changes will affect to setup after system restart.

H_TeXMeX_H 05-22-2009 03:26 PM

Oh yeah, sometimes I have to restart after partitioning otherwise it won't see the partitions, so you can try that, but I bet you did.

kay27 05-22-2009 10:41 PM

Yes I did and partitions are accessible for kernel so it's trouble with setup program only.
It's surprising that Slackware setup contains rather poor help.
There is the paragraph about activating swap before run setup (mkswap, swapon) - swap is activating with no errors, but ADDSWAP still could not find it (I think because setup firstly try access /dev/sda and fail).

kay27 05-23-2009 12:25 PM

So /dev/sda,sdb broken, how to install to /dev/sdc?
 
So, I have ICH9 RAID, BUT I DO NOT WANT TO USE IT WITH SLACKWARE. I also don't want to migrate or backup it somewhere or reconfigure because it contains critical data. I need to install Slackware to /dev/sdc that is a single hard drive, not a member of RAID5 (but /dev/sda,sdb and sdd are members).

Symptoms:
1) cfdisk without parameters say error: partition ends after the end of disk or something like (it's about /dev/sda as default);
2) setup program could not find partitions with type 82 and 83 prepeared with `cfdisk /dev/sdc': /dev/sdc5 and /dev/sdc6 (setup is also scan firstly /dev/sda and I need a way to prevent it).

I need a way to tell setup program to use /dev/sdc immediately, without making scan that in always fails due to unsupport intel matrix storage by kernel.

There is I posted before in top level forum wrongly: http://www.linuxquestions.org/questi...-ideas-727828/

H_TeXMeX_H 05-23-2009 01:06 PM

I wonder if you try to boot using the boot options 'sda=noprobe sdb=noprobe sdd=noprobe', so at the boot prompt try:

Code:

hugesmp.s sda=noprobe sdb=noprobe sdd=noprobe

unSpawn 05-23-2009 06:33 PM

@kay27: threads merged. Please don't open new threads on the same subject.

kay27 05-24-2009 03:25 AM

unSpawn, thank you.
H_TeXMeX_H, I tried, but problem partitions are still visible :( Anyway also thanx a lot. I've just started to explore setup scripts in Slackware :)

# which setup
/usr/lib/setup/setup

This is a script, not a binary. It calls /sbin/probe at first that is also a script. probe contain at the begin:
# This is 'probe', a wrapper for using fdisk to gather drive info for
# the Slackware setup scripts...

probe says 'Unable to seek on /dev/sda' and exit. That is the problem. It's here.

Analyzing script, I found that /sbin/probe use /proc/partitions that contain information about absolutely all partitions:

Code:

# cat /proc/partitions
major minor  #blocks  name

  8      0  244198584 sda
  8      1  30716248 sda1
  8      2    5116702 sda2
  8      3  409601272 sda3
  8      4          1 sda4
  8    16  244198584 sdb
  8    17  30716248 sdb1
  8    18    5116702 sdb2
  8    19  409601272 sdb3
  8    20          1 sdb4
  8    32  488386584 sdc
  8    33 .................
..............

I tried:
Code:

# chmod +w /proc/partitions
# chmod +w /proc
# ed /proc/partitions

and delete lines from 3 (minor 0) up to first inclustion of sdc... But 'w' command (in ed text editor) fail with: ""/proc/partitions", /proc/partitions: Input/output error". I still have no rights to write.

How I can edit this file? :)

H_TeXMeX_H 05-24-2009 04:52 AM

Try unmounting all the RAID drives before running setup, if they are mounted.

Code:

umount /dev/sda
umount /dev/sdb
umount /dev/sdd

If not, I think you can edit the setup script, possibly.

kay27 05-24-2009 07:52 AM

They are unmounted...

I tried to modify /sbin/probe so lot of time, but it seems, it *very* love to call fdisk -l everywhere :) so I find the brute force solution:

Code:

cp /sbin/fdisk /sbin/fdisk.org
echo fdisk.org -l /dev/sdc > /sbin/fdisk
setup

It is installing now :) I write it from cellphone.

H_TeXMeX_H 05-24-2009 07:54 AM

That's so odd that you have to do that. I wonder if this should be considered a bug or something.

kay27 05-24-2009 08:53 AM

No, H_TeXMeX_H, that was temporary installation environment, I think that way is more simple than to totally rewrite probe and setup scripts :)

It was successfully installed... but I can't do normal boot, only single user mode... of course "due to disk errors" :)
No kernel patch for matrix storage, no way to skip checking sda/sdb at the time of boot (?)... Don't know what to do.
Making fake raid - it was my big mistake. It's nowhere to migrate raid this time... They say ubuntu and freebsd have no such problem, maybe I'll try, but these are not the soft I want try)

H_TeXMeX_H 05-24-2009 09:39 AM

It would be nice if you posted the exact error where it fails, you might be able to comment something out of /etc/rc.d/rc.M.


All times are GMT -5. The time now is 04:35 AM.