-   Slackware - Installation (
-   -   I Have Slacked Almost (

ThomasLMcLean 06-09-2013 08:10 AM

I Have Slacked Almost
I have a i3-2220 in a Asus P8H77-V mother board, with 8 Gb of RAM, and a 40 Gb intel SSD.

I have loaded 14.0x86_64. I also have the book, Slackware Essentials, which has been a big help.

It boots up, I sign in as user then root, KDE comes up at the root command kdm, it works well. But I can not get the system to find the LAN, and then make the connection to the Internet.

I have not been able to make use of chapter 5 Network Configuration.

I would like someone that could help. My understand of the command line seem to be inadequate.


on the wet coast, in the sunshine: 06-09-2013 08:16 AM

find ethernet devices:
$ ifconfig -a

wake up the LAN (for example eth0)
$ su
# ifup eth0
# dhclient eth0 # may be unnecessary after ifup
# ping

allend 06-09-2013 08:27 AM

Boot your system, login as root, run 'netconfig'.


It boots up, I sign in as user then root, KDE comes up at the root command kdm, it works well.
If you are booting to runlevel 3 (the default in a fresh install), then you are best to start your GUI with 'startx'. You can select your choice of GUI prior to running startx with 'xwmconfig'

Have you seen this?
and the configuration guide?

onebuck 06-09-2013 09:26 AM

Member Response

Look at these links specifically;

Slackware Doc Project
  • Plus look at the links in my signature.

ThomasLMcLean 06-09-2013 09:24 PM

Thanks for the replies:

I did the following:

# netconfig

Filled in the blanks, chose DHCP, and added my centurylink user name.

# /etc/rc.d/rc.inet1 eth0_start

No comment and no smoke.

# ifconfig -a

lo: flags+73<UP, LOOPBACK, RUNNING> mtu 16436

inet netmask 255000
inet6 ::1 Prefixlen 128 scopeid 0x10<host>
Loop txqueue 0 (local loopback)
Rx Packets 0 bytes (0 .0.B)
Rx errors 0 dropped 0 overruns 0
Tx packets 0 bytes 0 (0.0.B)
Tx errors 0dropped 0 overruns 0 carrier 0 collisions 0

# ifup eth0
command not found

# dhclient eth0
SIOCSIFADDR: no such device.

So what does this tell us?

Tom McLean
on the wet coast;
with a beautiful evening

allend 06-09-2013 10:20 PM


# /etc/rc.d/rc.inet1 eth0_start
In Slackware, use '/etc/rc.d/rc.inet1 restart'.

# ifconfig -a
The output does not show your network card as being present.
What is the output of '/sbin/lspci'?

allend 06-09-2013 10:55 PM

Just to answer my own question, I reckon that the output of lspci will show an Atheros AR8161 ethernet controller. As I understand it, that device is not officially supported in the Linux kernel.
You will need to download and build the alx kernel module.

ThomasLMcLean 06-11-2013 07:49 AM


# /sbin/lspci
Athens Communication Inc. Device 1091 (Rev 08)

I have tried several other things suggested by the refeences given and no change.

Does this mean I have to build a kernel?

How do I do a new kernel or set of drivers with no Internet connection?

Tom McLean
On the Wet Coast,
Finally, with rain

allend 06-11-2013 11:37 AM


# /sbin/lspci
Athens Communication Inc. Device 1091 (Rev 08)
I would have expected something like this

02:00.0 Ethernet controller [0200]: Atheros Communications Inc. AR8161 Gigabit Ethernet [1969:1091] (rev 08)
Making allowance for the likelihood that you have manually transferred the information, it does seem likely that you need the alx kernel module.
Summarising from the links I gave and transferring to the Slackware way of doing things.
1. From download the file compat-drivers-2013-03-28-5-u.tar.xz (This can be done from any computer with internet access, such as the one you last posted from).
2. Transfer the file to your Slackware install e.g. use a USB key
3. Extract the file using 'tar xvf compat-drivers-2013-03-28-5-u.tar.xz'
4. Get into the directory that is created. 'cd compat-drivers-2013-03-28-5-u'
5. Run './scripts/driver-select alx'
6. Run 'make'
7. As root, create a directory for the module in the /lib/modules tree. 'mkdir /lib/modules/$(uname -r)/kernel/drivers/net/ethernet/atheros/alx/'
8. As root, copy the kernel module into the /lib/modules tree. 'cp ./drivers/net/ethernet/atheros/alx/alx.ko /lib/modules/$(uname -r)/kernel/drivers/net/ethernet/atheros/alx/'
9. As root, update the module dependencies with '/sbin/depmod -a'
10. As root, test with 'modprobe -v alx'

I have tested up to step 6. If all else fails, fit a supported network card in your PC :)

ThomasLMcLean 06-11-2013 07:22 PM



I believe that you are correct, I did manualy transfer the device ID and probably left off the intro. I will check that and see what I can get done on the rest. This amy take a day or two.

Tom McLean
On the Wet Coast,
again, with sunshine

ThomasLMcLean 07-09-2013 01:14 PM

Sorry for the delay. Too many things going on in my life.

The full line from; /sbin/lspci is:
03:00.0 Ethernet Controller: Atheros Communications Inc. Device 1091 (Rev 08)

I am guessing that the model number does not change things any. I still need the alx drivers.

I tried, but only got part way.

I down loaded the file: compat-drivers-2013-03-5-u.tar.xz and copied it to a CD.

The CD is loaded into the slack computer and I can find the file both in terminal mode and with KDE.

In KDE, I can also find the alx file. However, there is no indication that tar xvf works. I also do not get anything that makes sense to me from KDE, and therefore am not sure that the file has been compiled. Either the whole file or the alx folder. In the KDE help system I found information on how to make a file. But, do not know what to do with the 3 lines of code.

KDE is brand new to me and the command line only a little better.

I have the driver file on a CD and on my desktop in Ubuntu. What to do now?

Thanks for your help and patience.

Tom McLean
On the Wet Coast
In the full sun.

allend 07-09-2013 07:17 PM

Copy the file compat-drivers-2013-03-5-u.tar.xz from the CD to your Slackware system using the Dolphin file manager.
Then use 'Shift-F4' to open a Konsole terminal window. Proceed from step 3 in post #9

ThomasLMcLean 07-09-2013 08:52 PM

Thanks Allend;

I think that I managed to get it un-tarred (extracted). I extracted a copy to /home/thomas/ and it showed up there. There are 4 atl drivers in the package.

Which One? My system is 1 gigabit. The lspci gives it as device 1091. There are too many applications for the Atheros drivers to find this on either the Atheros or Asus sites. I will assume either ATL1E or ATL1C. Any comments?

I will switch computers and try your suggestion.

Tom McLean

ThomasLMcLean 07-09-2013 10:33 PM


I am apparently having trouble with the command line.
mkdir does not seem to work.

I type on the command line:
Bash-4.2# mkdir /lib/modules/-r/kernel/drivers/net/ethernet/atheros/alx/

I get:
Cannot create directory /lib/modules/-r/kernel/drivers/net/ethernet/atheros/alx/ : No such file or directory

What is up?



allend 07-09-2013 10:53 PM


type on the command line:
Bash-4.2# mkdir /lib/modules/-r/kernel/drivers/net/ethernet/atheros/alx/
Replace the -r with the output of 'uname -r'. Or type the line exactly as I wrote in post #9, using $(uname -r).

All times are GMT -5. The time now is 04:34 AM.