-   Slackware - Installation (
-   -   How to startx automatically (and a modem question) (

prcarp 02-12-2004 06:50 AM

How to startx automatically (and a modem question)
I just installed Slackware 9.1 (along with LILO and Windows) on my machine and just about everything works. I have a couple of questions:

1) I made a new user account and I log in at a text prompt. I start KDE (3.1) by doing startx and everything works. Question is, how do I get a graphical logon screen and pick the desktop environment I want? I went through the Kcontrol stuff and I thought it was set up via the tab that configured the logon. Is there a default boot script somewhere that can startx for me?

2) I have a USRobotics V.Everything modem, PCI flavor. Plug-n-play has made it int 4, and I/O address x278, not quite COM2. Using KPPP, I don't know which device to use or even how to configure this. Any thoughts? I originally had MandrakeLive and it worked with the modem just fine (KDE 3.2).


Nis 02-12-2004 06:59 AM

1. Edit a line in /etc/inittab from


This logs you into a Display Manager where you can change your window manager and login.

2. Don't know about this one. Sorry. :)

newinlinux 02-12-2004 06:22 PM

not sure if USR modem uses Lucent/Agere chips, if it uses, then you can grab the driver source from the link and compile it, it's easy with Slackware(but make sure you have all the required packages installed before you start)

newinlinux 02-12-2004 06:30 PM lot's of USR modems listed here, check them out.

prcarp 02-13-2004 06:49 AM

Thanks, Nis for the inittab pointer. That's what I was looking for.

As far as the V.Everything modem, this thing is not a Winmodem (I made sure of that a while back as I thought this platform may go Linux). I will check the board later this weekend to see what chipset is on it.

I tried a couple of things that didn't work. I modified the /etc/rc.d/rc.serial and did a setserial /dev/ttS2 addr 0x2F8 port 4 (and then uncommented the line in /etc/rc.d/rc/S so that this script would run). I tried this so that I could select ttS2 in the KPP program. Didn't fly.

So I have two other things to try but don't know how to go about it.

1) Change /dev/modem to point to /dev/ttS5 (PCI modem). I am a newbie and I don't know how to do this. Any thoughts?

2) Figure out how to show /dev/ttS5 in the device list in KPPP. Right now, it only shows S1 through S4. I don't know how KPPP gets this list. I was contemplating grep'ing the source somewhere.


screw the USR modem and go get a cheapy 56k modem that is ISA flavor (and not a Winmodem). I am cheap myself so I really don't like this idea. ;)

Background: Slackware 9.1, KDE 3.1. I should point out that I tried MandrakeLive about a week or so ago and it found the modem just fine (and worked).

If anybody has ideas on this, thanks!


Shade 02-17-2004 11:34 AM

I don't have much to add to this, besides how to get rc.serial to run :-D

chmod +x /etc/rc.d/rc.serial

Makes the script executable and it'll run at boot.


edit to add: Hello from Northern VA and Richmond native ;)

shepper 02-20-2004 05:59 PM

I am using a USRobtics performance pro pci modem

You should not need any drivers. It is a full hardware modem is recognized as a serial device.

I am going to assume that you selected loopback for the network configuration part of you slackware install. If not then run "netconfig" as root.

If you had selected loopback at the install then you will need to get the correct link. In most setups the first pci com port is ttyS4. To get it working as root delete the symbolic link /dev/modem with "rm /dev/modem/"

Then make a new link to ttyS4 (com 5 in Windows) with the root command

"ln -s /dev/ttyS4 /dev/modem"

The last thing is setting up your dialup scripts. In kde this is simple using kppp. You can select the link you made in kppp (/dev/modem) If you are using gnome or the command line interface post back.

prcarp 02-20-2004 08:46 PM

Thanks a bunch!

I am now surfing from within Linux using Konqueror. I actually got fed up with my modem, yanked it out, and set the jumpers for non-PnP mode (int 3, addr x278 = /dev/ttyS1). Did the ln command to point /dev/modem to it and BAM - kppp now works.

I also did the inittab change and set runlevel to 4. Works like a champ.

One last question though:

The graphical login manager is Gnome and I would like to change the login manager itself to KDE (this is before I even log in and it reads the setting from somewhere else). I use KDE and set all the login stuff there but my settings don't reflect the characteristics I see when the login prompt is displayed. Where is the setting for the login manager(s) kept? I am guessing I need to change gdm to kdm somewhere.


PS: I got the latest "Running Linux" and "Linux in a Nutshell". Any other recommendations that would be good for a newbie?

johnw68 02-21-2004 12:40 PM

To make KDE the default make a symbolic link under /etc/X11/xinit
xinitrc should point to xinitrc.kde

To make it start on boot edit /etc/rc.d/rc.local to include the line:

prcarp 02-22-2004 09:26 AM

Thanks, johnw68.

I already had /etc/X11/xinit linked to xinitrc.kde.

I did the change to the /etc/rc.d/rc.local as you said but that had some very bad effects:
1) X took a very long time to boot up (I got impatient the first time and did the 3 finger salute).
2) The KDE login screen did eventually show up but although the mouse worked, keyboard did not (I believe something else was trapping the keystrokes).
3) Somehow I got past the KDE login and then the GNome login showed up. Logging out did the reverse. Looked like both kdm and gdm were running.

so... this is what I did
Removed the mod to rc.local and put it back as original.

While in that directory, I saw rc.# and I was thinking that the # corresponded to the init level. Good guess. I edited rc.4 and behold, gdm was started first if it was found, and if not, start kdm. I simply switched the order and now I have what I need. I installed *everything* when I put on Slackware 9.1.

Thanks for the pointer in the right direction.

johnw68 02-22-2004 09:58 AM

Glad you got it working. I've never installed *everything* because I always have to compile apache and php with a few special things. I've always used KDE and during the install phase of the *expert* selection it asks which window manager you want, so I just choose KDE at that point. You might want to look at the expert install. It lets you choose more detailed things, lets you see exactly what is going to be installed and everything you need is selected by default. I add things like Python and remove Apache.

All times are GMT -5. The time now is 06:46 PM.