LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - Installation
User Name
Password
Slackware - Installation This forum is for the discussion of installation issues with Slackware.

Notices


Reply
  Search this Thread
Old 12-07-2014, 10:23 PM   #1
mfoley
Senior Member
 
Registered: Oct 2008
Location: Columbus, Ohio USA
Distribution: Slackware
Posts: 1,789

Rep: Reputation: 139Reputation: 139
How to get displaylink USB to show text console


I have Slackware 14.1 newly installed. I have a displaylink USB adapter attached. I do get a green screen on the connected monitor when booted. The Displaylink appears in lsusb, and appears to be described in /sys/devices/pci0000:00/0000:00:1d.7/usb1/1-1/1-1.2/graphics/fb1/

I'd like to have my text console appear on the displayLink monitor. I've found LOTS of search hits on getting this to run X (which I actually did with a previous Ubuntu installation), but I don't want X, just simple text console.

How?
 
Old 12-15-2014, 12:43 AM   #2
mfoley
Senior Member
 
Registered: Oct 2008
Location: Columbus, Ohio USA
Distribution: Slackware
Posts: 1,789

Original Poster
Rep: Reputation: 139Reputation: 139
No one has any ideas on this one?
 
Old 12-18-2014, 12:47 AM   #3
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2.1.2 on Lenovo Thinkpad W520
Posts: 9,480

Rep: Reputation: Disabled
Blind guess: includes nomodeset in your command line to prevent using a frame buffer.
 
Old 12-18-2014, 01:37 PM   #4
mfoley
Senior Member
 
Registered: Oct 2008
Location: Columbus, Ohio USA
Distribution: Slackware
Posts: 1,789

Original Poster
Rep: Reputation: 139Reputation: 139
Nice guess, but no go. This seems like it should be simple ... just map console video to displaylink, oh well.

Here my dmesg output related to the displaylink. Looks promising, but just not getting things to the displaylink monitor. It seems to have allocated fb1 - how to get console out there ...?

[ 14.428177] udlfb: 720x400 @ 70 Hz valid mode
[ 14.428182] udlfb: 640x480 @ 60 Hz valid mode
[ 14.428186] udlfb: 640x480 @ 72 Hz valid mode
[ 14.428191] udlfb: 640x480 @ 75 Hz valid mode
[ 14.428195] udlfb: 800x600 @ 56 Hz valid mode
[ 14.428198] udlfb: 800x600 @ 60 Hz valid mode
[ 14.428201] udlfb: 800x600 @ 72 Hz valid mode
[ 14.428205] udlfb: 800x600 @ 75 Hz valid mode
[ 14.428208] udlfb: 1024x768 @ 60 Hz valid mode
[ 14.428211] udlfb: 1024x768 @ 70 Hz valid mode
[ 14.428215] udlfb: 1024x768 @ 75 Hz valid mode
[ 14.428218] udlfb: Reallocating framebuffer. Addresses will change!
[ 14.431530] udlfb: 1024x768 @ 60 Hz valid mode
[ 14.431535] udlfb: set_par mode 1024x768
[ 14.829320] udlfb: DisplayLink USB device /dev/fb1 attached. 1024x768 resolution. Using 3072K framebuffer memory
 
Old 12-18-2014, 01:47 PM   #5
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2.1.2 on Lenovo Thinkpad W520
Posts: 9,480

Rep: Reputation: Disabled
According to this page the udlfb kernel module is being obsoleted and replaced by udl.

I'd try to blacklist udlfb, and modprobe udl at boot time if it's not automatically loaded.

I checked, udl is configured as a module in Slackware kernels 3.10.17.

EDIT If not yet done, you could visit this forum.

Last edited by Didier Spaier; 12-18-2014 at 01:52 PM.
 
Old 12-18-2014, 11:31 PM   #6
mfoley
Senior Member
 
Registered: Oct 2008
Location: Columbus, Ohio USA
Distribution: Slackware
Posts: 1,789

Original Poster
Rep: Reputation: 139Reputation: 139
An lsmod on my Slackware 14.1 gives:

$ root@viao:~# lsmod | egrep "udlfb|udl"
udl 14949 0
drm_usb 1218 1 udl
udlfb 14780 0
fb_sys_fops 926 1 udlfb
syscopyarea 2914 2 udl,udlfb
sysfillrect 2990 2 udl,udlfb
sysimgblt 1859 2 udl,udlfb
drm_kms_helper 31444 2 udl,gma500_gfx
drm 192016 4 udl,drm_usb,drm_kms_helper,gma500_gfx

So I guess this means that both udl and udlfb are being loaded automatically?

> I'd try to blacklist udlfb, and modprobe udl at boot time if it's not automatically loaded.

newbie on this stuff, how do I "blacklist"?
 
Old 12-18-2014, 11:56 PM   #7
mfoley
Senior Member
 
Registered: Oct 2008
Location: Columbus, Ohio USA
Distribution: Slackware
Posts: 1,789

Original Poster
Rep: Reputation: 139Reputation: 139
OK,I found out about blacklisting. In the file /etc/modprobe.d/blacklist, I'd put:

blacklist udlfb

Right? A couple of links on this issue (/usr/src/linux-3.14.24/Documentation/fb/udlfb.txt and http://comments.gmane.org/gmane.comp...top.libdlo/653) suggested the following:

$ modprobe udlfb defio=1 console=1

and I've put this into /etc/modprobe.d/displaylink.conf:

options udlfb console=1

(which didn't work). But, now that I'm blacklisting udlfb, I suppose this file will no longer work.

Anyway, I've done the blacklist of udlfb, removed the displaylink.conf file from /etc/modprobe.d, kept your suggested nomodeset and rebooted. No change. also, udlfb is still in the lsmod list (meaning it is compile into the kerne?)

Still have the same dmesg results for udlfb (and udl?) below.

Suggestions?

[ 21.557589] udlfb: DisplayLink VGA Display Adapter - serial #111305
[ 21.564451] udlfb: vid_17e9&pid_02ee&rev_0103 driver's dlfb_data struct at f5209800
[ 21.571121] udlfb: console enable=1
[ 21.577748] udlfb: fb_defio enable=1
[ 21.584301] udlfb: shadow enable=1
[ 21.591904] udlfb: vendor descriptor length:1b data:1b 5f 01 0019 05 00 01 03 00 04
[ 21.598602] udlfb: DL chip limited to 2080000 pixel modes
[ 21.605653] udlfb: allocated 4 65024 byte urbs
[ 21.613633] usbcore: registered new interface driver udlfb
[ 21.631535] usbcore: registered new interface driver btusb
[ 21.715384] udlfb: 1024x768 @ 60 Hz valid mode
[ 21.721975] udlfb: 720x400 @ 70 Hz valid mode
[ 21.728500] udlfb: 640x480 @ 60 Hz valid mode
[ 21.734877] udlfb: 640x480 @ 72 Hz valid mode
[ 21.741079] udlfb: 640x480 @ 75 Hz valid mode
[ 21.747208] udlfb: 800x600 @ 56 Hz valid mode
[ 21.753310] udlfb: 800x600 @ 60 Hz valid mode
[ 21.759334] udlfb: 800x600 @ 72 Hz valid mode
[ 21.765086] udlfb: 800x600 @ 75 Hz valid mode
[ 21.770855] udlfb: 1024x768 @ 60 Hz valid mode
[ 21.776410] udlfb: 1024x768 @ 70 Hz valid mode
[ 21.781879] udlfb: 1024x768 @ 75 Hz valid mode
[ 21.787207] udlfb: Reallocating framebuffer. Addresses will change!
[ 21.795649] udlfb: 1024x768 @ 60 Hz valid mode
[ 21.800918] udlfb: set_par mode 1024x768
[ 21.820668] udlfb: DisplayLink USB device /dev/fb1 attached. 1024x768 resolution. Using 3072K framebuffer memory
:
:
[ 22.298144] usbcore: registered new interface driver udl

Last edited by mfoley; 12-19-2014 at 12:00 AM.
 
Old 12-19-2014, 01:15 AM   #8
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2.1.2 on Lenovo Thinkpad W520
Posts: 9,480

Rep: Reputation: Disabled
udl and udlfb are configured as modules in both generic and huge Slackware kernels.

To blacklist the module udlfb, write only this in /etc/modprobe.d/blacklist_udlfb.conf:
Code:
blacklist udlfb
The name of the file doesn't matter, but it should end in .conf, otherwise it will be silently ignored.

PS of course don't provide options for that module if you blacklist it.

Small tips, examples of commands to know if a driver is configured as a module and the options available if the answer is yes, (the second command should be typed as root):
Code:
grep -i udlfb /boot/config*
modinfo udlfb

Last edited by Didier Spaier; 12-19-2014 at 03:11 AM. Reason: PS added
 
Old 12-19-2014, 03:31 AM   #9
turtleli
Member
 
Registered: Aug 2012
Location: UK
Posts: 206

Rep: Reputation: Disabled
Is the device framebuffer connected to the framebuffer console?

See https://www.kernel.org/doc/Documentation/fb/fbcon.txt, I think the fbcon=map: stuff might be useful to you.
 
Old 12-22-2014, 11:05 PM   #10
mfoley
Senior Member
 
Registered: Oct 2008
Location: Columbus, Ohio USA
Distribution: Slackware
Posts: 1,789

Original Poster
Rep: Reputation: 139Reputation: 139
Duh! I didn't have my blacklist file named as blacklist.conf. I renamed the file correctly, rebooted and had a different outcome. No green screen, but nothing on external VGA screen at all. Related dmesg output:

[ 13.410974] fbcon: psbdrmfb (fb0) is primary device
[ 13.554200] uvcvideo: Found UVC 1.00 device <unnamed> (05ca:18b2)
[ 13.558034] input: UVC Camera (05ca:18b2) as /devices/pci0000:00/0000:00:1d.7/usb4/4-8/4-8:1.0/input/input10
[ 13.559627] usbcore: registered new interface driver uvcvideo
[ 13.559629] USB Video Class driver (1.1.1)
[ 13.662413] usb 4-1.2: new high-speed USB device number 6 using ehci-pci
[ 13.741401] usb 4-1.2: New USB device found, idVendor=17e9, idProduct=02ee
[ 13.741408] usb 4-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 13.741413] usb 4-1.2: Product: VGA Display Adapter
[ 13.741418] usb 4-1.2: Manufacturer: DisplayLink
[ 13.741422] usb 4-1.2: SerialNumber: 111305
[ 13.771434] Console: switching to colour frame buffer device 200x48
[ 13.796076] gma500 0000:00:02.0: fb0: psbdrmfb frame buffer device
[ 13.796254] gma500 0000:00:02.0: registered panic notifier
[ 13.796558] gma500 0000:00:02.0: Backlight lvds set brightness 7a127a12
[ 13.796806] [drm] Initialized gma500 1.0.0 2011-06-06 for 0000:00:02.0 on minor 0
[ 13.821687] usb 4-1.3: new high-speed USB device number 7 using ehci-pci
[ 13.896072] gma500 0000:00:02.0: Backlight lvds set brightness 7a127a12

I read elsewhere about needing to disable gma500 as well. Do you agree?

I'll check out your framebuffer console link now.
 
Old 12-22-2014, 11:20 PM   #11
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2.1.2 on Lenovo Thinkpad W520
Posts: 9,480

Rep: Reputation: Disabled
Quote:
Originally Posted by mfoley View Post
I read elsewhere about needing to disable gma500 as well. Do you agree?
You may try. Be aware that the exact name of the module is gma500_gfx, so write this then:
Code:
blacklist gma500_gfx
 
Old 12-23-2014, 01:07 AM   #12
mfoley
Senior Member
 
Registered: Oct 2008
Location: Columbus, Ohio USA
Distribution: Slackware
Posts: 1,789

Original Poster
Rep: Reputation: 139Reputation: 139
I checked out your https://www.kernel.org/doc/Documentation/fb/fbcon.txt link ... That simply worked! I put

append="nomodeset fbcon=map:1 vt.default_utf8=0"

into lilo.conf and voila! The VGA screen showed the console. I can use `setfont -C /dev/console` to change the font size. I do not have to blacklist udlfb for this to work.

I *knew* it had to be a simple solution.

Two issues:

Putting this in lilo.conf makes it always send the console to the VGA, even if not connected; in which case I have *no* console screen. Is there a way to a) specify this option at boot time? I haven't been able to figure out how the get that nice "boot options" prompt like the installation DVD has. b) even more preferable, is there a post-boot command I can run to change the console map?

One interesting note: when fbcon=map:1 is in effect a `shutdown -r now` takes about 3 minutes before I see the boot menu. Without that option rebooting is pretty much instant. Any theories on that?
 
Old 12-25-2014, 05:41 AM   #13
turtleli
Member
 
Registered: Aug 2012
Location: UK
Posts: 206

Rep: Reputation: Disabled
Boot time option: Add another lilo entry? (As a side note, is nomodeset actually doing anything useful for your setup?)
Post boot time option: The documentation suggests to use con2fbmap. The debian fbset package has this, it's in the fbset_2.1-28.debian.tar.xz file as a patch, I suppose you could just download that and

Code:
patch -i /path_to_package/debian/patches/03_con2fbmap.patch
gcc -o con2fbmap con2fbmap.c
to create the binary and man page. See if that works.

Are there any useful messages and/or does it appear to wait at anything while it is shutting down when using the fbcon=map:1 option? If con2fbmap works, perhaps you could try switching the consoles back to the other display before rebooting as a workaround.
 
Old 12-29-2014, 07:40 PM   #14
mfoley
Senior Member
 
Registered: Oct 2008
Location: Columbus, Ohio USA
Distribution: Slackware
Posts: 1,789

Original Poster
Rep: Reputation: 139Reputation: 139
My final solution was to have 2 lilo boot options, one with "fbcon=map:1", one without. The default boot option is without fbcon. So, if I have an external VGA connected to my computer I simply select the "Linux_extVGA" boot option at startup.
 
  


Reply

Tags
console, displaylink


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
We want Displaylink Drivers - Show your Support! Lop3 Linux - General 2 10-06-2014 12:17 PM
DisplayLink USB graphic adapter & Intel i915 romagnolo Linux - Hardware 5 06-08-2014 07:48 PM
LXer: One, Two, Three, or More - View It with DisplayLink and USB LXer Syndicated Linux News 0 05-20-2009 09:31 PM
LXer: DisplayLink Releases USB Display Drivers under LGPL LXer Syndicated Linux News 0 05-18-2009 08:10 PM
LXer: DisplayLink Provides USB GPU Support On Linux LXer Syndicated Linux News 0 05-16-2009 06:12 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - Installation

All times are GMT -5. The time now is 02:18 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration