LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - Installation
User Name
Password
Slackware - Installation This forum is for the discussion of installation issues with Slackware.

Notices

Reply
 
Search this Thread
Old 06-20-2008, 07:09 PM   #1
Dark Horse
LQ Newbie
 
Registered: Jun 2008
Location: Austin TX.
Distribution: WinXP, Ubuntu Studio
Posts: 4

Rep: Reputation: 0
How do I make the nvidia driver recognize my monitor


This is my first time to install Slackware and every thing was going well
had the resolution right with the vesa drivers. then I decided to install the Nvidia drivers that was a mistake now resolution is at 640x480 at best does any body know how to make the nvidia driver recognize my monitor correctly? I have tried several searches have found nothing useful yet.
Mark
 
Old 06-20-2008, 08:29 PM   #2
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
You should indicate what monitor you have. Also post the relevent sections of your xorg.conf file.
Check the most recent Xorg log in /var/log/. Errors are on lines preceded with (EE).

One thing that can cause a problem is if your vertical and horizontal rates are off for the monitor in the monitor section.

Also try running (as root) the nvidia-xconfig script. That may fix up your device section in xorg.conf.

See if you have other resolutions in your xorg.conf "Screen" section. If you do, and the refresh rates look OK, consider using the gtf program to generate the modelines to use.

For example:
Code:
 gtf 1024 768 60 -x

  # 1024x768 @ 60.00 Hz (GTF) hsync: 47.70 kHz; pclk: 64.11 MHz
  Modeline "1024x768_60.00"  64.11  1024 1080 1184 1344  768 769 772 795  -HSync +Vsync
Copy the output from the terminal and past it into the xorg.conf file; in either the Monitor section, or if you xorg.conf has one in a "Modelines" section; add a "Use Modelines" line referencing the Modelines section in the Monitor section. ( It probably already does, and you may have an empty Modelines section as well ) Change the mode line label for "1024x768_60.00" to "1024x768_60".

The xorg.conf file has it's own manpage that you can reference while editing.
 
Old 06-20-2008, 08:55 PM   #3
thatquietboy
LQ Newbie
 
Registered: May 2008
Posts: 25

Rep: Reputation: 17
nvidia's linux support is very good, and their installer worked well for me...http://www.nvidia.com/object/linux_d...32_177.13.html
 
Old 06-20-2008, 09:34 PM   #4
Dark Horse
LQ Newbie
 
Registered: Jun 2008
Location: Austin TX.
Distribution: WinXP, Ubuntu Studio
Posts: 4

Original Poster
Rep: Reputation: 0
My monitor is a sun 21" n3 monitor with a Geforce 7150 on board video card I had the res right until I installed the nvidia driver. If I can find a way to get nvidia to use the right monitor instead of the default it will probably be OK. here is the xorgconfig file as it is now.
Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
Screen 1 "Screen1" RightOf "Screen0"
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
RgbPath "/usr/share/X11/rgb"
ModulePath "/usr/lib/xorg/modules"
FontPath "/usr/share/fonts/TTF"
FontPath "/usr/share/fonts/OTF"
FontPath "/usr/share/fonts/Type1"
FontPath "/usr/share/fonts/misc"
FontPath "/usr/share/fonts/75dpi/:unscaled"
EndSection

Section "Module"
Load "extmod"
Load "dri"
Load "dbe"
Load "xtrap"
Load "record"
Load "glx"
Load "type1"
Load "freetype"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us,us,us,us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
EndSection

Section "Monitor"
Identifier "Monitor1"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
EndSection

Section "Device"
Identifier "Card0"
Driver "nvidia"
VendorName "nVidia Corporation"
BoardName "Unknown Board"
BusID "PCI:0:16:0"
EndSection

Section "Device"
Identifier "Card1"
Driver "nvidia"
VendorName "nVidia Corporation"
BoardName "Unknown Board"
BusID "PCI:0:3:3"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 1
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 4
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 8
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 15
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "Screen"
Identifier "Screen1"
Device "Card1"
Monitor "Monitor1"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 1
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 4
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 8
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 15
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection


Here is the file generated by nvidia at install.

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder63) Thu Jun 5 00:10:21 PDT 2008


Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
RgbPath "/usr/share/X11/rgb"
ModulePath "/usr/lib/xorg/modules"
FontPath "/usr/share/fonts/TTF"
FontPath "/usr/share/fonts/OTF"
FontPath "/usr/share/fonts/Type1"
FontPath "/usr/share/fonts/misc"
FontPath "/usr/share/fonts/75dpi/:unscaled"
EndSection

Section "Module"
Load "extmod"
Load "dbe"
Load "xtrap"
Load "record"
Load "glx"
Load "type1"
Load "freetype"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us,us,us,us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
EndSection

Section "Device"

### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
### [arg]: arg optional
#Option "ShadowFB" # [<bool>]
#Option "DefaultRefresh" # [<bool>]
#Option "ModeSetClearScreen" # [<bool>]
Identifier "Card0"
Driver "nvidia"
VendorName "nVidia Corporation"
BoardName "Unknown Board"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 1
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 4
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 8
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 15
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

unfortunately I accidentally over wrote the file that was working right with all the resolutions for my monitor I will see if I can recreate it at least that will get me back where I was. Can I copy The xorgconfig file from Ubuntu ? I saw in another thread where someone suggested doing that with Knoppix If that works then it would probably solve the problem
 
Old 06-21-2008, 11:02 AM   #5
Dark Horse
LQ Newbie
 
Registered: Jun 2008
Location: Austin TX.
Distribution: WinXP, Ubuntu Studio
Posts: 4

Original Poster
Rep: Reputation: 0
Talking I found an answer that is working so far.

I had an Install of Ubuntu That is unstable on my system but the video & mouse drivers worked right I replaced the slack xorg.conf with the one from the Ubuntu Partition and so far it works.
Mark
 
Old 06-21-2008, 12:44 PM   #6
H_TeXMeX_H
Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269Reputation: 1269
Have you tried running 'nvidia-settings' and using that to set your resolution ?
 
Old 06-24-2008, 05:08 PM   #7
SCerovec
Member
 
Registered: Oct 2006
Location: Cp6uja
Distribution: Slackware and Porteus
Posts: 648

Rep: Reputation: 45
There is a file (/usr/doc/NVIDIA*/ ?) that has all options the applyed driver knows about.

I do print this file for personal reference and make wonders with my setup.

I usually make it 4 column/A4/portrait/7pt/fixed/condensed so i keep the line breaks and get a tight fit to A4 ;-)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
upgraded 7.4 to 7.10, now nvidia driver and dual monitor problems :( B33FST3W Ubuntu 1 01-30-2008 07:22 PM
Can't make Nvidia driver work on Fedora 7! tauro_kpo Linux - Software 3 06-04-2007 04:08 AM
How to Make Slack Recognize My Monitor? bongski55 Slackware 6 10-30-2003 01:34 AM
Nvidia Driver Install Problems, XF86Config, Monitor XavierP Linux - Software 2 03-31-2003 04:50 AM
how do i make redhat recognize my printer new printer driver Kilahchris Linux - General 2 03-04-2003 05:08 PM


All times are GMT -5. The time now is 10:41 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration