LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware - Installation (https://www.linuxquestions.org/questions/slackware-installation-40/)
-   -   Help with install (https://www.linuxquestions.org/questions/slackware-installation-40/help-with-install-934693/)

emeisner 03-15-2012 09:17 PM

Help with install
 
Hello Slackware peeps. I am fairly new to linux and had done a ton of reading via the internet about different distros and what a beginner should try first. I won't delve into that much seeing as that's not important. But what came of it is slackware. I had read a few places that slackware is a good distro to start with because it forces you to learn linux and me being a glutton for punishment, well, I'm here....

Question is. I installed slackware. Everything went pretty swell and I was prompted to restart my computer. When I restarted I got this flashing message...

grub:

That was it. Nothing more. Nothing less. I googled it for awhile and came up with no answers. Any ideas? I tried to go through the prompts again and reinstall slackware but now it says (during FULL install) packages are damaged. grrr.

Help please.

lisle2011 03-15-2012 09:47 PM

Slackware INstall Goes awry
 
Well nothing is perfect. But if you could answer a couple of questions perhaps we can get you going.

Were did you get the Slackware distro, did you download the ISO's and burn your own disks?

Was there a previous installation of some other OS on your system?

Every time I have installed a default Slackware install (that is a install everything option) it usually prompts me to install lilo, that is a Linux Loader, always works perfectly every time. So grub!

So it does seem like there is a boot loader already installed and it is not lilo. Give me some feedback and let's get you going.

emeisner 03-16-2012 08:12 AM

Thanks for the reply!

Yes, I had Archbang on there. I successfully got that going but from there didn't know what the heck was going on. lol.

It asked me about downloading lilo too but in the prompt it said that downloading it can cause problems and I got scared and said NO! Now I regret doing that. Oh, and I used a DVD that I bought from Slackware directly.

I really appreciate the help. I can't wait to get Slack going!!!

emeisner 03-16-2012 09:16 PM

ok
 
Ok I think I figured it out. At least I got it to download correctly. I do seem to have another problem though. Upon boot, I get the slackware linux start up menu, where it asks which OS I would like to boot in. Well, when I click linux it scrolls through a bunch of info and I get this message:

Welcome to Linux 2.6.37.6-smp (tty1)
darkstar login:

I'm assuming that's my root log in. So I log in and then I get root@darkstar:`#. I watched a few youtube videos and none of them went through this. They just booted onto the desktop then configured. Now, the only thing I skipped was the network setup because I wasn't sure at the moment. Could that be the issue?

Please don't be that hard on me. ha! I am an extreme newbie but want to be a SLACKER! =)

Thanks for any info you all can provide.

onebuck 03-17-2012 10:36 AM

Member response
 
Hi,

Welcome to LQ & Slackware!

First thing would be to use 'adduser' to create a new user. Be sure to add the user to the groups;
Code:

users floppy audio video cdrom plugdev power netdev burning
You will get the suggested users group after adding the new user to the 'users' group by pressing the Up-arrow at the next prompt to get the suggested groups(editable line). Please note the prompts as you go through the 'adduser' script.

The new user(s) will be the normal operational user(s) for your system. Maintenance will require 'root'.

For your network, Configuring your network in Slackware is Alien_Bob's excellent article on the way network cards are configured in Slackware. Loads of internal reference links for Ethernet & Wireless.

Two good references SlackwareŽ Essentials & SlackwareŽ Basics.

Another useful resource would be 'Slackware-Links'. More than just SlackwareŽ links!

emeisner 03-17-2012 05:56 PM

Quote:

Originally Posted by onebuck (Post 4629169)
Hi,

Welcome to LQ & Slackware!

First thing would be to use 'adduser' to create a new user. Be sure to add the user to the groups;
Code:

users floppy audio video cdrom plugdev power netdev burning
You will get the suggested users group after adding the new user to the 'users' group by pressing the Up-arrow at the next prompt to get the suggested groups(editable line). Please note the prompts as you go through the 'adduser' script.

The new user(s) will be the normal operational user(s) for your system. Maintenance will require 'root'.

For your network, Configuring your network in Slackware is Alien_Bob's excellent article on the way network cards are configured in Slackware. Loads of internal reference links for Ethernet & Wireless.

Two good references SlackwareŽ Essentials & SlackwareŽ Basics.

Another useful resource would be 'Slackware-Links'. More than just SlackwareŽ links!


Woohoo! Ok. Thanks for the help. After I did that and tried to boot. It says I have a fatal server error: no screens found! wth. So I am not able to startx. Would have been something that I did at install?

emeisner 03-17-2012 06:10 PM

This is the full message, if it helps:

(==) Log file: "/var/log/Xorg.0.log", Time: Sat Mar 17 22:59:37 2012
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(EE) Failed to load module "fbdev" (module does not exist, 0)
(II) [KMS] drm report modesetting isn't supported.
(EE) RADEON(0): Chipset: "AMD Radeon HD 6800 Series" (ChipID = 06739) requires KMS
(EE) Screens(s) found, but none have a usable configuration.

Fatal server error:
no screens found


What do you think? I have been looking through the Slackware essentials book. hmmmm.

lisle2011 03-17-2012 07:48 PM

Can't find usable display
 
fbdev is deprecated I believe at least in slackware.

check out /etc/X11/xdm/xdm-config

Should like kinda like this




!
!
!
!
!






DisplayManager.authDir: /var/lib/xdm
DisplayManager.errorLogFile: /var/log/xdm.log
DisplayManager.pidFile: /var/run/xdm.pid
DisplayManager.keyFile: /usr/lib/X11/xdm/xdm-keys
DisplayManager.servers: /usr/lib/X11/xdm/Xservers
DisplayManager.accessFile: /usr/lib/X11/xdm/Xaccess
DisplayManager*resources: /usr/lib/X11/xdm/Xresources
DisplayManager.willing: su nobody -c /usr/lib/X11/xdm/Xwilling
! All displays should use authorization, but we cannot be sure
! X terminals may not be configured that way, so they will require
! individual resource settings.
DisplayManager._0.authorize: true ------------------------------------------- this line needs to exist for sure
!
DisplayManager*chooser: /usr/lib/X11/xdm/chooser
DisplayManager*startup: /usr/lib/X11/xdm/Xstartup
DisplayManager*session: /usr/lib/X11/xdm/Xsession
DisplayManager*reset: /usr/lib/X11/xdm/Xreset

DisplayManager*authComplain: true
! The following three resources set up display :0 as the console.
DisplayManager._0.setup: /usr/lib/X11/xdm/Xsetup_0
DisplayManager._0.startup: /usr/lib/X11/xdm/GiveConsole
DisplayManager._0.reset: /usr/lib/X11/xdm/TakeConsole

DisplayManager*loginmoveInterval: 10

! SECURITY: do not listen for XDMCP or Chooser requests
! Comment out this line if you want to manage X terminals with xdm
DisplayManager.requestPort: 0
-------------------------------------------------------------------------

then change to /etc/X11/xinit and type ./xinit.kde and all should be well providing the line I indicated above is there.

TobiSGD 03-17-2012 08:13 PM

The drivers in Slackware 13.37 are not working correctly with the Radeon HD6800 series, you either have to use the proprietary AMD drivers or update your Mesa/libdrm packages with the ones from the /testing branch of the repository.

emeisner 03-18-2012 12:42 PM

Quote:

Originally Posted by lisle2011 (Post 4629449)
fbdev is deprecated I believe at least in slackware.

check out /etc/X11/xdm/xdm-config

Should like kinda like this




!
!
!
!
!






DisplayManager.authDir: /var/lib/xdm
DisplayManager.errorLogFile: /var/log/xdm.log
DisplayManager.pidFile: /var/run/xdm.pid
DisplayManager.keyFile: /usr/lib/X11/xdm/xdm-keys
DisplayManager.servers: /usr/lib/X11/xdm/Xservers
DisplayManager.accessFile: /usr/lib/X11/xdm/Xaccess
DisplayManager*resources: /usr/lib/X11/xdm/Xresources
DisplayManager.willing: su nobody -c /usr/lib/X11/xdm/Xwilling
! All displays should use authorization, but we cannot be sure
! X terminals may not be configured that way, so they will require
! individual resource settings.
DisplayManager._0.authorize: true ------------------------------------------- this line needs to exist for sure
!
DisplayManager*chooser: /usr/lib/X11/xdm/chooser
DisplayManager*startup: /usr/lib/X11/xdm/Xstartup
DisplayManager*session: /usr/lib/X11/xdm/Xsession
DisplayManager*reset: /usr/lib/X11/xdm/Xreset

DisplayManager*authComplain: true
! The following three resources set up display :0 as the console.
DisplayManager._0.setup: /usr/lib/X11/xdm/Xsetup_0
DisplayManager._0.startup: /usr/lib/X11/xdm/GiveConsole
DisplayManager._0.reset: /usr/lib/X11/xdm/TakeConsole

DisplayManager*loginmoveInterval: 10

! SECURITY: do not listen for XDMCP or Chooser requests
! Comment out this line if you want to manage X terminals with xdm
DisplayManager.requestPort: 0
-------------------------------------------------------------------------

then change to /etc/X11/xinit and type ./xinit.kde and all should be well providing the line I indicated above is there.


Thanks. That didn't seem to work. It say's I don't have permission. In root or regular log in.

emeisner 03-18-2012 12:43 PM

Quote:

Originally Posted by TobiSGD (Post 4629460)
The drivers in Slackware 13.37 are not working correctly with the Radeon HD6800 series, you either have to use the proprietary AMD drivers or update your Mesa/libdrm packages with the ones from the /testing branch of the repository.

Yeah, I'm new to this so I have no idea what you are saying. Can you explain a little more for me please? How do I go about doing that?

TobiSGD 03-18-2012 04:42 PM

Open a terminal and mount your Slackware DVD:
Code:

su -
mount /dev/sr0 /mnt

Then navigate to the testing repository:
Code:

cd /mnt/testing/packages
Now install the newer Mesa and libdrm packages:
Code:

upgradepkg libdrm*.t?z
upgradepkg mesa*.t?z

Now reboot the machine and try it again with
Code:

startx

emeisner 03-18-2012 04:55 PM

Quote:

Originally Posted by TobiSGD (Post 4630014)
Open a terminal and mount your Slackware DVD:
Code:

su -
mount /dev/sr0 /mnt

Then navigate to the testing repository:
Code:

cd /mnt/testing/packages
Now install the newer Mesa and libdrm packages:
Code:

upgradepkg libdrm*.t?z
upgradepkg mesa*.t?z

Now reboot the machine and try it again with
Code:

startx

Dang! I get the same error code!

TobiSGD 03-18-2012 05:00 PM

I wonder why, that has worked for me and my Radeon HD 6870.
Anyways, the next option would be to download the proprietary driver from the AMD website and install that, that should work in any case.

emeisner 03-18-2012 05:05 PM

Quote:

Originally Posted by TobiSGD (Post 4630014)
Open a terminal and mount your Slackware DVD:
Code:

su -
mount /dev/sr0 /mnt

Then navigate to the testing repository:
Code:

cd /mnt/testing/packages
Now install the newer Mesa and libdrm packages:
Code:

upgradepkg libdrm*.t?z
upgradepkg mesa*.t?z

Now reboot the machine and try it again with
Code:

startx

well when I type mount /dev/sr0 /mnt I get the following message:

mount: no medium found on /dev/sr0


All times are GMT -5. The time now is 07:51 PM.