-   Slackware - Installation (
-   -   Help: hard drive install slackware 12 from FAT32 partition using GRUB (

olin 09-19-2007 09:46 AM

Help: hard drive install slackware 12 from FAT32 partition using GRUB
First time to install Linux.

I try to install Slareware 12 on an old thinkpad 770 (233MHz, 64MB, no CD or 1.44 disk) from Windows NT 5.0 OS which alreay exists. I made four partitions in the IDE hard drive:
/dev/hda1 (C:\) (primary) for windows nt (fat32)
/dev/hda2 (primary) for linux /root (ext3)
/dev/hda5 (logical) for linux /user/local (ext3)
/dev/hda6 (logical) for linux swap

I downloaded Slackware 12 to C:\slackware folder and extracted the two files bzImage and intird.img and put them into C:\boot folder

I used GRUB to load kernel and initrd like below

title Slackware installation
kernel (hd0,0)/boot/bzImage rw root=/dev/ram load_ramdisk=1
initrd (hd0,0)/boot/intird.img

I tried a couple of kernels, only huge.s bzImage can let me into the setup interface (other kernels froze while loading). In the setup interface, everything worked fine. it could detect all the partitions for root, usr, swap and fat32, etc. But I found I did not enter the configure (kernel selection, timezone, etc...) menu like the Slackware essentials installation instructin shown,
It just told me I can reboot the computer and install. But after I rebooted, It did not start to install. I still had to select between Windows and GRUB.

I am an experienced MS Windows user and a C/C++ programming amateur but a totally newbie in GNU/Linux world. Could you please give me some help? Thank you very much!

olin 09-19-2007 10:12 AM

I guess the problem is that it cannot mount the C:\ (/dev/hda1) so that it cannot locate the installation files in C:\slackware

But the problem confused to me is when I ran setup (the graphic interface) and in the setup target partition menu, it detected there was a FAT32 partition and allowed me to add it in /etc/fstab and name it as fat-c and load successfully (show the device information). But when I quit setup, and typed mount, it only shown:
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
/dev/hda2 on /mnt type ext3 (rw)
/dev/hda5 on /mnt/usr/local type ext3 (rw)

if I typed mount /dev/hda1, it would give an error:
can't find /dev/hda1 in /etc/fstab or /etc/mtab

All times are GMT -5. The time now is 12:44 AM.