LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - Installation
User Name
Password
Slackware - Installation This forum is for the discussion of installation issues with Slackware.

Notices


Reply
  Search this Thread
Old 08-24-2019, 10:31 AM   #1
lancsuk
LQ Newbie
 
Registered: Jul 2019
Location: Burnley / UK
Distribution: Slackware 14.2
Posts: 7

Rep: Reputation: Disabled
Gtk+3 and Glib backports for Slackware 14.2?


Hiya,

I would like to know if there any chance to get Gtk+ 3.22 and Glib 2.49.4 packages for Slackware 14.2? Recently, I've created Xfce 4.14 packages on Slackware current, I would like to do the same with Slackware 14.2.

lancs

Last edited by lancsuk; 08-24-2019 at 10:45 AM.
 
Old 08-24-2019, 11:57 PM   #2
lancsuk
LQ Newbie
 
Registered: Jul 2019
Location: Burnley / UK
Distribution: Slackware 14.2
Posts: 7

Original Poster
Rep: Reputation: Disabled
Wow 107 viewer and nobody has any idea?

lancs
 
Old 08-25-2019, 10:20 AM   #3
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2.1.2 on Lenovo Thinkpad W520
Posts: 8,996

Rep: Reputation: 3639Reputation: 3639Reputation: 3639Reputation: 3639Reputation: 3639Reputation: 3639Reputation: 3639Reputation: 3639Reputation: 3639Reputation: 3639Reputation: 3639
Hello,

I am not an insider, but my bet is no.

Have a good day,
 
Old 08-25-2019, 11:05 AM   #4
ponce
Senior Member
 
Registered: Aug 2004
Location: Pisa, Italy
Distribution: Slackware
Posts: 4,985

Rep: Reputation: Disabled
Quote:
Originally Posted by lancsuk View Post
Hiya,
hello, welcome to LQ!

Quote:
Originally Posted by lancsuk View Post
I would like to know if there any chance to get Gtk+ 3.22 and Glib 2.49.4 packages for Slackware 14.2?
in 20 years that I'm using Slackware I don't remember an update to another major version of the gtk+ stack for a stable release, so, like Didier, I suppose the answer could be no...

Last edited by ponce; 08-25-2019 at 11:07 AM.
 
1 members found this post helpful.
Old 08-25-2019, 02:20 PM   #5
Didier Spaier
LQ Addict
 
Registered: Nov 2008
Location: Paris, France
Distribution: Slint64-14.2.1.2 on Lenovo Thinkpad W520
Posts: 8,996

Rep: Reputation: 3639Reputation: 3639Reputation: 3639Reputation: 3639Reputation: 3639Reputation: 3639Reputation: 3639Reputation: 3639Reputation: 3639Reputation: 3639Reputation: 3639
Let me add that, being also interested to upgrade glib2 and gtk+3, I made some experiments today. After a quick and dirty checking, it looks like you need to upgrade first glib2, fontconfig, freetype, harfbuzz, cairo, pango (I tried with the versions shipped in -current at time of writing).

However I failed to build a newer glib2 for some reason (It seemed to need an upgrade of glibc). Maybe I made mistakes, but it looks like a show stopper, at least for me and for now.
 
1 members found this post helpful.
Old 08-25-2019, 11:00 PM   #6
lancsuk
LQ Newbie
 
Registered: Jul 2019
Location: Burnley / UK
Distribution: Slackware 14.2
Posts: 7

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Didier Spaier View Post
Let me add that, being also interested to upgrade glib2 and gtk+3, I made some experiments today. After a quick and dirty checking, it looks like you need to upgrade first glib2, fontconfig, freetype, harfbuzz, cairo, pango (I tried with the versions shipped in -current at time of writing).

However I failed to build a newer glib2 for some reason (It seemed to need an upgrade of glibc). Maybe I made mistakes, but it looks like a show stopper, at least for me and for now.
Thanks for your help, it was helping a lot. I've packaged quick&dirty no slack-desc...just makepkg.

Order:

glib-2.56.1
cairo-1.14.12
gobject-introspection-1.56.1
gdk-pixbuf-2.36.12
fontconfig-2.13.0
freetype-2.10.1 ( tricky )
harfbuzz-1.8.8
pango-1.42.3
atk-2.29.2
at-spi2-core-2.28.0
at-spi2-atk-2.26.2
vala ( slackbuild )
libgusb-0.3.0
colord-1.4.3
gtk+-3.22.30

Thanks a lot!

Last edited by lancsuk; 08-26-2019 at 12:35 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] stable-backports distribution spec not known to backports.debian.org jhwilliams Debian 7 05-31-2012 05:31 AM
GTK+ programs on Windows without having to install GTK+, GLib, etc Nylex Programming 2 02-19-2006 01:33 PM
Freerock uninstall stole GTK looking for up-to-date pango, atk, gtk, glib and xft tgz Oholiab Slackware 8 09-18-2005 11:57 AM
can't install gtk 2.4.4: "Requested 'glib-2.0 >= 2.4.0' but version of GLib is 2.2.3 webazoid Linux - Software 0 07-15-2004 06:07 PM
Problems relating to glib 1.2.10 and glib 1.2.9 p3ngu!n Mandriva 10 05-23-2004 09:03 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - Installation

All times are GMT -5. The time now is 03:34 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration