-   Slackware - Installation (
-   -   GRUB loading Error 17 (

cmlal 11-08-2005 03:56 PM

GRUB loading Error 17

I am a newbie and I realize I have probably dived in at the deep end with this and I need some help swimming.

I used SuSE before, but people kinda kept telling to get a Real Distro. So today, after only having used Linux for two weeks, I made an attempt to install Slack. The installtion process sure is different, heh.

I got till the end, however, having made the partitions and selected things to install and watched it install a lot of stuff that I don't understand, and then I got the instructions to exit the setup and reboot with ctrl alt del. I did that and now I get this at startup

GRUB Loading stage 1.5.
GRUB loading, please wait...
Error 17

And then nothing happens. I have no idea what this means!

I am using Slax to get online now, really grateful for live cds...

Any and all help would be greatly appreciated!

saikee 11-08-2005 05:03 PM

List out the content of

typing command fdisk -l at root terminal

and the files for the Slack's



here. I thought Slackware use Lilo by default, what version are you using?

The above files will tell us your partition scheme, Grub's boot control file and the partition Grub has been order to mount.

Error 17 in Grub is "Cannot mount selected partition"

cmlal 11-08-2005 05:29 PM

Thanks so much for your helpful advice!

I chickened out though and went back to SuSE. (I'm probably going to give Slack another try a bit further down the line. For now I just need a working computer.) I think maybe I know what I did wrong though. I think I forgot to mount the partitions. Will definitely remember that the next time.

saikee 11-08-2005 05:40 PM

You can add as many distros to you box as you like. All you need is about 5Gb hard disk space per distro. I have 50+ systems and about 42 of them are Linux.

No need to chicken out just add one distro whenever you have time. Grub can boot the whole lot.

LightOfErindir 11-12-2005 07:46 AM

I'm having very similar r the details....

I'm trying to install Slackware 10.1 on my other machine. It does NOT have Windoze.

Distro: Slackware 10.1 (4CD - 2CD bin, 2CD sources)

Processor: p4 1.6 Ghz 32 bit
Motherboard: Intel 845 GLAD
Samsung 40 GB HDD (IDE)
Samsung CD R/RW drive
USB mouse and Keyboard.

The HDD is partitioned like this:
/dev/hda1 ---> ext3 ----> / (6GB Approx)
/dev/hda2 ---> ext3 ----> /home (15GB Approx.)
/dev/hda3 --->swap ---->swap (300 MB Approx. )....128 MB physical RAM.

The Problem:
The PC hangs at GRUB prompt and beeps the motherboard speaker continuously. It does not respond to KBD.
Before that it installs all the packages without problem.

I've tried to disable hotplug but it still hangs.

HELP NEEDED desparately...

saikee 11-12-2005 08:31 AM


The standard method to get inside an unbootable Linux is either by its installation CD or boot it up to a Live CD.

In both case you need to boot up a kernel in command shell, mount the distressed distro and change root to it. Say if you boot to a Live CD or Slackware installation CD and in bash shell (your / partition of Slackware is hda1)

mkdir /mnt/hda1
mount /dev/hda1 /mnt/hda1
chroot /mnt/hda1

If the above works you should see the command prompt sign changes slightly, signifying you are now inside the distressed Slackware.

You can then try to replicate the boot loader in the MBR again or in a floppy by stataement

grub-install /dev/hda<---- hda means whole disk
grub-install /dev/fd0<----- enable you to boot from a floppy

However if the boot loader has not been installed properly your /boot/grub/menu.lst may not be complete and the above could only boot up a defective Grub unable to pull Slackware up. The cure to this depends on how bad a state Grub is in.

You can list Slackware's /boot/grub/menu.lst here

Your Slackware 10 should be bootable if the /boot/grub/menu.lst has the following entries

title Slackware
root (hd0,0)
kernel /boot/vmlinuz root=/dev/hda1 ro


As you haven't seen Slackware boot loader I have a bad feeling that you may not know what Grub looks like because Slackware comes standard with Lilo as the boot loader. I personally downloaded Grub 0.97 and installed it in the last two versions of Slackware. If your Slackware does have a Lilo then it should boot if its /etc/lilo.conf has these entries


If everything fails then I would go for a re-install

LightOfErindir 11-15-2005 09:59 AM

Problem solved...i forced LILO to install in it's booting fine...but there's another prob....X server won't says inetd socket not found....i checked that inetd was running...wat can be the prob?

rinkrat248 11-27-2005 12:03 PM

I did an installation of Slackware 10.2 w/ no X-Windows. I was prompted to setup LILO during the installation and did so. /etc/lilo.conf looks fine.

When I try to boot up from the hard drive it says the same GRUB loading error described above. When I look for /boot/grub/ the folder is not found.

This seems to be some kind of problem with the installation script eh?

saikee 11-27-2005 12:29 PM

The standard command to fire up X-windows is to type


at the terminal. If X-windows has been installed then there is nothing we can do. If X-windows didn't fire up due an error then it is a matter to amend xorg.conf which is stored in /etc/X11 directory.

If you make a Grub floppy unattached to an operating system, described in Chapter 3.1 of Grub Manual using just a Live CD that supports Grub like Ubuntu or Mepis, then you can boot up this floppy and fire up Slackware manually using these lines

root (hdi,j) <-----i=disk No., j=partition No. and Grub counts from 0
kernel /boot/vmlinuz ro root=/dev/hdxy <-------- suppy hdxy as the root partition of Slackare

That is the way I boot up my Slackware 10.1 and 10.2 after the installation.

Grub floppy gets you into a Grub prompt. You can ask Grub to find out where Slackwar stores the kernel by typing

find /boot/vmlinuz <--- Grub will tell you which (hdi,j) got it

Once you fire up Slackware install Lilo again by typing at the terminal

lilo -b /dev/hda

dasy2k1 11-27-2005 03:45 PM

i have had this problem for ages...
either an error 17 or 15, (it changes depending on mood)
the cox is fully useable... i just have to boot with a boiot floppy and it woirks fine
kinda anoying but bearable

saikee 11-27-2005 04:39 PM


Look once you boot up the Linux just restore its boot loader into MBR using

grub-install /dev/hda for Grub

lilo -b /dev/hda for Lilo

and no need to use the floppy any more. What is annoying?

dasy2k1 11-28-2005 01:44 PM

hmmm i tried
thge lilo option but now when i boot my machine
it dousent recognise my hard drive at al...
and when i try with the boot disk i get the folowing:

VFS: Cannot open root device "hda1" or 03:01
Please append a correct "root=" boot option
Kernel panic: VFS: Unable to mount root fs on 03:01

i then tryed specifying the following parameters at the boot: prompt

mount root=/dev/hda bare.i
giving the same result.

what should i try now?

dasy2k1 11-28-2005 03:00 PM

well i halted my machine for a while and tehn started itr again and lo and behold the HDD was recognised again!

seems that this machine has a habit of this as i remember a simmaliar thing happenning when it still ran Windowz 98 SE

now i get lilo when i start and the annoying bootdisk is out of a job!
for some starnge reason though ttl1 has an image of tux sitting at the top and all text is so minute that you can barley read it! no good if you dont want to use x (using ttl2 works fine though)

crapodino 11-28-2005 03:17 PM

i had windows. then i installed suse 10 with grub in mbr. I works perfectly for a week. Today i did an "disk optimicer" from Norton System Wotks in a windows partition and when i restart the pc i have the grub error 17.

I don't have any rescue disk. I only have suse 10 cds

please...i really need to solve this problem

crapodino 11-28-2005 03:23 PM

i didn't change nathing but the optimittation disk!!!

i can't believe it!

All times are GMT -5. The time now is 03:50 PM.