-   Slackware - Installation (
-   -   gnumeric gnomeslackbuild slackware 13.0 (

Ben Cobb 10-24-2009 07:33 AM

gnumeric gnomeslackbuild slackware 13.0
Recently installed slackware 13.0. Added the gnome from
Everything works fine except gnumeric. It comes up fine and behaves with
a new sheet but a lot of things don't work if I load one of my active

Noticed the version that came from slackbuild was older (1.8 something) than
the one I have been using (1.9.1). Removed 1.8 and installed 1.9.1. It was
missing a library which I added.

Tried reinsalling slackware 13.0 and did a net install of the gnome suite
(first time I installed gnome I did it step by step). Had the same results.

Running gnumeric from xterm shows me some of the errors:

(gnumeric:3496): GLib-GObject-WARNING **: specified class size for type
`GnmGODataScalar' is smaller than the parent type's `GODataScalar' class size

(gnumeric:3518): GLib-GObject-WARNING **: specified class size for type
`GnmGODataMatrix' is smaller than the parent type's `GODataMatrix' class size

** (gnumeric:3518): CRITICAL **: scg_edit_start: assertion
`IS_SHEET_CONTROL_GUI (scg)' failed

** (gnumeric:3518): CRITICAL **: wbcg_edit_finish: assertion `IS_SHEET
(wbcg->editing_sheet)' failed

some of the old spread sheets work - some don't

Ben Cobb 10-24-2009 09:40 AM

the plot thickens as on another machine (13.0) gnumeric seems to work

get a couple of error messages but everything works - thought I had done a similar install there.

the next day it started working on my main machine - see what happens tomorrow

Ben Cobb 10-28-2009 03:45 PM

problem is most likely as when running 12.1 I added gnome from gslaky ( which provided gnumeric 1.9.1. I added gnome for 13.0 from gnomeslackbuild which had gnumeric 1.8.4.

Have had some success rebooting to 12.1, running gnumeric 1.9.1 there and exporting to an .xls file then rebooting to 13.0 and opening the .xls file with gnumeric 1.9.1.

luckily I only have a few spreadsheets to convert (if this continues to work).

appendum: above works only somethimes think I will stick with 1.8.4, found I can cut and past from an older spreadsheet (values only) then add the formulas by hand.

Ben Cobb 10-29-2009 07:39 AM

still get too many errors - think I will switch to openoffice.

have been trying multiple things. upgraded goffice, got gnumeric to work - seems to be erratic -works on some boots not others. on last try (from a compile for gnumeric complained about a missing library. will recomlile goffice from slackbuild as I don't think I looked for errors when it finished.

Ben Cobb 11-01-2009 07:21 AM

so when do you stop fussing (exploring)? Have upgraded, downgraded, compiled, moved libraries for the past week. still get error messages and sometimes it works then doesn't.

found if I reboot to slackware 12.1 have gnumeric save my spreadsheets to .xls format. OpenOffice reads everything (including formulas) fine.

think I will switch and find something else to do.

All times are GMT -5. The time now is 10:03 PM.