-   Slackware - Installation (
-   -   Fresh Slackware 9.1 installation requires boot disk to boot (

smithtodda 06-14-2004 10:56 PM

Fresh Slackware 9.1 installation requires boot disk to boot
Hi, I recently installed Slackware 9.1 successfully on one of my machines, but I think I may have picked the wrong option on the kernel selection screen during the installation. (I'm just guessing, I don't know that I actually picked the wrong option.) Anyway, now in order to boot the machine, I have to supply the boot disk that I made during the installation. Is there any way to reconfigure things so that it'll boot from a kernel on the HD? I'm assuming I can accomplish this without reinstalling. Thanks.


slakmagik 06-14-2004 11:48 PM

You probably need to edit /etc/lilo.conf and run 'lilo' as root. If lilo's not even installed, you'd need to install that, then do the above. ...Try running /sbin/liloconfig, actually. I've never tried to install lilo on Slackware after an install (just Basic and maybe some other distros) but it should work. As always with this stuff, be careful.

linda 06-20-2004 07:01 PM

I, too, just did an install of Slackware 9.1. When it got to the part of installing Lilo, i got an error message of Lilo not being able to be installed. First I chose the Simple "Try to install LILO automatically" I chose to install to my /, which is hdb3. That didn't work, so i tried to install to a floppy: that didn't work either.
Any suggestions? It's slow booting from a floppy!

slakmagik 06-20-2004 08:45 PM

As above, have you tried running liloconfig or editing lilo.conf manually and running lilo?

Also, what were the error messages; what type of filesystem are you using; what other systems are on your box; could BIOS settings be an issue? Have you run 'expert' and/or tried to install lilo to the MBR?

Also, there's suddenly been a burst of people seeming to have this sort of trouble, so search around, if you haven't yet, and see if any of their experiences help.

Lastly, if you installed from a CD, you should be able to boot from it, too - not as fast as hard drive, but faster than floppy. At the boot prompt, 'bare.i root=/dev/hdb3 noinitrd ro'. The Slack CD has extensive documentation (some somewhat out of date but essentially accurate).

linda 06-21-2004 08:30 AM

I think liloconfig is the command I used to get the menus described above. I tried it during the install, and again after everything was set up. I do have a boot disk, but that's all.

How do you "run" lilo? My error message said it was not installed, so can I even run it?

The error message was pretty much "Error #1 Lilo was not installed." I'll go back and write it down exactly, but each attempt got me the same error message.

I am running Slack 9.1, / on hdb3, and /boot on hdb1. On hda1 I have winxp. I don't really think Bios could be a problem, because I had Lilo working with another distro a few years ago.

I have tried "expert" but that did not work either. The ONLY thing I did not try was to install Lilo to my MBR. It actually surprised me that I could not install it to even a floppy.

Could you post what the lilo.conf should have on it? I have been reading a lot of posts about Lilo not working, too. I am wondering if it is a slack problem? I am following the Chapter 7 Booting instructions for Lilo. I go all the way through as described, but at the end it says Lilo was not installed. I'm going to go look at exactly what that message was... :-)

slakmagik 06-21-2004 11:54 PM

I'm not sure about something. 'which lilo' (as root) does return a result, right? The 'not installed' is lilo's error message regarding 'installing' to a boot sector?

If it's not installed, just mount your installation medium and installpkg from there. By 'running it' I just mean issue the command at a prompt in order to reinstall it (or maybe in this case to install it. :) )

If it's failing to install (which is what it sounds like) it probably is an error in the lilo.conf. Post that up.

As far as it goes, it's going to vary from setup to setup.

boot = /dev/hda                    # device containing the boot sector
default=Slack                      # default system to boot by label
message = /boot/boot_message.txt    # eh...
prompt                              # means let me pick the system without keyboard gymnastics
timeout = 50                        # but do Slack in 5 seconds
change-rules                        # something about not rewriting the boot-sector
  vga = 773                        # gimme a big screen with the framebuffer
...                                # snip a zillion entries
image = /boot/vmlinuz-generic-2.6.7 # fullname of the kernel
  label = slackwareB                # what lilo's menu displays
  root = /dev/hdb5                  # where the root fs is
  initrd = /boot/initrd.gz          # need an initial ramdisk in this case
  read-only                        # mount it read-only initially for fsck
other = /dev/hdb1                  # call this other because it's not Linux
  label = NT                        # lilo's menu again
  table = /dev/hdb                  # device containing partition table
  master-boot                      # make NT think it's on hda (or that's my intent)

So yours might be something like

boot = /dev/hda
message = /boot/boot_message.txt
timeout = 50
vga = 773
image = /boot/yourKernel
  label = Slack
  root = /dev/hdb3
other = /dev/hda1
  label = NT
  table = /dev/hda

That's probably not right but if lilo's installed and you run lilo.conf, it'll walk you through the steps of creating something similar.

linda 06-23-2004 08:33 PM

I can't believe it, it works! I actually got Lilo to install and then followed the directions to make my nt loader boot lilo, so I can boot Slack! Yes, I know it is a roundabout way, but I have installed Windows so many times I hate losing it accidentlly. I want to wipe it out, piece by piece! So I have my dual-boot system.

Thanks for all the patience and help!

Just in case someone else reads this, here was my problem (I think)...
"Simple" would not work. I had to use "Expert" (which I am not!)
I had to do the step named Begin, and then the step named Linux, and then the step named Install. I think I might have skipped the step named Linux, which actually adds the partition I wanted to boot, stupid me!

Next job: new kernel. Or maybe I should get the new version 10, since I just sort of proved to the world that i can't follow directions? :-)

slakmagik 06-23-2004 09:06 PM

Glad you got it working. I've never gone the ntldr>lilo route - I prefer lilo running the show - but whatever works. :)

As far as the new kernel/new version, assuming that was a question and not thinking out loud, whatever makes you happy. It'd probably be better to just explore your new system as is for awhile and then if you get to feeling really comfortable with it (or break it completely ;) ) you could try upgrading it.

The other argument is that kernel 2.6, udev, and xorg and more makes for quite a bit of change. So you *could* look at as that you're learning things that won't apply in the next version and might as well go ahead and learn the latest first. Merit in either view, I suppose.

Flipside is, with an '01 registration, you've probably already picked up several things, so sticking with this and then making the transition to 10/2.6.7 later would be okay.

All times are GMT -5. The time now is 03:00 PM.