LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware - Installation (https://www.linuxquestions.org/questions/slackware-installation-40/)
-   -   eth0 doesn't work on new slackware 14.2 installation (https://www.linuxquestions.org/questions/slackware-installation-40/eth0-doesnt-work-on-new-slackware-14-2-installation-4175616651/)

odjb 11-24-2017 05:22 AM

Thanks for this tip, I'll try ASAP.

odjb 11-27-2017 08:51 AM

I followed your instructions but now, by default when I restart eth0, I'm in 10mb half duplex. I can set it manually to 100mb full. I still can't set it to 1gb.

abga 11-27-2017 12:26 PM

Well, at least you tried an alternative. You might want to revert the changes and use the kernel provided r8169 instead.
There are other non OS/driver related things you might want to try:
- enter the BIOS settings and disable Wak-on-LAN & Network booting if they're active, maybe you have also some Ethernet related settings
- check if you have a BIOS (firmware) update and go for it
- disable auto-negotiation and enforce Gigabit (if possible) on the device you connect your host to (the other end of your Ethernet cable)
- wait for new kernel (r8169 driver)


All times are GMT -5. The time now is 10:18 PM.