-   Slackware - Installation (
-   -   Error w/ Root Login - Slackware Fresh Install (

Zvakin 08-21-2005 04:51 PM

Error w/ Root Login - Slackware Fresh Install
Hi, I'm extremely new to Linux, but I thought I'd try my hand with a distribution of Slackware 10.1.

I'll get down to the problem I'm having, then I'll explain the setups I've tried:
Everything seems to go alright at first when I install from CDs, but once I try to login as root for the first time to add a new user I get this:

~Welcome to Linux 2.4.26 (tty1)
~[hostname] login: root
~Password: [whatever i set]
~Linux 2.4.26.
~Last login: Sun Aug 21 16:37:12 -0500 2005 on tty1.
~You have mail.
~-bash: fortune: command not found
~Welcome to Linux 2.4.26 (tty1)
~[hostname] login:

Basically, the console recycles me back to the login after the error occurs.

I am currently running on a Pentium III 800Mhz with ~256 MB, with an 6 GB HDD. I am installing from a CD-ROM.

I have tried the following permutations:

- Slackware 10.1 from two different ISO sources, and 10.0 from one source.
- Hard Drive Paritions as follows:

1) 1GB / ; 1GB swap; 1.5GB /usr; 1.5GB /opt; 1GB /home;
2) 1.5GB /; 256MB swap; 1.5GB /usr; 2GB /opt; 768MB /home;

- I have installed slackware using the "full" option every time, and I have only attempted to use KDE.
- I have set up "root" with and without passwords several times each.

Also, the second time I tried installing, instead of coming up with the -bash: fortune: error it displayed certain quotes from famous people, then recycled me back to login.

I would be more than happy to supply any more needed information.

I would greatly appreciate any thoughts and help that you could provide. Thanks in advance.

-:newbie: -

slackhack 08-21-2005 05:36 PM

that is not normal behavior. did you check the md5sums on your isos? it seems like you have that covered with the multiple sources, but perhaps something still could be getting corrupted in the download process?

on the off chance that it does have something to do with fortune, try booting a slax or knoppix cd and disabling it:

# chmod 600 /etc/profile.d/bsd-games*

(make sure you cd to the mount with the slackware /etc first and not the slax/knoppix /etc).

rnicolson 08-21-2005 05:54 PM

I had some issues similar to this where the end fix was that my cd rom drive that I used to install slack with was bad. If you have another one it might be worth a try. i know I was frustrated for a long time where I could instll with no errors but could not log in at all.

All times are GMT -5. The time now is 06:05 PM.