-   Slackware - Installation (
-   -   CUPS Printing on Slackware (

daleman 04-12-2005 01:47 AM

CUPS Printing on Slackware
This is not STRICTLY an installation issue, but it certainly is hampering my installation effort.

I am developing or rather rewriting an application to run on linux (the original was DOS based, written in Clipper). Outside of my control, the chosen language has been FlagShip, a unix based system, which runs a large percentage of Clipper Code.

Anyway, started off on Red Hat 9, but for a number of reasons, it was decided to change to Slackware 10. This has been working well until my current showstopper.

The FlagShip Printing System is simple, as i understand it, based around lpd. I was able to set up CUPS on Red Hat to emulate LPD (CUPS-LPD, launched from XINETD) and all way well.

On my Slackware box, however, (after I enabled the parallel port) I was able to install a local DOT MATRIX printer, with a RAW print queue, and send it a test page.

BUT, when I attempt the following : lp -d locdot /etc/passwd

I get the following errors :

Status Information, attempt 1 of 3:
sending job 'root@thebitch+666' locdot @localhost
connecting to 'localhost', attempt 1
cannot open connection to localhost - No such file or directory
Make sure the remote host supports the LPD protocol
Waiting 10 seconds before retry

Problem is, I am not even aiming at a remote host - this attempts and fails 3 times - bang I am stumped.

I imagine there is some stupid, arcane file that I have to alter, but i simply have no idea where to look. So if anyone can point me in the right direction, I would be eternally grateful.

herbc 04-12-2005 08:35 PM

is /usr/bin/lp pointing to /usr/bin/lp-cups?

daleman 04-13-2005 08:14 AM

thanking you kindly sir, you nailed it - i also needed to change lpr -> lpr-cups,

but once I had, voila, thrings sprung gleefully from the printing device.

And I have licked the local printing problem - but now I cannot connect to a remote printer - I have tried all I can but CUPS seems adamant that I should not be able to do a simple maping to a remote printer. Well to be fair, it stumps me - It asks for a server, which I think I know the obvious answer to, & a print queue - the default being "/print/queue1" which apparently doesnt work. So how do I know what the print queue should be?

The Web interface (localhost:631) is no more helpful, it requires a URI, how should I know what that should be??

Sheeesh, why on earth does it all have to be so ridiculously complicated? Please help?!

markopadjen 04-05-2008 02:08 PM

Another question
I've had a same problem on Mandrake 9.1 using clip-1.2.
This post helped me a lot so I figured to post a question here.

After changing the pointing target printing works. But, it only prints AFTER exiting the application.

Can anyone help me with this? I've tried everything in code, it closes the connection and in DOS that works.

Thanks in advance.

markopadjen 04-05-2008 02:10 PM

Forgot to mention:
Printer is EPSON LX 300 and installed drivers are for standard 9pin printer.

All times are GMT -5. The time now is 09:54 PM.