-   Slackware - Installation (
-   -   cd rom error on installation media (With both slack 9,1 and slack 10) (

busbarn 06-27-2004 01:24 PM

cd rom error on installation media (With both slack 9,1 and slack 10) [SOLVED]
I'm trying to install slack 10 on an old pc that I just got. I downloaded the isos and the md5sum checked out great. I reboot with the cd in the drive and everything works great. Slack boots. AFter loading the kernel, I try to set up network by typing network. The cdrom drive spins and the light comes on, but then returns an error saying that there is no media in the drive. I continue with setup and everything is okay until I try to select media for installation. I choose auto, and it gives me a message that it can't find a cd. I try manual, and select /dev/hdb. THe light comes on on the drive and it spins, but I get the same message back again.

I love slackware and would love to get this working. If anyone had any suggestions I'd really appreciate it.

It's a samsung cd rom drive.
during the boot, the kernel finds it at /dev/hdb.
the drive is setup to be a slave, and is plugged in accordingly to the motherboard.

Thanks again.

J.W. 06-27-2004 09:38 PM

I'm confused. Why don't you just install from the install CD's? -- J.W.

busbarn 06-27-2004 10:21 PM

I'm sorry I must not have been clear. WHen I use the setup command on disc 1, i go through the steps. When I get to Installation SOurce, it won't read the cdrom drive.

J.W. 06-28-2004 12:55 PM

Got it -- so the installation proceeds normally until the point it asks you to select the source, which you want to be the CD, but then it seems to be unable to find the CD.

That's odd, and if you are confident that your ISO's are valid, and the machine boots off the CD first, then you should be ready to go. The only suggestion I'd have would be to perhaps make the CD the secondary master rather than the primary slave. This of course assumes that your machine has a second IDE channel. Naturally this would require that you rejumper that CD device. Theoretically, the above shouldn't really make a difference, but maybe it would. As I indicated, I'm just as baffled as you are as to why the PC seems to be able to boot off the CD, but then to later be unable to recognize it, especially if the ISO's are valid. I suppose you might want to try downloading the ISO's again, from a different mirror site, to see if that makes any difference. I wish I could be more helpful - good luck with it. -- J.W.

busbarn 06-28-2004 02:42 PM

I read on a post over at that somebody had the same problem and they solved it by downloading all of the sources onto a partition, and installing from there instead of the cd. So I burned knoppix live cd to boot into the computer. It freezes when looking for the cdrom.

I don't have the right cable to move the cdrom to the secondary master or else i would try that. Any other ideas?

busbarn 06-30-2004 12:07 AM

THe cdrom must be going bad. I got a cable to change the cdrom from a slave to a master. Same problem. I switched out the cdrom and it worked like a charm.

neauxway 07-15-2004 03:03 PM

I have this exact problem with a Samsung Sc-140, P4P800 Deluxe motherboard with the cdrom on secondary master. Is there a resolution. Oh installing Mandrake 10.0

All times are GMT -5. The time now is 03:06 AM.