-   Slackware - Installation (
-   -   Can't execute .sh file with shell konsole/installing slax to hdd (

Chazfem 01-06-2014 09:59 PM

Can't execute .sh file with shell konsole/installing slax to hdd
I want to use Slax 6.1.2 on an old P3 256mb ram laptop. I really need it to be installed onto the hdd as I need the usb port for a wireless adapter and my daughter might want to play some CDs on it. It will be the only OS installed on the laptop.

I used gparted on live cd of puppy linux to partition the hdd to: 25Gb fat32 storage, a swap, extended and 2.5Gb ext3 partition as the boot for Slax. I loaded the live CD, copied the boot and slax folder to the 2.5GB partition (hda1). I followed the instructions (see link) and updated the folder using kwrite.

Now when it comes to running to make it work I run into difficulties. I open up the Shell - Konsole and I typed "bash/mnt/hda1/boot/".
All I get is -bash: ./ No such file or directory.
I tried "mnt/hda1/boot/"
I tried "bash/mnt/media/hda1/boot/"
I tried "bash/mnt/system/media/hda1/boot/"
I tried "chmod +x"
I tried "./"
I tried "su" (not sure what that does exactly but I'd run out of everything else)

Al of these I have tried many many times. I tried re-copying the folders. I tried doing it without modifying the contents of folder. But always I get the line "No such file or directory"

Could somebody please point me in the right direction here please. It sounds like I'm telling it to look in the wrong place for the file but I can't see that I am. When I'm looking at the file the location in the address bar is "system:/media/hda1/boot" Anyway shouldn't "./" work for any location?

For any answers please bear in mind that I am new to linux and will probably need things spelled out pretty well! Thanks!

ponce 01-06-2014 11:42 PM

hi Chazfem, welcome to the Slackware forum.

maybe you can have a better help on the slax's one as this is dedicated to Slackware and answers don't apply to it: actually, I see jcsoh has already provided you one

Smokey_justme 01-07-2014 01:59 PM

Have you tried "bash /mnt/hda1/boot/" or "bash /mnt/hda1/boot/"? (one is from documentation, the other is what I understand from is from your post).

Also, please note the space after bash and the / before mnt.. They both are mandatory;)

Later edit: Never mind, just followed ponce's link and saw that he was helped already.. Sorry :(

All times are GMT -5. The time now is 12:10 AM.