-   Slackware - Installation (
-   -   cannot re-mount /dev when encrypting root partition (

sn9ke_eyes 07-09-2007 02:04 PM

cannot re-mount /dev when encrypting root partition
Doing a clean install of Slackware 12.0 on my laptop

I followed the instructions in README_CRYPT.TXT from the dvd.

I setup /home encrypted, added the encrypted swap, no problems.

I ran into a problem when trying to finish up the encrypted root partition

In the bottom of the readme it has a link to Alien's page which suggests these options

mount -o bind /proc /mnt/proc
mount -o bind /sys /mnt/sys
mount -o bind /dev /mnt/dev
chroot /mnt

The mounts for /proc and /sys work find but the problem I am having is with mounting /dev

I get this error:

mount: wrong fs type, bad option, bad superblock on /dev, missing codepage or other error

sn9ke_eyes 07-09-2007 04:37 PM

well I booted off a sysrescuecd and was able to bind /dev with that cd. still not sure why it didn't work with the slack cd. maybe something with the way the slack cd loads the installer fs ?

All times are GMT -5. The time now is 09:17 PM.