LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware - Installation (https://www.linuxquestions.org/questions/slackware-installation-40/)
-   -   Cannot get Slack back onto this computer! (https://www.linuxquestions.org/questions/slackware-installation-40/cannot-get-slack-back-onto-this-computer-709569/)

27thSunshine 03-06-2009 03:06 AM

Cannot get Slack back onto this computer!
 
Alright Slackware forums. This is not my first Slack install. A few months ago I burned a 12.1 CD [about 4 days before 12.2 came out as it turns out, hah]. I successfully installed slackware on my laptop [Sony VAIO VGN-FE890]. Twice. Maybe 3 times, I can't remember.

Anyway, I have a fetish or something for fresh installs, but I left my DVD at home [on the other side of the world, mind.] - no biggie, download the official 12.2 torrent and burn it to a DVD. Which didn't work -- "Killed" in the middle of package installs, at seemingly random intervals. Google it up - oh, I must've burned it too fast.

Purchased a DVD-RW, 'cause I can't afford to be buying 20 DVDs to re-re-re-re-re burn this thing. Thus far I believe I've burned and erased and burned again at least 4 or 5 times - and, being set at the slowest speed in both CD/DVD Creator AND Brasero [I have Ubuntu installed right now 'cause I need *some* kind of OS], it takes like 50 minutes each time. Still to no avail! It kills, it hangs, the kernel panics, and the few times I've managed to actually get all the way through the install process, I get this error message upon attempting to install LILO:

Code:

Fatal: Trying to map files from unnamed device 0x0001 (NFS/RAID mirror down?)
...and not only does LILO not install, but as it turns out nothing else did either and Ubuntu is left untouched, ready to try burning it...again.

I guess I should mention that I gave up on the 12.2 iso -- for the past couple times I've been trying the same exact 12.1 iso I'd used with the first, successful DVD.

So what am I doing wrong, Slack-folk? How can I get Ubuntu off and Slack set back in?

H_TeXMeX_H 03-06-2009 06:43 AM

That's odd, it may be just bad media or something. Maybe try the USB or PXE installers:
http://www.slackware.com/~alien/

linus72 03-06-2009 06:54 AM

OK-sounds like your burning it fast...maybe.
I use K3b, write it at the slowest speed, make sure your using DVD-R or DVD+R-not DVD-RW!
K3b is the best isoburner I have found for Linux.

27thSunshine 03-06-2009 06:42 PM

How am I burning it too fast if I'm using the slowest option available which takes close to an hour?
Also...does it really say you can't use DVD-RW? Damn. Damndamndamn. Okay, I'll buy ONE more DVD R next week if the alternatives won't work this weekend.

Thanks for the USB installer -- I have my USB stick all ready to go, but right now my only problem seems to be not getting my laptop to boot from it...I changed the order in the BIOS to boot from USB first, but that doesn't seem to be working, so either it's a laptop problem or I didn't do the USB thing right. I just used the usbboot.img from the slackware 12.2 ISO, using the command dd if=usbboot.img of=/dev/sdc1 bs=512 [and yes, sdc1 is what my stick is called, I quadruple checked before running this command]. I know the stuff's on there, I've checked out the stick...I just can't boot from it at the moment. Any ideas, anything else I need to put on there to get this thing to work?

Thanks to you both for the help so far, by the way.

H_TeXMeX_H 03-07-2009 03:16 AM

Quote:

Originally Posted by 27thSunshine (Post 3467396)
I just used the usbboot.img from the slackware 12.2 ISO, using the command dd if=usbboot.img of=/dev/sdc1 bs=512 [and yes, sdc1 is what my stick is called, I quadruple checked before running this command].

Usually /dev/sdc1 means that you're overwriting the first partition of /dev/sdc. Are you quite sure the USB stick is not /dev/sdc, because I'm pretty sure it is.

27thSunshine 03-07-2009 05:46 AM

I'm absolutely positive it's sdc1, because when I run fdisk -l, that's exactly what it spits at me. /dev/sdc1.

H_TeXMeX_H 03-07-2009 06:26 AM

Can you post that output of fdisk ?

linus72 03-07-2009 07:19 AM

Try the Alien bob's site ( http://www.slackware.com/~alien/Slackware )
The iso's for 11.0-12.2 are here- ( http://www.slackware.com/~alien/slackboot/mini/ )
They are essentially the same as the usbboot.img, so just extract the .iso, right-click on the iso/extract here/ open up the folder-goto "edit" at the top of the file browser-choose "select all"-then choose "copy/cut" the contents of that folder, paste them into your USB through your file manager's window, after that(or before you put it all into the USB) go into the isolinux folder-again "select all"-cut-then go back out of that folder to the top directory-"paste"-asks if u want to replace the readme-there's2 so whatever-now all your isolinux contents are in the top directory-delete the isolinux folder-open up the isolinux.cfg file-put a "/" in front of "message.txt", "f2.txt", and in front of where the initrd's are "initrd=/initrd.img" "initrd=/smp/initrd.img" Now, hit save.
Ok, now rename the isolinux.cfg to syslinux.cfg, now here's the real trick!
Download "Billix" from here- ( http://sourceforge.net/projects/billix )
Extract the USB version-extract it-go into the folder-find the "ldlinux.sys"-this is what syslinux puts in your USB when you terminal "syslinux -s /dev/sdxx" where "xx" is your USB-which you don't know!
Now just copy/paste that ldlinux.sys into your USB and it's now bootable!
and you never had to touch your termianl or know what your USB is identified as!
Other distro's have the ldlinux.sys too, but I can't remember...?!
Too much Heavy Metal and pot I guess?!
Anyway-hope I got all that right-the netinstall iso will ask you for the mirrors/directories for where the slack packages are-so take note.
Also read the Slackware-How-To in the iso.
Also-make sure the "boot" flag is on-you can check and turn it on with Gparted-Gparted should also tell you what the USB designation is (sdf1/sda1,etc)
B

bgeddy 03-07-2009 09:58 AM

H_TeXMeX_H was correct - /dev/sdc1 is a partition on the usb stick. The image should be written to /dev/sdc and overwrite any partitions on there. Have a look at the information on the installation disk about USB installs to explain this.
Quote:

I'm absolutely positive it's sdc1, because when I run fdisk -l, that's exactly what it spits at me. /dev/sdc1.
Fdisk -l will show partitions on a device however you don't want the image file to go to a partition rather the root device itself so the command is:
Quote:

dd if=usbboot.img of=/dev/sdc bs=512

27thSunshine 03-07-2009 08:11 PM

Haaa...I feel like a moron, of course you were both right -- re-do it with out the 1, it boots from the USB just fine.
BUT.
It STILL hangs or kills process in the middle of installing packages. I cannot think of what could possibly be wrong! I downloaded the usbboot.img from an official slack ftp server...this is frustrating. Remind me never to remove slackware from my computer ever again ever.
Any ideas?
Thanks for the input thus far everyone, I do appreciate it.

...and my USB stick seems to have died. Fantastic.

H_TeXMeX_H 03-08-2009 04:15 AM

Hmm, either this is strange coincidence or maybe a hardware issue has popped up. I say try running memtest86 just in case.

linus72 03-09-2009 02:14 PM

Well?
Did you get slack installed via USB??
I am thinking about trying it too, only problem I'm gonna have is the pcmcia command isn't finding my Xircom card (RealPort Cardbus Ethernet 10/100 RBE-100)
Anyone know what the issue is??
Also-I am gonna try netinstall 'cause Slack doesn't seem to recognize my USB-CDROM-but other distro's do-or I would install that way.
Anybody know what I'm doing wrong??
My bad-I think it's a not a PCMCIA card is it?so, I just use netconfig??

27thSunshine 03-11-2009 08:35 AM

Memtest was fine, hardware SHOULD be fine...I tried completely cleaning everything off with G-Parted, to see if maybe Slack just didn't want to install over something else, but that didn't work either..and Ubuntu reinstalled just fine.

I just don't understand what is causing it to hang like that! It's not like you can burn a USB boot stick too fast...

linus72 03-11-2009 09:28 AM

Try to put Slack onto USB the way I did it...(see above)...that way there's no terminal and you don't need to know whether it's sdf1/sda1, etc.
If you can't get it to find the USB to install Slackware-then just do the netinstall and give it the mirror locations at the slackware-get slack site.
Also-you can "trick" the slackware by doing this-(if you have a USB-CDROM/DVD), when you get to setup, remove the USB, insert the USB-CDROM, make sure that the cd is in the cdrom, but not closed..., then press enter to autolocate the CDROM-at the same time close the CDROM tray so it starts spinning-then it should detect it and start the install.
That's how I've been doing it on my Toshiba 7000CT-it can't boot from USB and no CDROM-just floppy-so I use Plop Bootmanger to amke a bootfloppy-boot the USB, then proceed as above.
See my post here for info- ( http://www.linuxquestions.org/questi...nstall-709372/ )
try using the 1,2, and 3 Cd's instead of DVD too.
Hope that helps-I wanna know if your successful or no...?

bgeddy 03-11-2009 11:18 AM

Just a possibility but you did select a swap partition in the install, didn't you ? I've seen installs die if this is not done.


All times are GMT -5. The time now is 09:10 PM.