LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - Installation
User Name
Password
Slackware - Installation This forum is for the discussion of installation issues with Slackware.

Notices


Reply
  Search this Thread
Old 08-27-2004, 11:37 PM   #1
thom
Member
 
Registered: Feb 2002
Location: Washington DC
Distribution: SuSE 9.1/Slackware 10
Posts: 193

Rep: Reputation: 30
can't use cdplayer as user slackware 10


I can't seem to play cds or use the cdrom device as user. In root all works ok.
I get "drive error" with cdplayer and have set fstab so:
/dev/hda2 swap swap defaults 0 0
/dev/hda3 / reiserfs defaults 1 1
/dev/hda1 /windows vfat defaults 1 0
/dev/hdb1 /sparedrive vfat defaults 1 0
/dev/cdrom /mnt/cdrom iso9660 noauto,owner,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0

I changed /dev/cdrom to : /dev/cdrom /mnt/cdrom iso9660 noauto,user,ro 0 0
still no go

group looks so:
root::0:root
bin::1:root,bin,daemon
daemon::2:root,bin,daemon
sys::3:root,bin,adm
adm::4:root,adm,daemon
tty::5:
disk::6:root,adm
lp::7:lp
mem::8:
kmem::9:
wheel::10:root
floppy::11:root
mail::12:mail
news::13:news
uucp::14:uucp
man::15:
audio::17:
video::18:
cdrom::19:
games::20:
slocate::21:
utmp::22:
smmsp::25:smmsp
mysql::27:
rpc::32:
sshd::33:sshd
gdm::42:
shadow::43:
ftp::50:
pop::90op
nobody::98:nobody
nogroup::99:
users::100:
console::101:


all this is default after re-install. I tried editing both files as found on other threads.

works fine in my laptop and this is a fresh install on soyo board.
I have also tried editing group in /etc.
Really stumped here. Any help would be greatly appreciated.
thanks.

Last edited by thom; 08-27-2004 at 11:42 PM.
 
Old 08-28-2004, 02:17 AM   #2
Jimbo1265
Member
 
Registered: Apr 2004
Location: Oklahoma City, OK, USA
Distribution: Slackware
Posts: 48

Rep: Reputation: 15
In Slackware 9.1, cdrom's were in the disk group. Making your user a member of the disk group allowed your user to access the cdrom.
In Slack10, cdrom's are now in the cdrom group. In order for a user to access cdrom's, the user now needs to be a member of the cdrom group.

Edit:I just noticed. You have "user" listed in fstab. That should be "users".

Last edited by Jimbo1265; 08-28-2004 at 07:32 AM.
 
Old 08-28-2004, 09:07 AM   #3
thom
Member
 
Registered: Feb 2002
Location: Washington DC
Distribution: SuSE 9.1/Slackware 10
Posts: 193

Original Poster
Rep: Reputation: 30
thanks jimbo,
I added "users" in fstab and still cannot play any cds as user: thom in KsCD or CDplayer etc.

Regarding the /etc/group file: I'm not sure I understand this.
Where is lists "cdrom:19:" must I type the user name or can I not just put "users" to cover all?

Also I have not added anything to my system yet to avoid other possibilities. This is on a fresh install.

Another clue is that "root" cannot create a "device" for cdrom on desktop that will open without error. Root can play cds fine though.

I'm wondering if its a path issue also: I don't knwo what to check. I also
am wondering other than "group" and "fstab" what to look for. It is strange as all devices are detected on boot, though cd/rw is not in fstab. I have "plug and play in bios disabled" and am wondering if bios could be an issue.

...edited post....
)I added myself, but its still broke:
thom@tendata:~$ groups thom
thom : users disk audio cdrom
thom@tendata:~$

on cdplayer: "drive error"

Thanks a bunch. This is really my only hurdle with slackware10 (i had kde 3.3, nvidia, etc) all working beautifully.

Last edited by thom; 08-28-2004 at 09:25 AM.
 
Old 08-29-2004, 11:31 AM   #4
Jimbo1265
Member
 
Registered: Apr 2004
Location: Oklahoma City, OK, USA
Distribution: Slackware
Posts: 48

Rep: Reputation: 15
Since it works as root but not for user, it's a simple permissions problem. Do me a favor and run
Code:
ls -l /dev/cdrom
and post the results.
Also, if /dev/cdrom is a symlink to another device(/dev/hdc if reader, /dev/sr0 if burner) run
Code:
ls -l /dev/hdc
or
Code:
ls -l /dev/sr0
and post those results as well.
 
Old 08-30-2004, 08:12 AM   #5
thom
Member
 
Registered: Feb 2002
Location: Washington DC
Distribution: SuSE 9.1/Slackware 10
Posts: 193

Original Poster
Rep: Reputation: 30
thanks again Jimbo,
Will post when I get back to home box.
 
Old 08-30-2004, 03:37 PM   #6
kingterr0r
Member
 
Registered: Aug 2004
Location: New York
Distribution: SuSE 9.1 Pro
Posts: 32

Rep: Reputation: 15
alright, first of all =]
Music cds donesn't need mounting, you can play then without mounting... as far as mounting cdroms, i.e data cd's you'd su and mount /dev/cdrom /mnt/cdrom thats to unmount, umount /mnt/cdrom... thats all that needs to be done, no editing of anything
 
Old 08-31-2004, 12:39 AM   #7
Jimbo1265
Member
 
Registered: Apr 2004
Location: Oklahoma City, OK, USA
Distribution: Slackware
Posts: 48

Rep: Reputation: 15
True. You don't mount audio cd's to play them. However, you do need access to the device in order to use it. If you aren't a member of the devices group, you can't use it.
It's the same with mounting a device. If permissions are wrong and/or you aren't in the devices group, you won't be mounting that device. No matter what.
So, you're a bit off there.
 
Old 09-02-2004, 12:26 AM   #8
thom
Member
 
Registered: Feb 2002
Location: Washington DC
Distribution: SuSE 9.1/Slackware 10
Posts: 193

Original Poster
Rep: Reputation: 30
Sorry it took so long to get back. Below is what I get:

thom@tendata:~$ ls -l /dev/cdrom
lrwxrwxrwx 1 root root 8 2004-09-01 21:13 /dev/cdrom -> /dev/hdc
thom@tendata:~$ ls -l /dev/hdc
brw-rw---- 1 root disk 22, 0 2002-06-09 15:27 /dev/hdc
thom@tendata:~$ ls -l /dev/sr0
brw-rw---- 1 root cdrom 11, 0 1999-04-13 00:24 /dev/sr0
thom@tendata:~$

Its not a hard ware issue and I am on a fresh install again. No matter what I add to fstab or groups seems to help. I do have a cd burner which is not showing up. But I really don't care about that right now. I think I need help with paths or something. No clue.

In the home icon: mount: only root can mount /dev/cdrom on /mnt/cdrom
Please check that the disk is entered correctl


Thanks

Last edited by thom; 09-02-2004 at 12:41 AM.
 
Old 09-02-2004, 01:18 AM   #9
kingterr0r
Member
 
Registered: Aug 2004
Location: New York
Distribution: SuSE 9.1 Pro
Posts: 32

Rep: Reputation: 15
for music cds doesnt need mounting, data cds you get root priv. by su then enter p.w and type
mount /dev/cdrom /mnt/cdrom
to unmount type umount /mnt/cdrom
to eject cd type
eject -r
 
Old 09-02-2004, 01:36 AM   #10
Jimbo1265
Member
 
Registered: Apr 2004
Location: Oklahoma City, OK, USA
Distribution: Slackware
Posts: 48

Rep: Reputation: 15
I almost had an answer for you but you went and added a cdrw to the equation. How are your drives installed? By that I mean to what ide channel are they each attached and in what position?
For example, on my machine, the hard drive is, of course, master drive on the primary ide. The dvdrw is master drive on the secondary ide. The dvdrom is slave on the secondary ide.
I need a clue before I can continue.
 
Old 09-02-2004, 02:15 AM   #11
Jimbo1265
Member
 
Registered: Apr 2004
Location: Oklahoma City, OK, USA
Distribution: Slackware
Posts: 48

Rep: Reputation: 15
Quote:
Originally posted by kingterr0r
for music cds doesnt need mounting, data cds you get root priv. by su then enter p.w and type
mount /dev/cdrom /mnt/cdrom
to unmount type umount /mnt/cdrom
to eject cd type
eject -r
Learn to read. This isn't simply about listening to a music cd. Which the OP isn't able to do as user.
The user shouldn't need root privilege to mount data cd's either.
The point of this whole thread is to give users access to the drive.
And I'll reitterate my point from my previous response to you. We know you don't mount a music cd. That isn't the point of this thread.
The point of this thread is that the OP's user account has no access to the cdrom at all while root does. This is a problem and we're trying to fix it.
 
Old 09-02-2004, 02:24 AM   #12
kingterr0r
Member
 
Registered: Aug 2004
Location: New York
Distribution: SuSE 9.1 Pro
Posts: 32

Rep: Reputation: 15
ask the first foremost question......
how did he setup his user account...
see if it needs editing if it does simply login as root go to kusers 'thinking its kde hes using' and edit the user and add the appropriate groups needed, or slect all just in case to see if that will work... if not then edit fstab like this
/dev/cdrom /mnt/cdrom iso9660 noauto,owner,ro 1 1
see if that works...
or change owner to users and see if that works..
and ive heard of people doing a chmod 444 /dev/cdrom and that working also i wouldnt recommend doing that because you may not be able to even mount it at all..
 
Old 09-02-2004, 07:37 AM   #13
thom
Member
 
Registered: Feb 2002
Location: Washington DC
Distribution: SuSE 9.1/Slackware 10
Posts: 193

Original Poster
Rep: Reputation: 30
Cdrom is master and cdrw is slave. Its always worked before on other versions and different distros.

In KDE when i open up the "Home" icon I can see the "audio cd browser spinning" non-stop.
In Devices. when I click on cdrom I get: mount: only root can mount /dev/cdrom on /mnt/cdrom
Please check that the disk is entered correctly. and the cdrom picture is spinning.

It matters not if data or cd music of course.

I tried changing my fstab: from this: dev/hda2
swap swap defaults 0 0
/dev/hda3 / ext3 defaults 1 1
/dev/hda1 /windows vfat defaults 1 0
/dev/hdb1 /sparedrive vfat defaults 1 0
/dev/cdrom /mnt/cdrom iso9660 noauto,owner,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0

To this:
/dev/hda2 swap swap defaults 0 0
/dev/hda3 / ext3 defaults 1 1
/dev/hda1 /windows vfat defaults 1 0
/dev/hdb1 /sparedrive vfat defaults 1 0
/dev/cdrom /mnt/cdrom iso9660 noauto,owner,ro 1 1
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0

Still not working. The settings are exactly the same for everything as my laptop which works. I will try adding "user" to fstab again, but I have done all this.
adding "users" instead of owner gives me this when opening cdrom:

mount: wrong fs type, bad option, bad superblock on /dev/cdrom,
or too many mounted file systems
Please check that the disk is entered correctly.

?where is this "kusers" you are talking about?
My problem I don't think can be solved by editing "group" or "fstab"


Last edited by thom; 09-02-2004 at 07:48 AM.
 
Old 09-02-2004, 07:57 AM   #14
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
Sometimes these problems can be solved by unmounting the drive (from a terminal, as root, using the commands specified above), and then remounting it, in order for the new /etc/fstab settings to be used, and to refresh the cache of the drive's contents.
 
Old 09-02-2004, 08:14 AM   #15
Makaelin
Member
 
Registered: Mar 2004
Posts: 93

Rep: Reputation: 15
I'm having the same problem. I changed /dev/cdrom to 'user' instead of 'owner', and rebooted, but no good. I've also got a slave CD-RW that isn't showing up. Going to keep tweaking and watching this thread, will post if something works.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
store bought cds, slackware, and cdplayer xviddivxoggmp3 Slackware 18 10-22-2004 02:09 AM
can't mount cdplayer on my toshiba satellite pro 420cdt with zipslack denizen Linux - Laptop and Netbook 0 09-08-2004 01:01 PM
cdplayer permission nacha Slackware 3 05-23-2004 11:41 AM
convert windows' cdplayer.ini to linux format? SharpyWarpy Linux - General 2 04-26-2004 07:34 PM
Fedora C2T2 CDplayer won't play monkeezz12 Linux - Laptop and Netbook 2 04-11-2004 12:54 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - Installation

All times are GMT -5. The time now is 11:20 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration