-   Slackware - Installation (
-   -   booting after install Slackware 14 64 on a Asus Sabertooth 990FX R2.0 (

m1bear 03-03-2013 10:00 PM

booting after install Slackware 14 64 on a Asus Sabertooth 990FX R2.0
First off know that I am new to Linux, Slackware may not be the best start but I will keep at it anyhow I don't want easy I want to learn.

the system
mb ASUS Sabertooth 990FX R2.0
CPU AMD FX 8 Core runs at 3.6Ghz
video 2X Asus Nvidia 550 Ti
Mem 1 8 Gb running 1600
HD1 2X SATA 250GB (Raid 0 with win7 64)
HD2 1 SATA 80GB (Slackware)

the problem:
Slackware installs just fine have a little problem with Lilo(I disconnect the windows HD and Lilo is fine) but gets through the install process. I just set up two partitions swap and /. when I restart it would first just stop at USB and when I say stop that is what i mean no Kernel panic just not going on no HD activity press the Numlock light goes on and off but not doing anything. Ctr+alt+Del still restarts. I reconfigured and didn't load the mouse. it then would go past the USB but stop at video. it looks like it is probing for sound on my video cards. or just got done probing for sound and is probing something else. it is in same state as before just hanging not froze no Kernel panic with one exception it will reboot itself after about 5 min. I believed that it might be the nouveau drivers so i reinstalled leaving it out. didn't help still stopped at the same point. I just happened to have a DVD with Slackware 13 64 on it laying around so I tried to install. installed and boots great in fact that is what I am using to type this. So why is 14 giving me a hard time? I am guessing has something to do with the way the Kernel is compiled, I am not advanced enough to make my own yet.

Like I said I am learning any thoughts would be nice.

I tried again the this is what is on the screen before it stops responding

drm noveau 000:01:00.0:...appears to be valid
drm noveau 000:01:00.0: Bit Bios found
drm noveau 000:01:00.0: Bios version
drm noveau 000:01:00.0: TMDS table Version 2.0
drm noveau 000:01:00.0: Found Display configuration Block ver

I had to write this down by hand like i said it sometimes restarts but not for a good while 2-5 min sometimes gets a little more sometimes a little less. like i said 13.37 installed and worked i changed the display driver to Nvidia 310 as soon and it was running

1 is it possible to install the Nvidia driver from there install script during the install or do i have to waite till I get it stable enough?

2 can i somehow install 13.37 and install driver then upgrade to 14?

3 would appending the video mode in Lilo.config stop it from trying to probe the video card and let it finish booting?

This is all assuming that it is caused from the noveau driver or rather I think kernel module am i way off in thinking this?

m1bear 03-04-2013 11:37 AM

well so far no luck I tried to change lilo display mode and it made the text output smaller and stopped at a difference place with whatever resolution I chose seemed to go further with higher resolutions. I also tried pulling out one of the video cards didn't help. it is drastic for me for I love my video cards but next I think i will try replacing it with a old 8500. thinking if I can get it to boot I can change driver and replace my good cards.

I think it is probably bad when you have to do the hardware part but it might be the kernel just isn't configured to support it as it is. (I am rather sure that it can because 2.6 did on Slackware 13.37)

m1bear 03-04-2013 12:58 PM

Well Solved all by myself, well kinda a walk around to install Nvidia Drivers from the Nvidia sight. I am sure there are easier ways to get Slackware 14 working with Nvidia 550 Ti video cards.
On the off chance that this can help I will Recap my hardware workaround although I dont think it will work unless you have a spare older Nvidia card around.

1 I installed slackwarex86_64 14 (gave me no problem installing or configuring)

2 tryed to boot (froze from I believe a conflict with the noveau driver module)

3 took out video card and replaced with 8500 (think might have problems if it is not Nvidia based)

4 booted, everything loaded just fine

5 downloaded Linux driver from Nvidia 310.32, cd myself to the dir it was in

6 once in the Dir typed in su then root password

7 they typed "bash" (dont know if this is how to run this program but it worked)

8 after accepting agreement it told me the noveau driver module was loaded and couldn't install until it was unloaded it offered to try and unload it so i let it

9 reboot (hoping it had managed to unload)

10 repeated steps 6-8 (it finished installing this time )

11 rebooted started x "startx" (everything was looking good)

12 shutdown turn off power supply and replace my two 550 Ti cards (I remembered the sli bridge even)

13 turn everything back on everything went smooth started x started Firefox and typed this.

well I know kinda made it simple, sry not trying to insult anyone's intelligence just want to make sure that anyone can do the same if they want. I think the important thing is to get the (noveau driver module) out of the system and I am sure that can be done without swapping video cards. point is I have been working on this for two days straight if I can save someone else that time than it is worth posting. I know hardware I do not know Linux (I learned a lot). I am hoping someone else more knowledgeable than me will shed some light and post a easier way to do this.

also just a note I did try to boot from the DVD because it worked for the install but, if it told it root=/dev/sda1 it would always freeze didn't matter how I booted the system.

there is more info out there too bad I didn't find it until after I resorted to drastic measures:

thanks, rinias

I wish would have found this earlier. What I am not sure of is if "Disabling the nouveau Module" could be done while installing, or while booting from the DVD/CD. I am sure, that it would be worth a try if I wanted to reinstall my system.

Kallaste 03-11-2013 10:09 PM

Good job! Sorry no one here was able to help you but I'm glad you got it figured out. Enjoy Slackware.

m1bear 03-21-2013 07:56 PM

not so hard afterall
I cannibalized a bigger hard drive out of one of my kids old computers. this gave me a great excuse to reinstall Slackware and see if there was a easier way to deal with my video cards.

the page:

gave me the basic idea, the problem being that I could not boot my system so I had to incorporate "Disabling the nouveau Module" in my set up. This turned out to be very easy to do.

1. I let my computer boot form the install DVD,ran setup, installed my system and configured my system

2. I did NOT exit the setup program instead I went to another terminal ALT+F2

3. Then to figure out where my DVD was mounted I typed in "mount"

4 changed directory to where the DVD was mounted and then /extra/xf86-video-nouvea

5 ran pkgtool and installed xf86-video-nouvea

6 change back to setup screen ALT+F1 exit setup, take out DVD restart ALT+CTRL+DEL

after that I just followed the rest of the steps I had downloaded the driver to a usb drive so I just ran it from there

no taking out video cards and swapping them of course if you do exit the setup you can still install the xf86-video-nouvea package but you will have to mount the DVD you self and then run pkgtool from the xf86-video-nouvea directory. To me being lazy why go to the trouble when setup already mounted it for me

gauchao 12-21-2014 02:41 PM

Which bootloader are you using? Also, how have you defined the motherboard BOOT parameters (I mean, UEFI and Secure Boot) I am interested because I have a new machine with the same motherboard. Thank you.

Alien Bob 12-21-2014 02:53 PM

gauchao, this thread was ended one and a half year ago. Please do not dig it up. Your post is pointless.

gauchao 12-22-2014 09:56 AM

Sorry Eric. My fault.

m1bear 12-22-2014 11:45 AM

gauchao, 14.1 installs smoothly whatever problem I had way back then is no longer relevant. as for your question set secure boot to "other operating system" and the rest depends on how you partition you HD, MBR or GPT. It is a Fantastic motherboard!!

All times are GMT -5. The time now is 08:21 PM.