-   Slackware - Installation (
-   -   Are the programs in util-linux the same version as those in util-linux-ng? (

harryhaller 10-07-2011 09:43 AM

Are the programs in util-linux the same version as those in util-linux-ng?
I have just upgraded from 13.1 to 13.37. First of all, I would like to thank the Slackware team for their fantastic work - this was the first time that I have done an upgrade and it went really smoothly - so thanks a lot - it's much easier than doing a clean install! :)

I followed the instructions in UPGRADE.TXT, of course, and at the end it advises us to remove util-linux-ng after having checked that util-linux is correctly installed.

However when I ran removepkg for util-linux-ng, it brought messages that it could not remove the programs because they were referenced in another package. I assume that the "other" package is util-linux and that the programs are all the same version - even though some appear to have no version number.

I am just checking - I don't have a problem (yet). I'm sorry I can't paste the messages but I cannot easily reporduce the messages and, due to a quirk with mc/screen/root, the messages are lost.

Basically I just want to be reassured that everything is ok.. Ta. :)

GazL 10-07-2011 10:32 AM

It's just a consequence of upstream dropping the 'ng' suffix from their name. It's still the same package (13.37 will be a more recent version).
It's a pretty important package. If you'd done it wrong, you would know about it! ;)

harryhaller 10-07-2011 10:43 AM

Thanks - I just wanted to be sure - apart from losing boot messages when using the frame buffer terminal - everything is running very smoothly. Cheers :)

All times are GMT -5. The time now is 07:58 PM.