LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware - Installation (https://www.linuxquestions.org/questions/slackware-installation-40/)
-   -   14.2 install goes normally, but will not reboot, gives grub command line instead (https://www.linuxquestions.org/questions/slackware-installation-40/14-2-install-goes-normally-but-will-not-reboot-gives-grub-command-line-instead-4175692274/)

porphyry5 03-18-2021 04:12 PM

14.2 install goes normally, but will not reboot, gives grub command line instead
 
asus L210, installing slackware 14.2
system has uefi bios that permits usb install if Esc key held down when Power switch pressed. I disabled Secure Boot as slackware was not acceptable, unsigned.

I deleted every partition shown by cgdisk on /dev/mmcblk0, and set up 3 partitions,
Code:

1 type EF00 300MB
2 type 8300 20GB
3 type 8300 15GB, this last for /home

Install proceeded normally, but slackware would not reboot, gave me grub command line instead. Nor could I boot the install from the slackware usb, any of the choices offered led to Kernel Panic.

Back in the uefi bios, I noticed a difference, it no longer offered boot option from HDD, showing it only as a Storage device.

I then reinstalled Lubuntu 18.04, which succeeded, and also restored the HDD as a boot option in the uefi bios. So I assume the way I partitioned the HDD in slackware offended the bios, but I have no clue as to why. Any suggestions?

I reinstalled slackware, using the same partitions created by lubuntu, but got the same result, reboot went to grub command line instead. But the uefi bios still shows the HDD as 1st boot option.

Now I have reinstalled lubuntu, side-by-side with slackware. On the reboot grub offered both slackware and lubuntu as boot options, but choosing slackware led to Kernel Panic again.

Emerson 03-19-2021 09:06 AM

:twocents: Probably Grub does not know how to access NVMe drive. I have no Grub experience, it is not suitable for me, therefore can't tell how to configure Grub for NVMe access, but they have excellent documentation online for you to read.

colorpurple21859 03-19-2021 10:38 AM

Quote:

gave me grub command line
Did your run
Code:

grub-mkconfig -o /boot/grub/grub.cfg
after running grub-install?

colorpurple21859 03-19-2021 02:02 PM

Quote:

but choosing slackware led to Kernel Panic again.
I think you need to create a /boot/initrd.gz to boot slackware on a nvme drive.

Emerson 03-19-2021 02:24 PM

Hold your horses, Grub can't even find the kernel, it is Grub issue right now, not kernel-initrd. At least this is what initial post tells, although the 'kernel panic' remark is confusing.

porphyry5 03-19-2021 02:41 PM

Quote:

Originally Posted by Emerson (Post 6232054)
Life is a tragedy for those who feel and a comedy for those who think.

But what if you do both?

Thanks for the referral to grub documentation. I love slackware, eventually, when one finally gets it going, probably on the principle that we love that which makes us suffer. ubuntu is like windows, a convenient annoyance that works out of the box.

porphyry5 03-19-2021 02:43 PM

Quote:

Originally Posted by colorpurple21859 (Post 6232075)
Did your run
Code:

grub-mkconfig -o /boot/grub/grub.cfg
after running grub-install?

No, but why should I have needed to, this isn't Arch?

porphyry5 03-19-2021 02:47 PM

Quote:

Originally Posted by colorpurple21859 (Post 6232141)
I think you need to create a /boot/initrd.gz to boot slackware on a nvme drive.

OK, so given Emerson's 2nd post, I'll do another install and try grub command at its command line.

colorpurple21859 03-19-2021 02:56 PM

Quote:

No, but why should I have needed to, this isn't Arch?
You are right Slackware isn't Arch, Slackware isn't like any other distro either, so yes you have to run grub-mkconfig. Slackware does not auto-run grub-mkconfig or mkinitrd during kernel updates either.

Emerson 03-19-2021 03:07 PM

Quote:

Originally Posted by porphyry5 (Post 6232166)
OK, so given Emerson's 2nd post, I'll do another install and try grub command at its command line.

Hope you don't mean installing Slackware again? All you need to do is chroot and run grub-mkconfig.

Regarding your question about that oriental proverb. Can't answer that. It would be off topic. Not to mention there is no way to sugarcoat it for you.

porphyry5 03-19-2021 03:25 PM

Quote:

Originally Posted by colorpurple21859 (Post 6232172)
You are right Slackware isn't Arch, Slackware isn't like any other distro either, so yes you have to run grub-mkconfig. Slackware does not auto-run grub-mkconfig or mkinitrd during kernel updates either.

Not disputing what you say but I would have thought then that the install disk would have said run mkconfig instead of just reboot.

But as there are 2 distros on my HDD, I think I'd better study up on Grub first, it would be mortifying to lose access to both of them for doing just one command. Thanks for your help, be back in a few days to report progress.

colorpurple21859 03-19-2021 03:29 PM

Slackware installs lilo/elilo by default not grub. How did you install grub and/or what iso did you use?

Emerson 03-19-2021 03:36 PM

Two or more distros, one Grub is enough, you can add Slackware to your existing Grub install, I think it is somewhere in Lubuntu /etc, /etc/grub perhaps.

porphyry5 03-19-2021 03:37 PM

Quote:

Originally Posted by Emerson (Post 6232179)
Hope you don't mean installing Slackware again? All you need to do is chroot and run grub-mkconfig.

I did, but at the very last moment I drew back, realizing I might thereby lose access to the only working distro on the machine. Think I'll take a few days to study grub and chroot before doing anything.
Quote:

Regarding your question about that oriental proverb. Can't answer that. It would be off topic. Not to mention there is no way to sugarcoat it for you.
You know 'off topic' is the finest red herring ever since the original seduced sober and industrious fox-hounds two hundred years ago.
Sugarcoat? is for pollyannas, those people who refer to realists as cynics.

porphyry5 03-23-2021 03:18 PM

Quote:

Originally Posted by colorpurple21859 (Post 6232191)
Slackware installs lilo/elilo by default not grub. How did you install grub and/or what iso did you use?

Slackware was the 1st install, which failed, so then I installed lubuntu side-by-side with the slackware so that I would have a system to work from on this machine.
This is the content of my slackware/boot dir
Code:

/media/q/5bb5deec-0a16-4c5b-bc55-8d2fb1a8047f/boot $ ls
coffee.dat            inside.dat                tuxlogo.bmp
config@                onlyblue.bmp              tuxlogo.dat
config-generic-4.4.14  onlyblue.dat              vmlinuz@
config-huge-4.4.14    README.initrd@            vmlinuz-generic@
elilo-ia32.efi        slack.bmp                  vmlinuz-generic-4.4.14
elilo-x86_64.efi      System.map@                vmlinuz-huge@
grub/                  System.map-generic-4.4.14  vmlinuz-huge-4.4.14
inside.bmp            System.map-huge-4.4.14

Also, there is no etc/mkinitrd.config, only the sample showing the defaults, which reads
Code:

# mkinitrd.conf.sample
# See "man mkinitrd.conf" for details on the syntax of this file
#
#SOURCE_TREE="/boot/initrd-tree"
#CLEAR_TREE="0"
#OUTPUT_IMAGE="/boot/initrd.gz"
#KERNEL_VERSION="$(uname -r)"
#KEYMAP="us"
#MODULE_LIST="ext4"
#LUKSDEV="/dev/sda2"
#LUKSKEY="LABEL=TRAVELSTICK:/keys/alienbob.luks"
#ROOTDEV="/dev/sda1"
#ROOTFS="ext3"
#RESUMEDEV="/dev/sda2"
#RAID="0"
#LVM="0"
#UDEV="1"
#MODCONF="0"
#WAIT="1"

Now I'm considering running
Code:

sudo chroot /media/q/5bb5deec-0a16-4c5b-bc55-8d2fb1a8047f mkinitrd ...
but cannot figure how to specify what the input file should be. There is no existing .img file in boot/ to use, and otherwise mkinitrd defaults to $(uname -r), which will yield
Code:

$ sudo chroot /media/q/5bb5deec-0a16-4c5b-bc55-8d2fb1a8047f/ uname -r
4.15.0-139-generic

which is lubuntu.

Found slackware mini-howto for mkinitrd and have now run
Code:

/media/q/5bb5deec-0a16-4c5b-bc55-8d2fb1a8047f mkinitrd -c -k 4.4.14 -m ext4
which has duly generated /boot/initrd-tree and /boot/initrd.gz

colorpurple21859 03-23-2021 06:49 PM

Did you run
Code:

mount --bind /dev /media/q/5bb5deec-0a16-4c5b-bc55-8d2fb1a8047f/dev
and the same for /proc, /sys, and /run before chrooting into slackware? After chroot run
Code:

sh /usr/share/mkinitrd/mkinitrd_command_generator.sh -k 4.4.14
to get a good starting initrd.gz. If it still doesn't boot you may have to add more modules to the mkinitrd command.

porphyry5 03-24-2021 03:03 PM

Quote:

Originally Posted by colorpurple21859 (Post 6233443)
Did you run
Code:

mount --bind /dev /media/q/5bb5deec-0a16-4c5b-bc55-8d2fb1a8047f/dev
and the same for /proc, /sys, and /run before chrooting into slackware? After chroot run
Code:

sh /usr/share/mkinitrd/mkinitrd_command_generator.sh -k 4.4.14
to get a good starting initrd.gz. If it still doesn't boot you may have to add more modules to the mkinitrd command.

I didn't, spent quite some time trying to figure that out, because there are examples both ways on the net, but nowhere explained why it was one way or the other, so decided it had to depend on whether the chrooted fs was already mounted, which is what applied in my case. In any case, the result does not boot.
But now,
Code:

~ $ sudo mount --bind /dev /media/q/5bb5deec-0a16-4c5b-bc55-8d2fb1a8047f/dev
[sudo] password for q:
~ $ sudo mount --bind /proc /media/q/5bb5deec-0a16-4c5b-bc55-8d2fb1a8047f/proc
~ $ sudo mount --bind /sys /media/q/5bb5deec-0a16-4c5b-bc55-8d2fb1a8047f/sys
~ $ sudo mount --bind /run /media/q/5bb5deec-0a16-4c5b-bc55-8d2fb1a8047f/run
~ $ sudo chroot /media/q/5bb5deec-0a16-4c5b-bc55-8d2fb1a8047f
/ # sudo sh /usr/share/mkinitrd/mkinitrd_command_generator.sh -k 4.4.14
#
# mkinitrd_command_generator.sh revision 1.45
#
# This script will now make a recommendation about the command to use
# in case you require an initrd image to boot a kernel that does not
# have support for your storage or root filesystem built in
# (such as the Slackware 'generic' kernels').
# A suitable 'mkinitrd' command will be:

mkinitrd -c -k 4.4.14 -f ext4 -r /dev/mmcblk0p2 -m usb-storage:xhci-hcd:mmc_core:sdhci:sdhci-pci:xhci-pci:ohci-pci:ehci-pci:uhci-hcd:ehci-hcd:hid:usbhid:i2c-hid:hid_generic:hid-cherry:hid-logitech:hid-logitech-dj:hid-logitech-hidpp:hid-lenovo:hid-microsoft:hid_multitouch:jbd2:mbcache:ext4 -u -o /boot/initrd.gz
/ # mkinitrd -c -k 4.4.14 -f ext4 -r /dev/mmcblk0p2 -m usb-storage:xhci-hcd:mmc_core:sdhci:sdhci-pci:xhci-pci:ohci-pci:ehci-pci:uhci-hcd:ehci-hcd:hid:usbhid:i2c-hid:hid_generic:hid-cherry:hid-logitech:hid-logitech-dj:hid-logitech-hidpp:hid-lenovo:hid-microsoft:hid_multitouch:jbd2:mbcache:ext4 -u -o /boot/initrd.gz
OK: /lib/modules/4.4.14/kernel/drivers/usb/storage/usb-storage.ko added.
OK: /lib/modules/4.4.14/kernel/drivers/usb/host/xhci-hcd.ko added.
OK: /lib/modules/4.4.14/kernel/drivers/mmc/core/mmc_core.ko added.
OK: /lib/modules/4.4.14/kernel/drivers/mmc/core/mmc_core.ko added.
  60-odd similar lines elided
OK: /lib/modules/4.4.14/kernel/fs/ext4/ext4.ko added.
38703 blocks
/boot/initrd.gz created.
Be sure to run lilo again if you use it.
/ #

seems much more agreeable than yesterday. But concerning the last line, run lilo again. Not lilo, but elilo was run on the original install, which command does not exist in this slackware fs, so no need to run it again?

But as both systems have versions of /boot/grub/grub.cfg decided to update grub, 1st on the lubuntu system which produced no change at all in its grub.cfg. Then on the slackware fs I got
Code:

/media/q/5bb5deec-0a16-4c5b-bc55-8d2fb1a8047f $  sudo mount --bind /dev /media/q/5bb5deec-0a16-4c5b-bc55-8d2fb1a8047f/dev
/media/q/5bb5deec-0a16-4c5b-bc55-8d2fb1a8047f $ sudo mount --bind /proc /media/q/5bb5deec-0a16-4c5b-bc55-8d2fb1a8047f/proc
/media/q/5bb5deec-0a16-4c5b-bc55-8d2fb1a8047f $  sudo mount --bind /sys /media/q/5bb5deec-0a16-4c5b-bc55-8d2fb1a8047f/sys
/media/q/5bb5deec-0a16-4c5b-bc55-8d2fb1a8047f $ sudo mount --bind /run /media/q/5bb5deec-0a16-4c5b-bc55-8d2fb1a8047f/run
/media/q/5bb5deec-0a16-4c5b-bc55-8d2fb1a8047f $  sudo chroot /media/q/5bb5deec-0a16-4c5b-bc55-8d2fb1a8047f
/ # grub-mkconfig -o /boot/grub/grub.cfg
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-huge-4.4.14
Found initrd image: /boot/initrd.gz
Found linux image: /boot/vmlinuz-huge
Found initrd image: /boot/initrd.gz
Found linux image: /boot/vmlinuz-generic-4.4.14
Found initrd image: /boot/initrd.gz
Found linux image: /boot/vmlinuz-generic
Found initrd image: /boot/initrd.gz
done
/ # exit

This has produced a much improved grub.cfg, but with no ubuntu entries at all. So now I'll see what happens with a normal boot.

colorpurple21859 03-24-2021 03:56 PM

What are you using for the primary boot loader?

porphyry5 03-24-2021 05:36 PM

Quote:

Originally Posted by colorpurple21859 (Post 6233793)
What are you using for the primary boot loader?

As far as I know, grub is the only boot loader on both systems, but I've now got the lubuntu grub.cfg to find slackware properly by adding
Code:

GRUB_DISABLE_OS_PROBER=false
to lubuntu's /etc/default/grub and rerunning grub-mkconfig.

At the boot menu selecting Slackware now runs far longer before crashing, right after processing usb sticks. So I think now I'll follow your earlier recommendation to update kernel and packages.

colorpurple21859 03-25-2021 06:24 AM

Did you try all the menu entries for slackware? What are the last few lines before it stops?

porphyry5 03-26-2021 02:35 PM

Quote:

Originally Posted by colorpurple21859 (Post 6233988)
Did you try all the menu entries for slackware? What are the last few lines before it stops?

With my HD, which is actually a 256gb usb stick, plugged into a 3.2 port, it stops at Kernel Panic, no menu.
With no external devices, it stops at command line, in something called BusyBox, which I didn't investigate, needing to look it up on the web to find how it works.

Trying to update existing packages not going well. Not understanding why can't find libaudit file in chroot when file exists and lib directory is mounted.
Code:

~ $ sudo mount --bind /usr /media/q/5bb5deec-0a16-4c5b-bc55-8d2fb1a8047f/usr
~ $ sudo mount --bind /lib /media/q/5bb5deec-0a16-4c5b-bc55-8d2fb1a8047f/lib
~ $ sudo chroot /media/q/5bb5deec-0a16-4c5b-bc55-8d2fb1a8047f
/ #  sudo slackpkg update gpg
sudo: error while loading shared libraries: libaudit.so.1: cannot open shared object file: No such file or directory
/ # exit
~ $ cd /media/q/5bb5deec-0a16-4c5b-bc55-8d2fb1a8047f
/media/q/5bb5deec-0a16-4c5b-bc55-8d2fb1a8047f $ sudo find . -iname '*libaudit*'
[sudo] password for q:
./lib/x86_64-linux-gnu/libaudit.so.1
./lib/x86_64-linux-gnu/libaudit.so.1.0.0
./usr/share/doc/libaudit1
./usr/share/doc/libaudit-common
./usr/share/man/man5/libaudit.conf.5.gz
/media/q/5bb5deec-0a16-4c5b-bc55-8d2fb1a8047f $


colorpurple21859 03-26-2021 05:11 PM

Quote:

sudo mount --bind /usr /media/q/5bb5deec-0a16-4c5b-bc55-8d2fb1a8047f/usr
~ $ sudo mount --bind /lib /media/q/5bb5deec-0a16-4c5b-bc55-8d2fb1a8047f/lib
This is wrong, the only directories that you mount bind before chroot is /dev /proc /sys /run. Those directories normally will be empty if mounted and viewed from another distro/live iso.

porphyry5 03-26-2021 07:02 PM

Quote:

Originally Posted by colorpurple21859 (Post 6234509)
This is wrong, the only directories that you mount bind before chroot is /dev /proc /sys /run. Those directories normally will be empty if mounted and viewed from another distro/live iso.

Yes, that made a great difference, if only to show me that I can have internet access only through lubuntu. So now I'm thinking download the latest packages through lubuntu and then using removepkg and installpkg. Is this feasible?

colorpurple21859 03-26-2021 07:29 PM

Quote:

if only to show me that I can have internet access only through lubuntu.
Copy ubuntu /etc/resolv.conf to slackware/etc see it that will allows running slackpkg from within chroot.

colorpurple21859 03-26-2021 08:57 PM

Quote:

it stops at command line, in something called BusyBox,
I don't think updates will fix this.
post slackware /etc/fstab and
Code:

lsblk -f

Didier Spaier 03-27-2021 08:09 AM

Nothing new: https://www.linuxquestions.org/quest...6/#post5750043

You are not the first to come across this issue: https://forum.salixos.org/viewtopic....p=46513#p46511

porphyry5 03-27-2021 01:30 PM

2 Attachment(s)
Quote:

Originally Posted by colorpurple21859 (Post 6234555)
I don't think updates will fix this.
post slackware /etc/fstab and
Code:

lsblk -f

Code:

/ # cat /etc/fstab
/dev/mmcblk0p2  /                ext4        defaults        1  1
/dev/mmcblk0p3  /home            ext4        defaults        1  2
#/dev/cdrom      /mnt/cdrom      auto        noauto,owner,ro,comment=x-gvfs-show 0  0
/dev/fd0        /mnt/floppy      auto        noauto,owner    0  0
devpts          /dev/pts        devpts      gid=5,mode=620  0  0
proc            /proc            proc        defaults        0  0
tmpfs            /dev/shm        tmpfs      defaults        0  0
/ # lsblk -f
NAME        FSTYPE LABEL UUID                                MOUNTPOINT
mmcblk0                                                       
├─mmcblk0p3  ext4        2ae29942-2e4d-480f-8447-bd4760dfe640
├─mmcblk0p1  vfat        D766-8D60                           
├─mmcblk0p4  ext4        465abeaa-ce77-48bc-8fe7-b8bd718a351e
└─mmcblk0p2  ext4        5bb5deec-0a16-4c5b-bc55-8d2fb1a8047f
mmcblk0boot0                                                 
mmcblk0boot1                                                 
sda                                                           
└─sda1      ext4  256GB 2b068e6d-e967-44a4-85eb-3f4d219a5d03
/ #

Also have dmesg for the 2 attempts to boot slackware that I described. slboot.1 has no usb slots occupied, slboot.2 has my HD in usb 3.x and a wifi dongle in usb 2.x

porphyry5 03-27-2021 02:11 PM

Quote:

Originally Posted by colorpurple21859 (Post 6234534)
Copy ubuntu /etc/resolv.conf to slackware/etc see it that will allows running slackpkg from within chroot.

Don't think its that simple, slackware doesn't have systemd, and lubuntu seems pretty secretive about the content of netif/
Code:

/etc $ readlink -f resolv.conf
/run/systemd/resolve/stub-resolv.conf

/etc $ cd /run/systemd/resolve/
/run/systemd/resolve $ ls
netif/  resolv.conf  stub-resolv.conf
/run/systemd/resolve $ cd netif
bash: cd: netif: Permission denied
/run/systemd/resolve $ sudo cd netif
sudo: cd: command not found
/run/systemd/resolve $ ls netif/*
ls: cannot access 'netif/*': Permission denied
/run/systemd/resolve $ sudo ls netif/*
ls: cannot access 'netif/*': No such file or directory
/run/systemd/resolve $ cat stub-resolv.conf
# This file is managed by man:systemd-resolved(8). Do not edit.
#
# This is a dynamic resolv.conf file for connecting local clients to the
# internal DNS stub resolver of systemd-resolved. This file lists all
# configured search domains.
#
# Run "systemd-resolve --status" to see details about the uplink DNS servers
# currently in use.
#
# Third party programs must not access this file directly, but only through the
# symlink at /etc/resolv.conf. To manage man:resolv.conf(5) in a different way,
# replace this symlink by a static file or a different symlink.
#
# See man:systemd-resolved.service(8) for details about the supported modes of
# operation for /etc/resolv.conf.

nameserver 127.0.0.53
options edns0
search caferoma

But if slackware uses a link like lubuntu, and one knew the name it would use for that link, it might work?

colorpurple21859 03-27-2021 07:00 PM

Change your /etc/fstab to this for the / and /home lines to use uuids

Code:

UUID=5bb5deec-0a16-4c5b-bc55-8d2fb1a8047f    /              ext4        defaults      1  1
uuid=2ae29942-2e4d-480f-8447-bd4760dfe640  /home            ext4        defaults      1  2

Quote:

Don't think its that simple, slackware doesn't have systemd,
coping using file manager won't work, from a terminal will
Code:

sudo cp /etc/resolv.conf /media/q/5bb5deec-0a16-4c5b-bc55-8d2fb1a8047f/etc/resolv.conf
add a wait and these modules to your mkinitrd command
Code:

-w 15 -m cqhci:uas:mmc_block

porphyry5 03-28-2021 02:20 PM

Quote:

Originally Posted by colorpurple21859 (Post 6234857)
add a wait and these modules to your mkinitrd command
Code:

-w 15 -m cqhci:uas:mmc_block

New initrd.gz created
Code:

/ # mkinitrd -c -k 4.4.14 -f ext4 -r /dev/mmcblk0p2 -m usb-storage:xhci-hcd:mmc_core:sdhci:sdhci-pci:xhci-pci:ohci-pci:ehci-pci:uhci-hcd:ehci-hcd:hid:usbhid:i2c-hid:hid_generic:hid-cherry:hid-logitech:hid-logitech-dj:hid-logitech-hidpp:hid-lenovo:hid-microsoft:hid_multitouch:jbd2:mbcache:ext4 -w 15 -m cqhci:uas:mmc_block -u -o /boot/initrd.gz
OK: /lib/modules/4.4.14/kernel/drivers/usb/storage/usb-storage.ko added.
OK: /lib/modules/4.4.14/kernel/drivers/usb/storage/uas.ko added.
OK: /lib/modules/4.4.14/kernel/drivers/mmc/core/mmc_core.ko added.
OK: /lib/modules/4.4.14/kernel/drivers/mmc/card/mmc_block.ko added.
34647 blocks
/boot/initrd.gz created.
Be sure to run lilo again if you use it.
/ #

fstab and copy successful, and slackpkg update gpg connects successfully, but wants an insecure connection
Code:

/ # slackpkg update gpg

mkdir: cannot create directory ‘/home/q/.gnupg’: No such file or directory
                        Downloading http://mirrors.slackware.com/slackware/slackware64-14.2/GPG-KEY...
--2021-03-28 11:23:57--  http://mirrors.slackware.com/slackware/slackware64-14.2/GPG-KEY
Resolving mirrors.slackware.com (mirrors.slackware.com)... 207.223.116.213
Connecting to mirrors.slackware.com (mirrors.slackware.com)|207.223.116.213|:80... connected.
HTTP request sent, awaiting response... 302 Found
Location: https://mirrors.slackware.com/slackware/slackware64-14.2/GPG-KEY [following]
--2021-03-28 11:23:59--  https://mirrors.slackware.com/slackware/slackware64-14.2/GPG-KEY
Connecting to mirrors.slackware.com (mirrors.slackware.com)|207.223.116.213|:443... connected.
ERROR: cannot verify mirrors.slackware.com's certificate, issued by ‘CN=R3,O=Let's Encrypt,C=US’:
  Unable to locally verify the issuer's authority.
To connect to mirrors.slackware.com insecurely, use `--no-check-certificate'.

slackpkg does not accept '--no-check-certificate', as a parameter, so will try adding it to the 'mirrors.slackware.com' line in /etc/slackpkg/mirrors. But it will not accept any uncommented line containing anything other than an url.

Checking those dmesg files I attached, they're pretty useless, don't include the part at the end where it all goes wrong. Also, slackware was generating error messages before it crashed that dmesg does not show. /var/log contains nothing created on 3/27. Is there any way of capturing the boot process record to a file as it proceeds? Otherwise, the only thing I can think of is to photograph the screen as it runs.

Tried booting slackware with new initrd: it fails now with
Code:

mount can't find /mnt in fstab
ERROR: no /sbin/init on rootdev
Trying to mount /dev on /mnt/dev

Typing exit got the Busybox again

So I added a UUID line for /mnt in slacware's /etc/fstab and tried again. Same result, same message no /mnt in fstab.

porphyry5 03-28-2021 02:41 PM

Quote:

Originally Posted by Didier Spaier (Post 6234654)

Thank you for this info, but I prefer to learn from this manual diagnosis and repair process.

colorpurple21859 03-28-2021 04:18 PM

You may have to use a newer kernel than what is in 14.2. I was looking through other threads with a similar problem, and came across one where slackware-current would boot, but slackware 14.2 wouldn't.
that should have been
Code:

mkinitrd -c -k 4.4.14 -f ext4 -w 15 -r /dev/mmcblk0p2 -m usb-storage:xhci-hcd:mmc_core:sdhci:sdhci-pci:xhci-pci:ohci-pci:ehci-pci:uhci-hcd:ehci-hcd:hid:usbhid:i2c-hid:hid_generic:hid-cherry:hid-logitech:hid-logitech-dj:hid-logitech-hidpp:hid-lenovo:hid-microsoft:hid_multitouch:jbd2:mbcache:ext4:cqhci:uas:mmc_block -u -o /boot/initrd.gz

Didier Spaier 03-28-2021 05:36 PM

Quote:

Originally Posted by porphyry5 (Post 6235065)
Thank you for this info, but I prefer to learn from this manual diagnosis and repair process.

np. Anyway I wrongly assumed this machine had a NVMe drive but it has an eMMC.

colorpurple21859 03-29-2021 09:53 AM

For the cqhci driver you will need the 4.19 kernel or newer.

porphyry5 03-29-2021 02:49 PM

Quote:

Originally Posted by colorpurple21859 (Post 6235078)
You may have to use a newer kernel than what is in 14.2. I was looking through other threads with a similar problem, and came across one where slackware-current would boot, but slackware 14.2 wouldn't.
that should have been
Code:

mkinitrd -c -k 4.4.14 -f ext4 -w 15 -r /dev/mmcblk0p2 -m usb-storage:xhci-hcd:mmc_core:sdhci:sdhci-pci:xhci-pci:ohci-pci:ehci-pci:uhci-hcd:ehci-hcd:hid:usbhid:i2c-hid:hid_generic:hid-cherry:hid-logitech:hid-logitech-dj:hid-logitech-hidpp:hid-lenovo:hid-microsoft:hid_multitouch:jbd2:mbcache:ext4:cqhci:uas:mmc_block -u -o /boot/initrd.gz

Thank you so much for your help. This mkinitrd gives me a login shell!!

porphyry5 03-29-2021 02:50 PM

Quote:

Originally Posted by colorpurple21859 (Post 6235237)
For the cqhci driver you will need the 4.19 kernel or newer.

Got it. And thank you again

colorpurple21859 03-29-2021 04:33 PM

Great you got it working with the 4.4 kernel.

porphyry5 03-31-2021 03:15 PM

Quote:

Originally Posted by colorpurple21859 (Post 6235338)
Great you got it working with the 4.4 kernel.

Correction: you got it working, I was an interested bystander.
One last question: the modules you were adding to mkinitrd-generator, where are they contained in the system?

colorpurple21859 03-31-2021 03:28 PM

They are in /lib/modules/<kernel version>/kernel are added to the initrd.gz to allow the kernel to preload them before attempting to access the drive for the root filesystem.

porphyry5 04-01-2021 02:09 PM

Quote:

Originally Posted by colorpurple21859 (Post 6235980)
They are in /lib/modules/<kernel version>/kernel are added to the initrd.gz to allow the kernel to preload them before attempting to access the drive for the root filesystem.

Thank you, and can this be taken as a generalization, that kernel panic always means "unable to proceed" with whatever it started doing immediately before the panic?

colorpurple21859 04-01-2021 02:46 PM

That is one way of looking at it.


All times are GMT -5. The time now is 04:40 AM.