-   Slackware - Installation (
-   -   14.1 on Acer Aspire One (

mscole 03-14-2014 07:14 PM

14.1 on Acer Aspire One
I have an Acer Aspire One that is a few years old. It has an Atom N450 cpu 1.66GHz, 1 GB ram, 160GB hard disk, and Windows seven. I would like to dual boot. I shrunk the C disk in Windows, made a usb bootstick, but when it gets to the Boot: prompt, it does not respond to the keyboard. I am able to boot a usb installation bootstick for 13.7, but I would really like 14.1. Has anyone done this successfully? I suspect the newer kernel in 14.1 is incompatible with the bios, cpu, or motherboard, but I hope somebody out there can prove me wrong. Mike.

mscole 03-14-2014 08:51 PM

After some more thought I realized I was never making it to the kernel, so the incompatibility must be with the usb boot stick itself. I made a new bootstick with 13.7, then tried to copy hugesmp.s from 14.1 and initrd.img to the 13.37 bootstick. The kernel copied, but the initial ramdisk would not fit because the usb stick was full. So I deleted the partial copy of initrd.img from the bootstick, and tried to boot from it. This time when I hit enter at the Boot: prompt, it started to load the kernel from 14.1, then hung when it could not find an initial ramdisk. Any ideas?

mscole 03-14-2014 09:06 PM

I think I'm going to install 13.7 and then upgrade to 14.1. I will post again after I try it tomorrow.

mscole 03-15-2014 08:44 PM

I can't boot from the 14.0 or the 14.1 USB install bootstick, but I can install from the 13.37 bootstick. I installed 13.37, and chose to install lilo on the MBR. Slackware boots, but if I try to boot windows 7 it takes me to the Acer Recovery program. I guess my computer doesn't like anything to change on the MBR, so I will have to start from scratch because I want to dual boot windows and slack. So I will run Acer Recovery, re-install 13.37 and install lilo on my root partition (I hope this works, it's an extended partition). I'll post again after I try this in case anyone is interested. It will probably be a few days.

Drakeo 03-16-2014 11:54 AM

to me that was what happened years ago back in 1997 windows would take me to a recovery mode check the disk and be done. for win 7 I have no clue. If the recovery program actually wipes the Slackware install you could have problems. keep us updated.

allend 03-16-2014 06:02 PM

Check the partitions on your hard disk. It sounds as though there is a recovery partition, then the Windows 7 boot partition, then the Windows 7 proper partition. You will need lilo to point to the Windows 7 boot partition to boot Windows 7.

mscole 03-16-2014 09:49 PM

Well, I managed to corrupt my windows boot partition and my acer windows recovery partition. I tried uninstalling lilo, but nothing worked, so I booted the 13.37 install stick, deleted all the partitions, made a swap, /, and home partition, and installed 13.37. That worked, I lost windows 7 recovery, but I don't really care.
I usually do a clean install when I upgrade Slack, so this was my first upgrade. I followed the instructions in UPGRADE.TXT to upgrade from 13.37 to 14.0, and it seems to be fine.
Tomorrow I will upgrade to 14.1, and then start KDE for the first time, and will see how well the various features that are particular to my netbook (e.g. power management) run under 14.1
Stay tuned.

mscole 03-18-2014 08:10 PM

I think I found a solution. The Slackware installation tree contains a folder called isolinux, with instructions for making a bootable installation DVD. It also tells how to make an iso that can be transferred to a usb stick and make it bootable. I am running the installation of 14.1 from such a usb stick right now, and it seems to be working smoothly. Mike.

s.verma 03-19-2014 02:18 AM

Dear mscole,
From what media you have made your usbstick bootable for install.
I mean to say have you used DVD iso. Why not use Unetbootin to boot iso file from usb stick.

Drakeo 03-19-2014 03:26 AM


Well, I managed to corrupt my windows boot partition and my acer windows recovery partition. I tried uninstalling lilo
you know. first if you want to keep windows you make a windows boot disk. second to get the mbr back you fdisk mbr that wipes it. then you put your windows boot disk in and do a boot recovery.

All times are GMT -5. The time now is 07:58 AM.