LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - ARM
User Name
Password
Slackware - ARM This forum is for the discussion of Slackware ARM.

Notices


Reply
  Search this Thread
Old 09-22-2018, 10:56 PM   #1
asarangan
Member
 
Registered: Jul 2009
Posts: 36

Rep: Reputation: 5
wlan0 not scanning on B+


I am running Slackware ARM 14.2 on a RP 3B+. I saw that some people had issues with wifi. My wlan0 device is being recognized, but it shows no results. "iwlist wlan0 scan" comes back with
"wlan0 No scan results. "

I know there are plenty of strong wifi signals nearby.

I also edited the /etc/wpa_supplicant.conf and added "country=US", but that does not seem to make any difference. The exact same setup works fine on the RP 3B (I have three of them running, and they are all connected via wifi). This issue seems specific to the 3B+. Any thoughts?
 
Old 09-23-2018, 04:49 PM   #2
abga
Member
 
Registered: Jul 2017
Location: EU
Distribution: Slackware
Posts: 720

Rep: Reputation: 400Reputation: 400Reputation: 400Reputation: 400Reputation: 400
Give the official kernel a try, if you're not already using it.
Follow the second half of this post, starting from "Follow the manual installation method, focus":
https://www.linuxquestions.org/quest...4/#post5862696
And use the latest Raspberry provided image to extract the kernel&stuff:
http://director.downloads.raspberryp...retch-lite.zip

P.S.
https://www.raspberrypi.org/forums/v...?f=28&t=209409

Last edited by abga; 09-24-2018 at 06:17 PM. Reason: P.S.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
network-manager scanning for wifi's on wlan1 but won't scan when on wlan0? BlackHawk Linux - Networking 2 12-26-2011 07:56 PM
"iwlist wlan0 scanning" doesn't see my AP. darkmaster977 Linux - Wireless Networking 5 11-22-2009 08:04 AM
Active Scanning or Passive Scanning Paris Heng Linux - Networking 2 02-15-2008 10:37 AM
iwlist wlan0 scanning lefter Fedora 1 12-28-2006 09:57 AM
Broadcom wireless with ndiswrapper: ifconfig wlan0 works; ifup wlan0 fails orangechicken Linux - Wireless Networking 2 04-17-2004 06:39 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - ARM

All times are GMT -5. The time now is 03:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration