LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - ARM
User Name
Password
Slackware - ARM This forum is for the discussion of Slackware ARM.

Notices


Reply
  Search this Thread
Old 11-22-2017, 09:06 PM   #31
glorsplitz
Member
 
Registered: Dec 2002
Distribution: slackware!
Posts: 497

Rep: Reputation: 88

@adamsimms, I have 2 rpi3 running current all up to date no connectivity issues.

What raspberry pi versions? What slackware versions?

Last edited by glorsplitz; 11-22-2017 at 09:17 PM.
 
Old 11-23-2017, 09:47 AM   #32
adamsimms
LQ Newbie
 
Registered: Nov 2017
Posts: 6

Rep: Reputation: Disabled
@glorsplitz It's a Raspberry Pi 3 running Jessie. Latest apt-get update && apt-get upgrade & apt-get dist-upgrade have been performed.

@business_kid I'm not sure if this is possible, but would I be able to hire you to help me troubleshoot this issue further?
 
Old 11-23-2017, 02:13 PM   #33
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 8,684

Rep: Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876
There's no need to hire - this is a forum. You just need a little familiarity with this stuff. I found it a nightmare when I started. Here's a few commands to check.
<sudo iwconfig -a> lists all network devices. Presuming yours is wlan0
<sudo iwlist wlan0 scan |grep -C3 Quality> Should show you all local wifi points like this with channel numbers and quality
Code:
sudo iwlist wlan0 scan |grep -C3 Quality
    Cell 17 - Address: 14:49:E0:9E:B0:B9
                    Channel:6
                    Frequency:2.437 GHz (Channel 6)
                    Quality=20/70  Signal level=-90 dBm  
                    Encryption key:on
                    ESSID:"Horizon Wi-Free"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 9 Mb/s
--
          Cell 18 - Address: 5C:A3:9D:BA:B0:98
                    Channel:1
                    Frequency:2.412 GHz (Channel 1)
                    Quality=41/70  Signal level=-69 dBm  
                    Encryption key:on
                    ESSID:"UPC242033514"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 9 Mb/s
--
          Cell 19 - Address: 58:2A:F7:E1:F4:15
                    Channel:9
                    Frequency:2.452 GHz (Channel 9)
                    Quality=22/70  Signal level=-88 dBm  
                    Encryption key:on
                    ESSID:"eir_WiFi"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s[SNIP]
Post the Quality on your own service please.

I gather you're on some version of slackware? There's a DHCP_KEEPRESOLV setting in /etc/rc.d/rc.inet1.conf which you need to uncomment and set to yes. That will stop dhcpcd overwriting resolv.conf. Look for it with grep -n, which gives you a line number. Also, the easiest way to start the wifi is
Code:
sudo /etc/rc.d/rc.inet1 restart
 
Old 11-23-2017, 03:44 PM   #34
adamsimms
LQ Newbie
 
Registered: Nov 2017
Posts: 6

Rep: Reputation: Disabled
@business_kid Here is the output of sudo iwlist wlan0 scan |grep -C3 Quality

Code:
Cell 01 - Address: D6:D9:19:9A:00:5A
                    Channel:1
                    Frequency:2.412 GHz (Channel 1)
                    Quality=55/70  Signal level=-55 dBm  
                    Encryption key:on
                    ESSID:"DiscoPro"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
 
Old 11-23-2017, 03:50 PM   #35
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 8,684

Rep: Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876
Ok. your card can see the wifi. Looks exactly like mine. That seems to clear that wifi.
If you can switch off encryption, you should be able to connect with
Code:
dhcpcd wlan0
 
Old 11-23-2017, 04:12 PM   #36
adamsimms
LQ Newbie
 
Registered: Nov 2017
Posts: 6

Rep: Reputation: Disabled
@business_kid

I'm not able to disable the encryption. For a little more context, this is a remote solar powered Raspberry Pi connected with a USB LTE stick. I'm able to SSH into the Raspberry Pi via this connection.

I'm trying to connect to a GoPro AP to download images, which was working for months. The GoPro turns on, enables WiFi, takes an image, then goes to sleep every hour. Suddenly I'm not able to connect to it's WiFi. In this context, I can't change anything about the AP physically or software wise.

It could be a problem with the GoPro, but based on my Pi I can see that it still comes on and enables wifi every hour - which lead me to believe that this is still a Raspberry Pi issue. If you would like to SSH into the Pi and take a look you are welcome. The purpose of my system is not working so anything will help.

Thanks!
 
Old 11-24-2017, 05:29 AM   #37
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 8,684

Rep: Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876
I don't see how I can ssh in if you haven't got internet.
Ok. Let's presume the card is working, dhcp is working, and get down to wpa_supplicant. Humour me and copy your wpa -supplicant.conf into /etc, as that's the usual location in my Slackware anyhow. Then start wpa_supplicant. Here's what I used, and what I got.
Code:
root@RoseViolet:~# wpa_supplicant  -iwlan0 -c/etc/wpa_supplicant.conf
Successfully initialized wpa_supplicant
wlan0: CTRL-EVENT-REGDOM-CHANGE init=BEACON_HINT type=UNKNOWN
wlan0: SME: Trying to authenticate with 34:81:c4:e0:4b:88 (SSID='MY_ESSID' freq=2437 MHz)
wlan0: Trying to associate with 34:81:c4:e0:4b:88 (SSID='MY_ESSID' freq=2437 MHz)
wlan0: Associated with 34:81:c4:e0:4b:88
wlan0: CTRL-EVENT-REGDOM-CHANGE init=COUNTRY_IE type=COUNTRY alpha2=IE
wlan0: WPA: Key negotiation completed with 34:81:c4:e0:4b:88 [PTK=CCMP GTK=TKIP]
wlan0: CTRL-EVENT-CONNECTED - Connection to 34:81:c4:e0:4b:88 completed [id=0 id_str=]
And the Network looks like this
Code:
bash-4.3$ iwconfig wlan0
wlan0     IEEE 802.11  ESSID:"MY_ESSID"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: 34:81:C4:E0:4B:88   
          Bit Rate=135 Mb/s   Tx-Power=15 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=62/70  Signal level=-48 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:17   Missed beacon:0
Now I would have to start dhcpcd to get myself an IP & route. If wpa_supplicant fails, reinstall that, retry, and add '-d' to the command shown. Paste the output to pastebin, and we'll have to grok it for clues. What's your kernel? Distro, or home built?
 
Old 11-24-2017, 12:53 PM   #38
adamsimms
LQ Newbie
 
Registered: Nov 2017
Posts: 6

Rep: Reputation: Disabled
wpa_supplicant -iwlan0 -c/etc/wpa_supplicant.conf outputs:

Code:
Successfully initialized wpa_supplicant
wlan0: Trying to associate with d6:d9:19:9a:00:5a (SSID='DiscoPro' freq=2412 MHz)
wlan0: CTRL-EVENT-ASSOC-REJECT status_code=16
wlan0: Trying to associate with d6:d9:19:9a:00:5a (SSID='DiscoPro' freq=2412 MHz)
wlan0: CTRL-EVENT-ASSOC-REJECT status_code=16
wlan0: Trying to associate with d6:d9:19:9a:00:5a (SSID='DiscoPro' freq=2412 MHz)
wlan0: CTRL-EVENT-ASSOC-REJECT status_code=16
wlan0: Trying to associate with d6:d9:19:9a:00:5a (SSID='DiscoPro' freq=2412 MHz)
wlan0: CTRL-EVENT-ASSOC-REJECT status_code=16
wlan0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="DiscoPro" auth_failures=1 duration=10 reason=CONN_FAILED
wpa_supplicant v2.3

Linux version 4.9.64-v7+ (dc4@dc4-XPS13-9333) (gcc version 4.9.3 (crosstool-NG crosstool-ng-1.22.0-88-g8460611) ) #1053 SMP Tue Nov 21 14:56:27 GMT 2017

PRETTY_NAME="Raspbian GNU/Linux 8 (jessie)"
NAME="Raspbian GNU/Linux"
VERSION_ID="8"
VERSION="8 (jessie)"

Last edited by adamsimms; 11-24-2017 at 01:09 PM.
 
Old 11-24-2017, 04:18 PM   #39
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 8,684

Rep: Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876
If everything's correct, and wpa has been reinstalled, you've one last option, which is to check it's loading firmware and that the firmware is good. Also the manufacturer's site for downloads. Errors of that sort are SSID/PSK, firmware, reception, or occasionally hardware.I've asked about all of them, but haven't always been answered. Check for a driver bug also. I would next suggest a usb wifi from ebay which can stay under the 100mA. The one I got had some weirdo realtek chip but I was able to compile a driver for the early ras-pi I had. You mightn't get that with 802.11n, but you can make the choices. If you have the wpa config, the wpa package, or anything else wrong, of course, it won't work.
 
Old 11-25-2017, 02:36 AM   #40
SCerovec
Senior Member
 
Registered: Oct 2006
Location: Cp6uja
Distribution: Slackware on x86 and arm
Posts: 1,168
Blog Entries: 2

Rep: Reputation: 166Reputation: 166
There are Atheros USB WiFi dongles out there - buy, compile the (mainline) kernel module (if not already present) and off You go.
They do cost a bit more than the realtek ones, but it pays off later, in the setup.

my 2c
 
Old 11-25-2017, 04:59 AM   #41
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 8,684

Rep: Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876
Just thinking, if you don't like this and have another box on hand, you can set up a wifi & dhcp server on that, and try logging in with your raspi. You may even go to setting up wpa_supplicant in server mode and completely duplicate your own setup. That way,you'll be able to fool around and gradually narrow things down. If you keep coming up against wpa_supplicant, and have reinstalled it, it could be hardware. But you eliminate everything else first. It's unusual for hardware to fail that way; Not impossible, but unusual.
 
Old 11-26-2017, 02:33 PM   #42
Penthux
Member
 
Registered: Dec 2008
Location: Middlesbrough, UK
Distribution: Slackware
Posts: 144

Rep: Reputation: 35
There's a "Setting up a wireless network connection on Slackware ARM on a Raspberry Pi 1, 2 or 3" guide/tutorial on the SARPi website if it helps at all.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound issues with slack 10.2 and onboard sound chip ricardo_ok Slackware 10 08-21-2006 01:38 PM
Onboard sound chip problem after kernel upgrade coralsaw Debian 4 06-15-2006 03:25 AM
Getting sound in slackware 9.1 with a ess 1868 onboard chip! HELP! toolfan Slackware - Installation 6 05-19-2004 07:21 PM
Need to Know Whether my Onboard Graphics Chip is an Intel i810 Huddlebum Linux - General 4 04-04-2004 11:14 AM
Audio driver for Gigabyte GA8IK1100's onboard sound chip? TMMO Linux - Newbie 1 08-10-2003 05:59 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - ARM

All times are GMT -5. The time now is 11:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration