LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - ARM
User Name
Password
Slackware - ARM This forum is for the discussion of Slackware ARM.

Notices


Reply
  Search this Thread
Old 01-05-2017, 08:55 PM   #1
slackist
Member
 
Registered: Feb 2004
Location: Phuket
Distribution: Slackware 14.1 and Slackware Arm
Posts: 478

Rep: Reputation: 41
RPi3 WiFi issues with onboard chip


The onboard wifi seemed to die a while back after I used the rpi-update utility so I stopped using it and just stuck with the reliable Slackware-ARM+cabled ethernet but I'd like to resolve it.

On boot it throws up the following messages that seem to be related to the problem:

Code:
[    4.461534] usbcore: registered new interface driver brcmfmac
[    4.698592] brcmfmac: brcmf_c_preinit_dcmds: Firmware version = wl0: May 27 2016 00:13:38 version 7.45.41.26 (r640327) FWID 01-df77e4a7
[    4.729301] brcmfmac: brcmf_cfg80211_reg_notifier: not a ISO3166 code
[    4.913421] brcmfmac: brcmf_cfg80211_reg_notifier: not a ISO3166 code
[    4.729301] brcmfmac: brcmf_cfg80211_reg_notifier: not a ISO3166 code
[    4.913421] brcmfmac: brcmf_cfg80211_reg_notifier: not a ISO3166 code
[    4.920253] cfg80211: World regulatory domain updated:
[    4.926905] cfg80211:  DFS Master region: unset
[    4.927044] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[    4.940538] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[    4.947310] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz, 92000 KHz AUTO), (N/A, 2000 mBm), (N/A)
[    4.954525] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm), (N/A)
[    4.961176] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (N/A)
[    4.968485] cfg80211:   (5250000 KHz - 5330000 KHz @ 80000 KHz, 160000 KHz AUTO), (N/A, 2000 mBm), (0 s)
[    4.975378] cfg80211:   (5490000 KHz - 5730000 KHz @ 160000 KHz), (N/A, 2000 mBm), (0 s)
[    4.981916] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[    4.988559] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm), (N/A)
I've tried many google tips about setting the reg domain etc, tried messing with rc.inetd and a host of other things.

Network mode on my router is 802.11b/g/n
Domain is China
Channel is 7
Frequency bandwidth is 20MHz/40MHz

I have tried wpa_supplicant with everything I can find to resolve it (including turning off all authentication) and nothing seems to work. I have tried making rc.firewall not start at boot but no luck.

Have I fried the onboard wifi or am I just being thick as usual?
 
Old 01-06-2017, 04:58 AM   #2
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 8,684

Rep: Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876
I gather you upgraded. Does it work if you downgrade it?
 
1 members found this post helpful.
Old 01-06-2017, 09:43 AM   #3
glorsplitz
Member
 
Registered: Dec 2002
Distribution: slackware!
Posts: 497

Rep: Reputation: 88
Your issue is wifi is just not working? Searching for "not a ISO3166 code" there's this

Code:
sudo iwconfig wlan0 power off
On a laptop I commented rate to let it default and got wifi to work better.
 
Old 01-06-2017, 12:38 PM   #4
Penthux
Member
 
Registered: Dec 2008
Location: Middlesbrough, UK
Distribution: Slackware
Posts: 144

Rep: Reputation: 35
Quote:
Originally Posted by slackist View Post
Have I fried the onboard wifi or am I just being thick as usual?
Most probably "No", and certainly "No".

The RPi3 onboard WNIC is tricky at the best of times. I've stopped using it because it's just cheap and unreliable, in my experience. So without intentionally dancing around your question/problem I'd advise you to get hold of the easiest USB wireless adapter you can lay your hands on and use that instead. It's more than likely going to serve you better. However, if you don't have access to one of these, take a look at alienBOB's pretty comprehensive networking guide which might help to point you in the right direction:

http://alien.slackbook.org/dokuwiki/...eless_networks

Also, there's the following SARPi page which you might find useful:

http://sarpi.fatdog.eu/index.php?p=wireless-nic

Hope it helps.

Last edited by Penthux; 01-06-2017 at 12:40 PM. Reason: edited URL
 
1 members found this post helpful.
Old 01-08-2017, 05:18 PM   #5
titopoquito
Senior Member
 
Registered: Jul 2004
Location: Lower Rhine region, Germany
Distribution: Slackware64 14.2 and current, SlackwareARM current
Posts: 1,596

Rep: Reputation: 125Reputation: 125
Just a shot in the dark: If you have installed some HAT onto the Raspberry Pi there can be interferences. Lately I tried an Sound Hat (DAC) for example, but that one had reportedly a broken design, so that two parts of it are electro-magnetical interfering with the Raspberry's Wifi chip. So if you have installed any additional hardware part please be sure to test Wifi also without it.
 
Old 01-09-2017, 08:08 AM   #6
slackist
Member
 
Registered: Feb 2004
Location: Phuket
Distribution: Slackware 14.1 and Slackware Arm
Posts: 478

Original Poster
Rep: Reputation: 41
Quote:
Originally Posted by business_kid View Post
I gather you upgraded. Does it work if you downgrade it?
Nope, still no joy

Quote:
Originally Posted by glorsplitz View Post
Your issue is wifi is just not working? Searching for "not a ISO3166 code" there's this

Code:
sudo iwconfig wlan0 power off
I've been through the Raspi forums and nothing suggested there works for me

Quote:
Originally Posted by Penthux View Post
<snipped>

The RPi3 onboard WNIC is tricky at the best of times. I've stopped using it because it's just cheap and unreliable, in my experience. So without intentionally dancing around your question/problem I'd advise you to get hold of the easiest USB wireless adapter you can lay your hands on and use that instead. It's more than likely going to serve you better.
I've been through aliensBOB's excellent guide several times and I think I've got everything in the right place but the thing still won't connect. I've got an old wifi dongle and that will connect fine but it's slow so I think I'll just stick with wired and give up for now. It seems that somehow broadcom and my router just can't get along.

The most frustrating part is that iwlist scan shows the router with the correct ESSID but the %^&$$ thing just won't associate with it.

Quote:
Originally Posted by titopoquito View Post
Just a shot in the dark: <snip>
Thanks for that, an intriguing idea. I don't have a HAT on it, just a ribbon cable to a T-cobbler. I disconnected it and it didn't make any difference unfortunately.
 
Old 01-09-2017, 01:47 PM   #7
interndan
Member
 
Registered: Aug 2004
Location: near Marion, Ill
Distribution: Slackware 14.2 32bit on laptop
Posts: 302

Rep: Reputation: 24
I don't know if this is any help for you since I don't have a RPI3, but I have found that installing wicd from extra and letting it handle wireless connections with broadcom cards works best. I never had any luck with networkmanager or manual configs. I also found after an upgrade that the newest drivers from broadcom (even though they are supposed to be compatible) didn't work consistently with my card. I had to download and build an older driver version to regain consistent operation.
 
2 members found this post helpful.
Old 01-12-2017, 05:14 PM   #8
SCerovec
Senior Member
 
Registered: Oct 2006
Location: Cp6uja
Distribution: Slackware on x86 and arm
Posts: 1,168
Blog Entries: 2

Rep: Reputation: 166Reputation: 166
1. aircrack-ng
2. kismet
3. wireshark
and try capture and analyze what Pi "hears" and what it "says" to the AP.

I had quite few times "almost" working drivers since 2k5 (PCI-ACX) over a wide variety if chips sometimes it's just the driver (kernel update and maybe even a patch only helps).

Not that I solved anything, but a point to an viable direction?
 
Old 01-13-2017, 05:46 AM   #9
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 8,684

Rep: Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876
I'm surprised that you couldn't restore function with a return to what was (I presume) a working system. What have you installed now?
When I have this issue, I try and narrow it down. Booted up & wifi started, post the output of these run one at a time in the given order (presuming wlan0 is your wifi device)
Code:
ifconfig wlan0 up
iwconfig wlan0
ping -c3 -I wlan0 <IP of your router, e.g. 192.168.1.1>
iwlist wlan0 scan
If these read ok, you're down to dhcp & wpa_supplicant. If they don't, it's probably the driver.
 
Old 01-13-2017, 09:52 AM   #10
slackist
Member
 
Registered: Feb 2004
Location: Phuket
Distribution: Slackware 14.1 and Slackware Arm
Posts: 478

Original Poster
Rep: Reputation: 41
Thanks for those.

I've just (yesterday) had a cataract operation so it'll be a little while until I get back to trying this. I'll will post back when I start up trying again.

Cheers.
 
Old 01-13-2017, 11:09 AM   #11
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 8,684

Rep: Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876
My sympathies. I know about life's limitations. Get well soon.
 
1 members found this post helpful.
Old 02-06-2017, 09:21 PM   #12
slackist
Member
 
Registered: Feb 2004
Location: Phuket
Distribution: Slackware 14.1 and Slackware Arm
Posts: 478

Original Poster
Rep: Reputation: 41
Meh, I am convinced it's broken now or the firmware is simply not compatible with my router.

I put raspian onto a card and then openelec and neither can connect to my WiFi. Even if I fiddle with the router settings to turn off all security my (old) Android phone will happily connect, as will my Mrs' iPhone, an iMac we have in the house, her work laptop which is on Win10, an Android tablet and an ancient SMC EZConnect g wifi dongle.

Thanks to all of you that tried to help but I think it is a hardware issue, probably caused by me shorting out something or other while I play around with my breadboard!
 
Old 02-07-2017, 04:43 AM   #13
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 8,684

Rep: Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876Reputation: 876
If you run through post #9 we might be able to call it for you.
 
1 members found this post helpful.
Old 02-08-2017, 01:51 AM   #14
justwantin
Member
 
Registered: Aug 2003
Location: Melbourne, Australia
Distribution: Slackware, Slackwarearm
Posts: 697

Rep: Reputation: 71
Darn hot out there and allot still to do but came in to cool off and saw this thread and thought I'd throw in my two cents/pence/whatever. This is my drill.

First check if your system sees a wifi something by as root running iwconfig if iwconfig returns with a wlan0 or so your system has loaded a module for your wireless device/chip and a wirless device wlanX has be created. If there is no wlanX then your wireless chip device has not been recognised and a device created.

If it has been created then here is what I would do if it was wlan0:

iwconfig wlan0 essid myessid # and if the essid is broken by a space put it in quotes

Then run iwconfig wlan0 to see what you get. Here's what I have out in the garden shed:
Code:
root@bpi9:/home/rick# iwconfig wlan0
wlan0     IEEE 802.11bg  ESSID:"gerrygarcia"  Nickname:"rtl_wifi"
          Mode:Managed  Frequency:2.462 GHz  Access Point: A0:63:91:74:C0:C4   
          Bit Rate:54 Mb/s   Sensitivity:0/0  
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:****-****-****-****-****-****-****-****   Security mode:open
          Power Management:off
          Link Quality=68/100  Signal level=58/100  Noise level=0/100
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
Now I would run ifconfig wlan0 up there should be nothing returned in the terminal and if so try to see what's about with iwlist wlan0 scan. If you see something returned indicating there is life out there, ie. your lan and anything else within range.

Ok you can now configure your wireless network connection using wicd very easily if you are GUI or an ssh X session after installing wicd as long as /etc/rc.d/rc.inet1.conf is clean and /etc/rc.d/rc.networkmanager is chmod -x and /etc/rc.d/rc.wicd is chmod +x

Maybe that will help. If you are working in a terminal you can use wicd-curses which is what I do when I can but there is a problem with the packaged wicd/curses/netentry_curses.pi in slackwarearm that will stuff things up. I have one that works but I am in remiss and having not yet submitted a patch and after this post I suppose I better learn how to make a diff!

Last edited by justwantin; 02-08-2017 at 01:53 AM. Reason: tyop
 
1 members found this post helpful.
Old 02-08-2017, 11:02 AM   #15
slackist
Member
 
Registered: Feb 2004
Location: Phuket
Distribution: Slackware 14.1 and Slackware Arm
Posts: 478

Original Poster
Rep: Reputation: 41
Quote:
Originally Posted by business_kid View Post
If you run through post #9 we might be able to call it for you.
I apologise business_kid for not responding to post #9, here are the results of the tests, I did issue ifconfig eth0 down and /etc/rc.d/rc.firewall stop before running the tests.
Code:
[root@darkmoon:~] # iwconfig wlan0
wlan0     IEEE 802.11bgn  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=31 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:on


[root@darkmoon:~] # ping -c3 -I wlan0 192.168.1.1
ping: Warning: source address might be selected on device other than wlan0.
PING 192.168.1.1 (192.168.1.1) from 192.168.1.19 wlan0: 56(84) bytes of data.
^C
--- 192.168.1.1 ping statistics ---
0 packets transmitted, 0 received
[root@darkmoon:~] # iwlist wlan0 scan

wlan0     Scan completed :
          Cell 01 - Address: 18:A3:E8:23:67:10
                    Channel:7
                    Frequency:2.442 GHz (Channel 7)
                    Quality=27/70  Signal level=-83 dBm  
                    Encryption key:on
                    ESSID:"House1000"
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              9 Mb/s; 12 Mb/s; 18 Mb/s
                    Bit Rates:24 Mb/s; 36 Mb/s; 48 Mb/s; 54 Mb/s
                    Mode:Master
                    Extra:tsf=0000000000000000
                    Extra: Last beacon: 80ms ago
                    IE: Unknown: 0009486F75736531303030
                    IE: Unknown: 010882848B960C121824
                    IE: Unknown: 030107
                    IE: Unknown: 050400010100
                    IE: Unknown: 2A0104
                    IE: Unknown: 32043048606C
                    IE: WPA Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (1) : TKIP
                        Authentication Suites (1) : PSK
                    IE: IEEE 802.11i/WPA2 Version 1
                        Group Cipher : TKIP
                        Pairwise Ciphers (1) : TKIP
                        Authentication Suites (1) : PSK
                    IE: Unknown: DD180050F2020101000003A4000027A4000042435E0062322F00
                    IE: Unknown: DD0600E04C020160
                    IE: Unknown: DD180050F204104A00011010440001021049000600372A000120
For justwantin:

Code:
[root@darkmoon:~] # iwconfig wlan0
wlan0     IEEE 802.11bgn  ESSID:"House1000"  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=31 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:on
In case this helps here is my wpa_supplicant.conf file with a bit removed:

Code:
[root@darkmoon:~] # cat /etc/wpa_supplicant.conf
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0
eapol_version=1
ap_scan=1
fast_reauth=1

network={
	scan_ssid=0
	ssid="House1000"
	proto=WPA WPA2
	key_mgmt=WPA-PSK WPA-EAP
	pairwise=CCMP TKIP
	group=CCMP TKIP
	psk=*removed*
}
And for extra info:
Code:
[root@darkmoon:~] # wpa_supplicant -Dnl80211 -i wlan0 -c/etc/wpa_supplicant.conf 
Successfully initialized wpa_supplicant
wlan0: Trying to associate with 18:a3:e8:23:67:10 (SSID='House1000' freq=2442 MHz)
wlan0: CTRL-EVENT-ASSOC-REJECT status_code=16
wlan0: Trying to associate with 18:a3:e8:23:67:10 (SSID='House1000' freq=2442 MHz)
wlan0: CTRL-EVENT-ASSOC-REJECT status_code=16
wlan0: Trying to associate with 18:a3:e8:23:67:10 (SSID='House1000' freq=2442 MHz)
wlan0: CTRL-EVENT-ASSOC-REJECT status_code=16
wlan0: Trying to associate with 18:a3:e8:23:67:10 (SSID='House1000' freq=2442 MHz)
wlan0: CTRL-EVENT-ASSOC-REJECT status_code=16
wlan0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="House1000" auth_failures=1 duration=10 reason=CONN_FAILED
^Cnl80211: deinit ifname=p2p-dev-wlan0 disabled_11b_rates=0
p2p-dev-wlan0: CTRL-EVENT-TERMINATING 
nl80211: deinit ifname=wlan0 disabled_11b_rates=0
wlan0: CTRL-EVENT-TERMINATING

Last edited by slackist; 02-08-2017 at 11:14 AM. Reason: I are eejit!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound issues with slack 10.2 and onboard sound chip ricardo_ok Slackware 10 08-21-2006 01:38 PM
Onboard sound chip problem after kernel upgrade coralsaw Debian 4 06-15-2006 03:25 AM
Getting sound in slackware 9.1 with a ess 1868 onboard chip! HELP! toolfan Slackware - Installation 6 05-19-2004 07:21 PM
Need to Know Whether my Onboard Graphics Chip is an Intel i810 Huddlebum Linux - General 4 04-04-2004 11:14 AM
Audio driver for Gigabyte GA8IK1100's onboard sound chip? TMMO Linux - Newbie 1 08-10-2003 05:59 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - ARM

All times are GMT -5. The time now is 07:16 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration