LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - ARM
User Name
Password
Slackware - ARM This forum is for the discussion of Slackware ARM.

Notices


Reply
  Search this Thread
Old 02-03-2021, 11:02 AM   #1
arfon
Member
 
Registered: Apr 2004
Location: Texas
Distribution: Slackware
Posts: 215

Rep: Reputation: Disabled
RPi wifi in -current is broken - do SLARM or SARPI devs look at this forum?


I just installed -current on a RPi3. Wifi worked fine on the install kernel. After completing the install (SARPI) wifi doesn't work.

The wifi works fine with Raspbian and the SARPI (fatdog) install kernel so, it's not a hardware issue.

Kernel modules are loaded but dmesg shows:

Code:
lsmod
brcmfmac              335872  0
brcmutil               24576  1 brcmfmac
cfg80211              782336  1 brcmfmac
rfkill
Code:
dmesg | grep brcm
...noise...
[    7.969258] ieee80211 phy0: brcmf_fw_crashed: Firmware has halted or crashed
...noise...
I ran an update and everything is current. I did a re-install and got the same result.

Last edited by arfon; 02-03-2021 at 11:49 AM.
 
Old 02-03-2021, 11:42 AM   #2
rsamurti
Member
 
Registered: Dec 2003
Location: Mysore
Distribution: Mandrake, Libranet, Slackware
Posts: 135

Rep: Reputation: 17
This may help:

https://www.linuxquestions.org/quest...an-4175689292/
 
Old 02-03-2021, 03:44 PM   #3
arfon
Member
 
Registered: Apr 2004
Location: Texas
Distribution: Slackware
Posts: 215

Original Poster
Rep: Reputation: Disabled
"https://www.linuxquestions.org/quest...an-4175689292/"

I tried the fix in that thread-

Code:
/lib/firmware/brcm# rm *.*
upgradepkg --reinstall sarpi3-hacks-3.0-armv7-1_slackcurrent_28Jan21_sp1.txz
...did not fix the issue.
 
Old 02-03-2021, 04:10 PM   #4
pchristy
Member
 
Registered: Oct 2012
Location: South Devon, UK
Distribution: Slackware
Posts: 697

Rep: Reputation: Disabled
It sounds similar to the issue I had with the Pi 400. If it works with Raspbian, try replacing the /lib/firmware/brcm folder with the one from Raspbian. That brought wifi to life on my 400.

--
Pete
 
Old 02-12-2021, 09:03 PM   #5
asarangan
Member
 
Registered: Jul 2009
Posts: 49

Rep: Reputation: 7
Quote:
Originally Posted by pchristy View Post
It sounds similar to the issue I had with the Pi 400. If it works with Raspbian, try replacing the /lib/firmware/brcm folder with the one from Raspbian. That brought wifi to life on my 400.

--
Pete
My 3B also stopped working after upgrading to the -current from 14.2. I copied the contents of https://archive.raspberrypi.org/debi...3+rpt3_all.deb, untarred and copied it into /firmware/brcm folder. It worked after that.
 
Old 02-13-2021, 05:36 AM   #6
louigi600
Member
 
Registered: Dec 2013
Location: Italy
Distribution: Slackware
Posts: 619
Blog Entries: 19

Rep: Reputation: 76
I run the current kernel on 14.4 on the RPi4 ... for me the wifi works.
I did have some issues with kernel version 5.10.11 (not with wifi on my rpi4) but all seems fine with 5.10.14. Make sure you also update the SARPi hacks and SARPi boot firmware.
I see you used the 28Jan21 build which is not the latest (09Feb21) maybe you will have better luck with the latest version.
If you also need bluetoth look this post with has the soution.
Quote:
RPi wifi in -current is broken - do SLARM or SARPI devs look at this forum?
I know for sure that the SARPi maintainer is very often on this forum.

Last edited by louigi600; 02-13-2021 at 05:46 AM.
 
Old 02-16-2021, 02:32 PM   #7
enine
Senior Member
 
Registered: Nov 2003
Distribution: Slackʍɐɹǝ
Posts: 1,303
Blog Entries: 4

Rep: Reputation: 193Reputation: 193
I just installed -current from the sarpi site on my 3 and it worked fine.

Last edited by enine; 02-17-2021 at 08:29 AM.
 
Old 02-17-2021, 03:38 AM   #8
pchristy
Member
 
Registered: Oct 2012
Location: South Devon, UK
Distribution: Slackware
Posts: 697

Rep: Reputation: Disabled
I think Exaga (sarpi maintainer) did an upgrade to the "hacks" package a week or two back that sorted many of the firmware issues.

--
Pete
 
Old 02-17-2021, 04:55 AM   #9
Exaga
SARPi Maintainer
 
Registered: Nov 2012
Distribution: Slackware [ARM]
Posts: 639

Rep: Reputation: 375Reputation: 375Reputation: 375Reputation: 375
Quote:
Originally Posted by enine View Post
Wonder if its something to do with the update process?
Could you be more specific and/or elaborate please? Whatever thoughts you have about any potential problem(s), suggestions, or ideas, I'm always willing to discuss it.

Quote:
Originally Posted by pchristy View Post
I think Exaga (sarpi maintainer) did an upgrade to the "hacks" package a week or two back that sorted many of the firmware issues.
I made a change to the kernel-headers-sarpi pkg recently but not the sarpi-hacks pkg.

The latest firmware-brcm80211 from https://archive.raspberrypi.org/debi...mware-nonfree/ is what's included in the sarpi-hacks pkg. Latest package is timestamped 2021-01-25 10:27 and RPi wireless is working as expected for me with this firmware. Obviously, I can't speak for all other users but one would surmise that it should work the same way on other systems.
 
Old 02-17-2021, 08:29 AM   #10
enine
Senior Member
 
Registered: Nov 2003
Distribution: Slackʍɐɹǝ
Posts: 1,303
Blog Entries: 4

Rep: Reputation: 193Reputation: 193
Quote:
Originally Posted by Exaga View Post
Could you be more specific and/or elaborate please? Whatever thoughts you have about any potential problem(s), suggestions, or ideas, I'm always willing to discuss it.
Sorry, got the threads mixed up, I was thinking this was one where they had done an upgrade and was noting my new install works fine. Edited my post.

Last edited by enine; 02-17-2021 at 08:36 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Autoboot.txt not found upon reboot after updating slarm current on rpi4 mEllis Slackware - ARM 5 05-31-2020 09:02 AM
LXer: GNOME 3.33.2 Released, Krita 4.2 Debuts, RPi Camera Modules on RPi Zeros Power the Penguin Watch Project, Intrinsyc Switches Its Home LXer Syndicated Linux News 0 05-30-2019 06:23 AM
Funny things Java Devs have to do, but Python devs don't svetlanarosemond Programming 13 11-04-2017 11:01 AM
LXer: Mini-PC taps RPi Compute Module and supports RPi 2 LXer Syndicated Linux News 0 02-22-2015 03:03 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - ARM

All times are GMT -5. The time now is 08:37 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration