-   Slackware - ARM (
-   -   Owncloud on Raspberry Pi (

enine 01-24-2014 06:20 PM

Owncloud on Raspberry Pi
Anyone running Owncloud on Slackware on a Raspberry Pi. It seems it works as I search and see others running it but on a different distro, is there something about Slackware that makes it so slow it won't work? I would think it would be fast but I can't even log in to Admin the site.

floppy_stuttgart 01-25-2014 04:28 PM

Im running raspberry pi with raspbian as printer and scanner and data server at home. I recommend it (the installation recommendations are present in the web).

enine 01-25-2014 06:09 PM

I thought about running rasbian, just wanted to keep everything Slackware. Is there that much difference between the distros?

louigi600 01-26-2014 12:15 PM

Rasbian is tuned for ARMv6 instruction set (and will most likely only run on the PI) while Slackware ARM is compiled for ARMv5 instruction set (and runs on almost any ARM device provided you have a kernel for it).
Actually some of the older releases are compiled for ARMv4 instruction set and will run on almost every ARM junk you can find (still requires you to find a suitable kernel for your junk board).

enine 01-26-2014 06:13 PM

So not as optimized. Still it seem odd that it can't even display a simple web page without timing out, well not so simple.
I downloaded a couple owncloud already setup but broken beyond what I could fix and finally found an instructable stepping through how to install it on Rasbian. It was a lot more involved that doing it on Slackware. On my main Slackware server it was just extract and copy under Apache then edit a couple config files. Rasibian was a whole lot more steps and kept throwing errors until I gave up and went to bed then in the morning had fixed itsself somehow.
So what would be the best small hardware for Slackware. I'd prefer to keep the same distro and want something small and appliance like.

louigi600 01-27-2014 01:26 AM

I was only lent a Pi some time back and I had a Slackware ARM 14 miniroot running on it ... with just a few extra packages.
I played with it for a very short time just to checkout that all the peripherals worked as expected ... I was evaluating if it was suitable for what I want to do with it (I'm not sure if I should by a Pi or an ODROID-U3 CE ... I might end up getting both !)
I can't think of any good reason that would account for your timeout issue and I'm pretty mich sure thete the optimization differences do cannot account for such a catastrophic difference.
When you get the timeout is there any interesting information on the web server logs that could help you debug the problem ?

enine 01-27-2014 06:49 AM

I didn't dig in that far, went ahead and downloaded rasbian.
I'm trying to move owncloud off my main server to a dedicated 'appliance' that I can stick in a DMZ. I setup a basic install of Slackware-arm current without X and KDE and Games and copied Owncloud over like I did on my main server and maybe one out of 4 times it would successfully login, most times it would time out on the redirect. I probably won't use the web interface that much, its basically going to be for syncing to my mobile devices but I could barely use the admin page to create accounts. I have an old MiniITX board lying around I could use but liked the idea of a tiny Raspberry Pi like box.

enine 02-03-2014 04:29 PM

Ok, I'm trying this again. Did a clean install of Slackware Arm-Current, updated and extracted ownCloud and a very basic install is working. I did a more complete install this time only leaving off KDE and games, before I tried to leave off X and kernel, etc and found i had to go back and install different packages when stuff was missing.

enine 02-05-2014 07:43 AM

Ok, I'm marking as solved. It is working now, a little slow but working. I tried a very minimal install before, left off X, K, etc. I had to install some packages that PHP needed but it appeared to work but apparently I was missing something else because this more complete install is working.

Its still a little slow, now sure if it will meet the WAF so I may still need more hardware in the future.

All times are GMT -5. The time now is 06:56 PM.