LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - ARM
User Name
Password
Slackware - ARM This forum is for the discussion of Slackware ARM.

Notices


Reply
  Search this Thread
Old 07-18-2015, 11:36 AM   #1
Altiris
Member
 
Registered: Mar 2013
Posts: 556

Rep: Reputation: Disabled
NTP isn't working (details)


I am on RPI2, 14.1, I can not get ntpd to work. I chmodded it, I added "/etc/rc.d/rc.ntpd start &" in my rc.local and my /etc/ntp.conf file looks like this

Code:
server 127.127.1.0
fudge 127.127.1.0

server pool.ntp.org iburst
server us.pool.ntp.org iburst

driftfile /etc/ntp/drift
logfile /var/log/ntp.log

restrict default noquery nomodify
restrict 127.0.0.1
When I do /etc/rc.d/rc.ntpd status I get "ntpd is running". However if I change status with stop I get "Stopping NTP Daemon line 31:kill (785) - No such process"

I tell it to start again and run "ntpdate -d timeserver" and I get

Code:
18 July 11:34:23 ntpdate 4.2.6p5@1.2349-o Wed Oct 16 12:03:52 UTC 2013 (1)
Looking for host timeserver and service ntp
Error resolving timeserver: Name or service not known (-2)
 
Old 07-18-2015, 04:58 PM   #2
drmozes
Slackware Contributor
 
Registered: Apr 2008
Location: Surrey, England
Distribution: Slackware
Posts: 717

Rep: Reputation: 554Reputation: 554Reputation: 554Reputation: 554Reputation: 554Reputation: 554
Quote:
Originally Posted by Altiris View Post
Code:
18 July 11:34:23 ntp
Error resolving timeserver: Name or service not known (-2)
Do you have working DNS? That message implies not.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
NTP just partialy working Thunderw Linux - Server 4 08-15-2013 10:34 AM
NTP synchronisation not working jonaskellens Linux - Newbie 6 10-29-2009 07:32 AM
ntp drift file in /etc/ntp instead of /var/lib/ntp - suggestion for a patch in Slack niels.horn Slackware 16 05-07-2009 08:35 PM
working details of loopback devices vivek_110477 Linux - Newbie 2 12-13-2007 12:28 AM
ntp -- is it working? synaptical Linux - Software 4 08-23-2004 04:50 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware > Slackware - ARM

All times are GMT -5. The time now is 12:43 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration