LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Slackware - ARM (https://www.linuxquestions.org/questions/slackware-arm-108/)
-   -   LXDE (https://www.linuxquestions.org/questions/slackware-arm-108/lxde-4175640120/)

interndan 10-10-2018 04:46 PM

LXDE
 
Does anyone have a working LXDE on SARPI installation of Slackwarearm 14.2? I had it working on any earlier install. IIRC I used Ponce's packages from his 14.0 tree. I haven't been able to get it working since I upgrade to 14.2. I have version 1b of Raspberry Pi.

interndan 10-21-2018 02:10 PM

I take it from the lack of response, that either no one else likes LXDE or there are no Slackwarearm 14.2 packages available. (or both)

So here is where I am to date:
Downloaded and installed the packages from Ponce's Slackwarearm-current tree. LXDE failed to start with LXsession errors. So I uninstalled all of those packages.

Next I downloaded and installed the packages from Ponce's Slackwarearm 14.0 tree. In this case, LXDE starts and seems to run ok until time to logout. LXsession-logout gives an error that libpng14.so.14 can't be found. I have been unable to locate that file or where to install it if I should find it. Cntrl+alt+backspace will kick me out of the x session and back to the log in screen.

mralk3 10-21-2018 10:39 PM

I do not use LXDE. However, you have to run packages built for slackware 14.2. Packages built for another release, or for slackware-current will not run correctly due to being compiled against a different set of system libraries. I suggest you take the SlackBuilds for lxde and build your own packages for 14.2.

Lysander666 10-22-2018 01:45 PM

I use 32bit LXDE from ponce, but it's not on a Raspberry Pi so I don't know if I can be of much help. I used the packages from here. I found the libpng14 package you're looking for at pkgs.org - OK it's pkgs.org but it links to another server, that at slackware.cs.utah.edu.

stormtracknole 10-23-2018 08:39 AM

Quote:

Originally Posted by interndan (Post 5913389)
Does anyone have a working LXDE on SARPI installation of Slackwarearm 14.2? I had it working on any earlier install. IIRC I used Ponce's packages from his 14.0 tree. I haven't been able to get it working since I upgrade to 14.2. I have version 1b of Raspberry Pi.

I use LXDE on my raspberry pi, but on -current. If you make the jump to -current, let me know I can make these packages available to you. Remember that 14.2 is soft float and -current is hard float. So, you can't install -current packages on the stable branch. All my pi's and arm devices run -current so I can't build any soft float packages.

interndan 10-23-2018 10:53 AM

@MRLK3 I have found over the years that I'm not very good or successful at modifying prebuilt Slackbuilds for whatever I was trying to accomplish . I always miss something and they don't work. That is one reason I have always used Ponce's packages since I discovered them. I have used sbopkg quite successfully, but Ponce's packages are well built it is just simpler/faster to download and install his prebuit packages. Any problems I have incurred were due to my ignorance, not his well built packages.

@Lysander666 I have used Ponce's packages on both 32 bit and 64 bit systems since at least 13.37. I took a look at the links you posted and question whether packages built for Slackware will work on Slackwarearm. I did notice, however that the link pointed to Slackware 14.1, so I perused the Slackwarearm site and noticed that between Slackwarearm 14.1 and Slackwarearm 14.2 that libpng was upgraded to libpng1.6.xx.

I then downloaded libpng-1.4.xx from the Slackwarearm 14.1 tree and downgraded my system with it. LXDE is now working as I expected. Downgrading to libpng-1.4.xx may induce other problems, but so far I haven't ran across any. I'll report back if I run across any problems.

Thanks to both of you for your suggestions.

interndan 10-23-2018 10:58 AM

@stormtracknole I have the Raspberry PI version 1b. I don't think -current will run on it. At least that is what I understood from SARPI instructions.

interndan 10-23-2018 12:49 PM

Well, that was quick. While LXDE itself seems to work, the downgrade broke some of the KDE apps. While I haven't used KDE as a desktop since version 3.4, I do still use some KDE apps. So, back to the drawing board.

stormtracknole 10-23-2018 12:55 PM

Quote:

Originally Posted by interndan (Post 5918350)
@stormtracknole I have the Raspberry PI version 1b. I don't think -current will run on it. At least that is what I understood from SARPI instructions.

The cpu may not support that type of instruction maybe? Anyhow, I wish I could be of more help. I have (in my opinion) that the soft float version is a bit slower.

interndan 10-25-2018 05:22 PM

I haven't been able to get a completely satisfactory solution to this so I think I'll mark this thread as solved and move on to something different for my Raspberry. But, that will be for another thread. Thanks for the suggestions though.


All times are GMT -5. The time now is 12:37 PM.